OVH Community, votre nouvel espace communautaire.

POSTFIX : Received: from localhost.localdomain


Didier Misson
12/09/2016, 01h36
Citation Envoyé par boris44
Bonsoir,

que contient ce fichier /etc/mailname

met y ton nom de domaine => domaine.fr

et décommentes la ligne :
myorigin = /etc/mailname

A+
Bonjour.

Il n'y a pas de fichier /etc/mailname.
Ce n'est pas utilisé par toutes les distributions.

Mais de toute façon, ça fonctionne quand on a UN domaine email.
Ici j'en ai plein... donc, si je force un "domaine.fr" , ça n'ira pas pour les autres.

Je suis sur la bonne piste.
Je posterai la config quand j'aurai tout résolu.

Merci

boris44
12/09/2016, 01h00
Bonsoir,

que contient ce fichier /etc/mailname

met y ton nom de domaine => domaine.fr

et décommentes la ligne :
myorigin = /etc/mailname

A+

Didier Misson
06/09/2016, 22h45
Bonsoir Nowwhat

Citation Envoyé par Nowwhat
Ceci est spécial :
Code:
test-domaine_fr unix  -       -       n       -       -       smtp
   -o smtp_bind_address6=2001:41d0:2:927b::15
   -o smtp_bind_address=5.196.43.182
   -o smtp_helo_name=mail.test-domaine.fr
   -o syslog_name=test-domaine.fr-transport
   -o smtp_tls_CAfile=/root/startssl/sub.class1.server.ca.pem
   -o smtp_tls_security_level=may
C'est la - en semble avec
sender_dependent_default_transport_maps = mysql:/etc/postfix/mysql-sdd_transport_maps.cf
(dans /etc/postfix/main.cf)
Je décodé le nom de domaine 'émetteur' - ici "test-domaine.fr" (un des mes domaines / URL's) vers quelque chose que je puisse utiliser dans master.cf (le "test-domaine_fr" au lieu de "test-domaine.fr" qui contient un point et ça va pas.) pour qu'il sélectionne le bon IPv4 et IPv6,; le nom (mail host) qu'il annonce au serveur en face, un prefixe pour le log, le bon certificat qui dit qu'il est "mail.test-domaine.fr)
Je n'ai pas lié Postfix à MySQL.
Je ferai un nouveau conteneur Proxmox avec une install propre, avec Postfix / MySQL, Amavis-new, etc

Qu'est-ce que la ligne
Code:
   -o smtp_tls_CAfile=/root/startssl/sub.class1.server.ca.pem
C'est le certificat du serveur lui-même ?

ça correspond à quoi ?
Pour le moment, je n'ai que les lignes avec le certificat Let's Encrypt du domaine dans les définitions pour smtp et submission :

Code:
 # submission IPv4 : 587
123.123.123.69:submission      inet    n       -       -       -       -       smtpd
  -o myhostname=mail.mondomaine.be
  -o smtp_helo_name=mail.mondomaine.be
  -o syslog_name=mondomaine.be-submission-ipv4
  -o smtpd_tls_cert_file=/etc/letsencrypt/live/mondomaine.be/fullchain.pem
  -o smtpd_tls_key_file=/etc/letsencrypt/live/mondomaine.be/privkey.pem
  -o smtpd_tls_CApath=/etc/ssl/certs
  -o smtpd_tls_security_level=may
  -o smtpd_tls_auth_only=no
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o content_filter=amavis:[127.0.0.1]:10026
#  -o milter_macro_daemon_name=ORIGINATING
J'ai mis en commentaire la ligne "amavis" car je ne l'ai pas encore installé.

A quoi sert la ligne "milter_macro_daemon_name" ?

Merci

Didier Misson
06/09/2016, 00h48
Citation Envoyé par Nowwhat
Règle d'or : on poste TOUT les entêtes sans exception - pas que ceux qui TE semble pas bon - car, si t'as pas compris, t'as zappé les indices qui peuvent nous dire ce qui se passe, et tu nous donne ce qui n'est pas faux ... résultat assuré : on va tous tourner en rond
Ok, je poste mes configs, en changeant juste le domaine et IPs

Je sais qu'il y a des erreurs !
Je n'ai pas encore modifié en tenant compte des exemples que tu me donnes...
(je suis crevé d'avoir passé tout le WE sur site web, Postfix, etc.... faut dormir parfois)


123.123.123.68 = ct1234.misson.ovh
123.123.123.69 = domaine.be = smtp.domaine.be


Les reverses sont OK.

évidemment, je compte ajouter d'autres domaines.


Master.cf :

Code:
123.123.123.69:smtp      inet    n       -       y       -       -       smtpd
#smtp      inet  n       -       y       -       1       postscreen
#smtpd     pass  -       -       y       -       -       smtpd
#dnsblog   unix  -       -       y       -       0       dnsblog
#tlsproxy  unix  -       -       y       -       0       tlsproxy
submission inet n       -       y       -       -       smtpd
# ne fonctionne pas   -o smtpd_mydomain=mondomaine.be
#  -o syslog_name=postfix/submission
#  -o smtpd_tls_security_level=encrypt
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_reject_unlisted_recipient=no
#  -o smtpd_client_restrictions=$mua_client_restrictions
#  -o smtpd_helo_restrictions=$mua_helo_restrictions
#  -o smtpd_sender_restrictions=$mua_sender_restrictions
#  -o smtpd_recipient_restrictions=
#  -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
#smtps     inet  n       -       y       -       -       smtpd
#  -o syslog_name=postfix/smtps
#  -o smtpd_tls_wrappermode=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_reject_unlisted_recipient=no
#  -o smtpd_client_restrictions=$mua_client_restrictions
#  -o smtpd_helo_restrictions=$mua_helo_restrictions
#  -o smtpd_sender_restrictions=$mua_sender_restrictions
#  -o smtpd_recipient_restrictions=
#  -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
#628       inet  n       -       y       -       -       qmqpd
pickup    unix  n       -       y       60      1       pickup
cleanup   unix  n       -       y       -       0       cleanup
...

123.123.123.69:smtp      inet    n       -       y       -       -       smtpd -o smtpd_tls_cert_file=/home/mondomaine/ssl.cert -o smtpd_tls_key_file=/home/mondomaine/ssl.key
127.0.0.1:smtp  inet    n       -       y       -       -       smtpd
smtp-14692394186666     unix    -       -       y       -       -       smtp -o smtp_bind_address=123.123.123.69

main.cf :


Code:
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# Didier MISSON 20160904
smtpd_tls_security_level = may
smtp_tls_security_level = may
smtp_tls_loglevel = 1
smtpd_tls_loglevel = 1

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
# myhostname = localhost.localdomain
# myhostname = smtp.$mydomain
myhostname = ct1234.misson.ovh
# myhostname = smtp.mondomaine.be
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = $myhostname, localdomain, localhost, localhost.localdomain, localhost
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
virtual_alias_maps = hash:/etc/postfix/virtual

# Didier MISSON 20160627
# Sender Dependent Outgoing IP address

sender_dependent_default_transport_maps = hash:/etc/postfix/dependent
dependent :

Code:
@mondomaine.be    smtp-14692394186666
Entête email Drupal --> gmail :

Code:
Delivered-To: didier.misson@gmail.com
Received: by 10.80.171.230 with SMTP id u93csp269746edc;
        Sun, 4 Sep 2016 02:24:57 -0700 (PDT)
X-Received: by 10.28.26.72 with SMTP id a69mr3220827wma.8.1472981097903;
        Sun, 04 Sep 2016 02:24:57 -0700 (PDT)
Return-Path: 
Received: from ct1234.misson.ovh ([123.123.123.69])
        by mx.google.com with ESMTPS id ia7si6379910wjb.123.2016.09.04.02.24.57
        (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Sun, 04 Sep 2016 02:24:57 -0700 (PDT)
Received-SPF: pass (google.com: domain of info@mondomaine.be designates 123.123.123.69 as permitted sender) client-ip=123.123.123.69;
Authentication-Results: mx.google.com;
       spf=pass (google.com: domain of info@mondomaine.be designates 123.123.123.69 as permitted sender) smtp.mailfrom=info@mondomaine.be
Received: by localhost.localdomain (Postfix, from userid 33)
	id B335C77A245; Sun,  4 Sep 2016 11:24:27 +0200 (CEST)
To: info@mondomaine.be, didier.misson@gmail.com
Subject: [Retours utilisateurs sur le site web] test dimanche 2
X-PHP-Originating-Script: 33:PhpMail.php
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8; format=flowed; delsp=yes
Content-Transfer-Encoding: 8Bit
X-Mailer: Drupal
Sender: info@mondomaine.be
From: mondomaine.be 
Reply-to: marc@misson.net
Message-Id: <20160904092427.B335C77A245@ct1234.misson.ovh>
Date: Sun,  4 Sep 2016 11:24:27 +0200 (CEST)

Marc Misson (non vérifié) (marc@misson.net) a envoyé un message en
utilisant le formulaire de contact à l'adresse https://mondomaine.be/contact.

Le nom de l'expéditeur
                 Marc



       Le courriel de l'expéditeur
                 marc@misson.net



       Sujet
                 test dimanche 2


         Message
           Hello
encore moi
il fait beau
Didier
Merci.
Didier

Didier Misson
06/09/2016, 00h21
Bonsoir
Citation Envoyé par Nowwhat
Pourquoi ?
Si ton serveur s'appelle "tweetie", ça va déranger personne.
ça pourrait...
juste que je trouvais utile / sympa / intelligent (barrer les mentions inutiles) d'avoir un nom smtp.mondomaine.be pour chaque domaine.

Le point intéressant, c'est que si un site spam (ça m'est arrivé), comme chaque smtp.mondomaine.be aurait eu sa propre IP, OVH n'aurait bloqué qu'une seule IP, un seul site...idem si l' IP se retrouve en black list.

Bon, ça me semblait idéal...
si pas possible, ou si pas une bonne idée... tant pis.

Citation Envoyé par Nowwhat
Bonne nouvelle.
J'ai, comme toi, plusieurs nom de domaines et autant des IPv4 / IPv6.
J'ai fait des tests IPv6.
Je voudrais bien pousser ça ...

mais ce qui me dérange, c'est qu'en IPv4, je peux basculer des blocs IPv4 dans le manageur OVH d'un serveur à l'autre.
ça permet de rétablir le serveur, les sites, en cas de panne d'un serveur ou de réinstall / upgrade, sans devoir attente le délais de propagation d'une modif IP dans le DNS...

Pas encore vu comment basculer un bloc IPv6 d'un dédié OVH à un autre...


Citation Envoyé par Nowwhat
J'utilise le system "virtual host" de postfix (va voir plus bas)

Pour simplifier les explications j'ai posté toutes les entêtes d'un mail reçu chez gmail :

Code:
Delivered-To: mon-gmail@gmail.com
Received: by 10.107.32.133 with SMTP id g127csp2616691iog;
        Sun, 4 Sep 2016 22:26:01 -0700 (PDT)
X-Received: by 10.194.149.113 with SMTP id tz17mr28752900wjb.64.1473053161791;
        Sun, 04 Sep 2016 22:26:01 -0700 (PDT)
Return-Path: 
Received: from mail.test-domaine.fr (mail.test-domaine.fr. [2001:41d0:2:927b::15])
        by mx.google.com with ESMTPS id x8si15806187wme.6.2016.09.04.22.26.01
        for 
        (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Sun, 04 Sep 2016 22:26:01 -0700 (PDT)
Received-SPF: pass (google.com: domain of postmaster@test-domaine.fr designates 2001:41d0:2:927b::15 as permitted sender) client-ip=2001:41d0:2:927b::15;
Authentication-Results: mx.google.com;
       dkim=pass header.i=@test-domaine.fr;
       spf=pass (google.com: domain of postmaster@test-domaine.fr designates 2001:41d0:2:927b::15 as permitted sender) smtp.mailfrom=postmaster@test-domaine.fr;
       dmarc=pass (p=REJECT dis=NONE) header.from=test-domaine.fr
Received: from localhost (localhost.localdomain [127.0.0.1])
	by ns311465.ip-188-165-201.eu (Postfix) with ESMTP id 8A7B563E1161
	for ; Mon,  5 Sep 2016 07:26:00 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at ns311465.ip-188-165-201.eu
Received: from ns311465.ip-188-165-201.eu ([127.0.0.1])
	by localhost (mail.brit-hotel-fumel.fr [127.0.0.1]) (amavisd-new, port 10026)
	with ESMTP id njxVFIa3775k for ;
	Mon,  5 Sep 2016 07:26:00 +0200 (CEST)
Received: from www.test-domaine.fr (localhost.localdomain [127.0.0.1])
	by ns311465.ip-188-165-201.eu (Postfix) with ESMTP id 2C48D63E1687
	for ; Mon,  5 Sep 2016 07:26:00 +0200 (CEST)
Received: from 2001:470:1f13:5c0:2::c6
        (SquirrelMail authenticated user postmaster@test-domaine.fr)
        by www.test-domaine.fr with HTTP;
        Mon, 5 Sep 2016 07:26:00 +0200
Message-ID: 
Date: Mon, 5 Sep 2016 07:26:00 +0200
Subject: tet mail
From: postmaster@test-domaine.fr
To: mon-gmail@gmail.com
User-Agent: SquirrelMail/1.4.23 [SVN]
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=test-domaine.fr;
	s=default; t=1473053160;
	bh=/t7V7d2aqZ/jpgluSJ0TCtZJ4yHQhR4n37KV2CO2JnI=;
	h=Date:Subject:From:To:Sender;
	b=c1hNSGOtzZEbxDyjaX/fE6kiYBISEWNDqd5XphzWXgctNVQj7/LU2SpF/K1tsgZT3
	 5MuehPU8F1P8st7cqXRRZxrvqIpuJCqdEcP3BwTu0/1n1BxmJErPDhslTJbol/OBRu
	 6aWNPiz4GIcmg/zmHsdyz4rrUBuExfoXhwVB8fmw=
T'as vu le

Il faut commencer à lire à partir de là, vers le haut.


[ Règle d'or : on poste TOUT les entêtes sans exception - pas que ceux qui TE semble pas bon - car, si t'as pas compris, t'as zappé les indices qui peuvent nous dire ce qui se passe, et tu nous donne ce qui n'est pas faux ... résultat assuré : on va tous tourner en rond ]
Tu as raison !
Je lis, et je posterai en détail toutes les entensuite.

- j'ai aussi un SPF=pass
- je n'ai PAS encore creusé pour le DKIM
- dmarc non plus...

Tu as aussi certainement raison : je n'ai pas pris le temps de comprendre les Virtual Host Postfix.

En pratique, je configure avec Webmin / Virtualmin ...
Mais pas de problème en VI... juste que je n'ai pas eu le temps de tout creuser.


Citation Envoyé par Nowwhat
Mon mail est donc posté par le CMS "squirrelmail" utilisant l'URL www.test-domaine.fr.

Puis, Squirrelmail injecte je mail dans le queue de postfix : localhost.localdomain [127.0.0.1], mon serveur nommé "ns311465.ip-188-165-201.eu" a bien reçu un mail pour destination mon-gmail@gmail.com

T'as vu mon serveur se nomme "ns311465.ip-188-165-201.eu" - un nom choisi par OVH - je n'ai pas retenu "tweetie" ....
( J'ai d'ailleurs jamais vu nie changé ce fichier /etc/hosts )
Ok, ici ça vient de Drupal.
c'est équivalent à Squirrelmail (ou Roundcube) : ça vient du serveur Web.

Je ne modifie pas non plus le /etc/hosts

C'est créé par Proxmox quand je configure les conteneurs virtuels.


Citation Envoyé par Nowwhat
Puis, localement, la service "amavisd-new", sur la porte 10026 a reçu mon mail pour des traitements ....
Entre autre pour ceci 'X-Virus-Scanned"
Je devrai ajouter Amavisd-new...
J'ai dû configurer tout ça en vitesse.
Pas eu le temps de tout tester comme je faisais en général

Citation Envoyé par Nowwhat
Puis, de retour chez postfix :

(et tu pense qu'il s'agit d'un erreur ??
Mais non, le mail est toujours sur MON serveur)
Logique
C'est bien ton serveur qui fait anti-virus et anti-spam.

donc, ici, je devrais avoir un "Receive from localhost ... by ct1234.misson.ovh" = le hostname de mon conteneur Virtuel Proxmox.


Citation Envoyé par Nowwhat
Les entêtes : Received-SPF et Authentication-Results : injecté par gmail - on le traite à part.

le dernier - et sache : CE entête a été ajouté par gmail, les autres, plus bas, sont de mon propre serveur postfix :
Code:
Received: from mail.test-domaine.fr (mail.test-domaine.fr. [2001:41d0:2:927b::15])
        by mx.google.com with ESMTPS id x8si15806187wme.6.2016.09.04.22.26.01
        for 
        (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Sun, 04 Sep 2016 22:26:01 -0700 (PDT)
gmail a reçu un mail de l'IPv6 2001:41d0:2:927b::15
Le reverse DNS, comme le IPv4, est ok et c'est mail.test-domaine.fr - ce qui tombe bien, car mail.test-domaine.fr pointe justement (aprèzs vérification DNS) vers 2001:41d0:2:927b::15 et 5.196.43.182.
Mon mail est recu crypte par TLS (touit une affaire des certificats etc - un monde a part)
Plus de problème avec TLS et certificat Let's Encrypt.


J'ai généré un certificat valide pour :

- monsite.be
- www.monsite.be
- smtp.monsite.be

Donc, j'ai mis le même certificat pour Postfix que pour le site web https.

Pour le renouvellement du CA par L.E., ça fonctionne car Postfix et Apache2 sont sur le même serveur.

Citation Envoyé par Nowwhat
Gmail, bien sur, ne pourait JAM%AIS recevoir mon mail de localhost.localdomain [127.0.0.1] - il faut que ce soit mon IPv4 (au moins) et au mieux :
Received: from mail.test-domaine.fr (mail.test-domaine.fr. [2001:41d0:2:927b::15])
or : ce que mon serveur à annoncé pendant le transfert de mon mail (HELO mail.test-domaine.fr)
c'est ça que j'ai loupé...

Citation Envoyé par Nowwhat
Ceci :
Code:
Received-SPF: pass (google.com: domain of postmaster@test-domaine.fr designates 2001:41d0:2:927b::15 as permitted sender) client-ip=2001:41d0:2:927b::15;
Authentication-Results: mx.google.com;
       dkim=pass header.i=@test-domaine.fr;
       spf=pass (google.com: domain of postmaster@test-domaine.fr designates 2001:41d0:2:927b::15 as permitted sender);
       dmarc=pass (p=REJECT dis=NONE) header.from=test-domaine.fr
indique que des divers tests ont été exécute, et ils sont tous Ok:
SPF
DKIM
DMARC


A savoir : mon /etc/master.cf :
la partie réception IPv6 :
Code:
[2001:41d0:2:927b::15]:smtp      inet    n       -       -       -       -       smtpd
  -o myhostname=mail.test-domaine.fr
  -o smtp_helo_name=test-domaine.fr
  -o syslog_name=test-domaine.fr-smtp-client-ipv6
  -o smtpd_tls_cert_file=/root/startssl/test-domaine.fr/ssl.crt
  -o smtpd_tls_key_file=/root/startssl/test-domaine.fr/ssl-decrypted.key
  -o smtpd_tls_CApath=/etc/ssl/certs
  -o smtpd_tls_security_level=may
  -o smtpd_tls_received_header=yes
  -o smtpd_sasl_auth_enable=no
T'as du voir la solution concernant ton "myhostname"
oui !

Mais tu dois écrire ça à la main pour chaque domaine ?

J'espère que Virtualmin peut me faire ça.
c'est juste par gain de temps et par uniformisation
sinon je le ferai en VI.


Citation Envoyé par Nowwhat
Réception IPv4 :
Code:
5.196.43.182:smtp      inet    n       -       -       -       -       smtpd
  -o myhostname=mail.test-domaine.fr
  -o smtp_helo_name=mail.test-domaine.fr
  -o syslog_name=test-domaine.fr-smtp-client-ipv4
  -o smtpd_tls_cert_file=/root/startssl/test-domaine.fr/ssl.crt
  -o smtpd_tls_key_file=/root/startssl/test-domaine.fr/ssl-decrypted.key
  -o smtpd_tls_CApath=/etc/ssl/certs
  -o smtpd_tls_security_level=may
  -o smtpd_tls_received_header=yes
  -o smtpd_sasl_auth_enable=no
Submission IPv4:
Code:
5.196.43.182:submission      inet    n       -       -       -       -       smtpd
  -o myhostname=mail.test-domaine.fr
  -o smtp_helo_name=mail.test-domaine.fr
  -o smtpd_tls_security_level=may
  -o smtpd_tls_auth_only=no
  -o smtpd_tls_cert_file=/root/startssl/test-domaine.fr/ssl.crt
  -o smtpd_tls_key_file=/root/startssl/test-domaine.fr/ssl-decrypted.key
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
  -o content_filter=amavis:[127.0.0.1]:10026
  -o milter_macro_daemon_name=ORIGINATING
  -o syslog_name=test-domaine.fr-submission
  -o smtpd_tls_CApath=/etc/ssl/certs
Puis, t'as compris, la même existe pour IPv6 ....
Et il existe aussi un pair de IPv4 et IPv6 concernant la réception SMTPS (porte 465)
oui, IPv4 ou IPv6 ... c'est juste la façon de noter l' IP qui change.

Par contre, je devrai regarder comment attribuer des IPv6 à mes conteneurs Proxmox
mais c'est possible !
Dans le futur, car pour le moment, mettre mes serveurs en IPv6 n'est pas urgent.

ah oui !

Il faut un bloc
IPv4:smtp et IPv6:smtp pour envoyer si le serveur mail de destination n'accepte pas le chiffrement

+ un bloc
IPv4:submission et IPv6:submission pour envoi avec chiffrement ... par site !

Finalement... c'est logique.

Moi, Virtualmin m'a ajouté un bloc à la fin du fichier master.cf

178.32.162...:smtp avec les certificats pour mon site
mais rien pour submission !

Le mail est malgré tout parti chiffré car j'ai une ligne "submission" sans restriction d' IP.


Je vais reposter mes conf et entêtes.

Citation Envoyé par Nowwhat
Ceci est spécial :
Code:
test-domaine_fr unix  -       -       n       -       -       smtp
   -o smtp_bind_address6=2001:41d0:2:927b::15
   -o smtp_bind_address=5.196.43.182
   -o smtp_helo_name=mail.test-domaine.fr
   -o syslog_name=test-domaine.fr-transport
   -o smtp_tls_CAfile=/root/startssl/sub.class1.server.ca.pem
   -o smtp_tls_security_level=may
C'est la - en semble avec
sender_dependent_default_transport_maps = mysql:/etc/postfix/mysql-sdd_transport_maps.cf
(dans /etc/postfix/main.cf)
Je décodé le nom de domaine 'émetteur' - ici "test-domaine.fr" (un des mes domaines / URL's) vers quelque chose que je puisse utiliser dans master.cf (le "test-domaine_fr" au lieu de "test-domaine.fr" qui contient un point et ça va pas.) pour qu'il sélectionne le bon IPv4 et IPv6,; le nom (mail host) qu'il annonce au serveur en face, un prefixe pour le log, le bon certificat qui dit qu'il est "mail.test-domaine.fr)




Mon /etc/postfix/main.cf est relativement petit (130 linges) , et ce "myhostname", je ne le déclare même pas.
Mon master.cf est bien plus grand .... car la, je traite par domaine, pour IPv4 puis IPv6 comme envoyer et recevoir mes mails.
Je vais relire tout ça, et poster mes configs !
Mais clairement, j'ai été trop vite en bricolant sans avoir tout compris !

La création des Virtual Hosts Postfix, par domaine, ça se résume à ajouter ces 2 ou 4 blocs de lignes (suivant qu'on utilise aussi IPv6 ou pas) dans Master.cf ?

Merci pour les expli

Didier Misson
05/09/2016, 18h05
Merci Nowwhat pour ces explis !

Je vois ça en détail ce soir.

Nowwhat
05/09/2016, 08h15
Citation Envoyé par Didier Misson
....
ce que je voudrais, c'est : myhostname = smtp.$mydomain
.....
Pourquoi ?
Si ton serveur s'appelle "tweetie", ça va déranger personne.

Citation Envoyé par Didier Misson
....
avec $mydomain qui prenne automatiquement la valeur correspondante aux domaines dont les mails sont envoyés.
Bonne nouvelle.
J'ai, comme toi, plusieurs nom de domaines et autant des IPv4 / IPv6.

J'utilise le system "virtual host" de postfix (va voir plus bas)

Pour simplifier les explications j'ai posté toutes les entêtes d'un mail reçu chez gmail :

Code:
Delivered-To: mon-gmail@gmail.com
Received: by 10.107.32.133 with SMTP id g127csp2616691iog;
        Sun, 4 Sep 2016 22:26:01 -0700 (PDT)
X-Received: by 10.194.149.113 with SMTP id tz17mr28752900wjb.64.1473053161791;
        Sun, 04 Sep 2016 22:26:01 -0700 (PDT)
Return-Path: 
Received: from mail.test-domaine.fr (mail.test-domaine.fr. [2001:41d0:2:927b::15])
        by mx.google.com with ESMTPS id x8si15806187wme.6.2016.09.04.22.26.01
        for 
        (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Sun, 04 Sep 2016 22:26:01 -0700 (PDT)
Received-SPF: pass (google.com: domain of postmaster@test-domaine.fr designates 2001:41d0:2:927b::15 as permitted sender) client-ip=2001:41d0:2:927b::15;
Authentication-Results: mx.google.com;
       dkim=pass header.i=@test-domaine.fr;
       spf=pass (google.com: domain of postmaster@test-domaine.fr designates 2001:41d0:2:927b::15 as permitted sender) smtp.mailfrom=postmaster@test-domaine.fr;
       dmarc=pass (p=REJECT dis=NONE) header.from=test-domaine.fr
Received: from localhost (localhost.localdomain [127.0.0.1])
	by ns311465.ip-188-165-201.eu (Postfix) with ESMTP id 8A7B563E1161
	for ; Mon,  5 Sep 2016 07:26:00 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at ns311465.ip-188-165-201.eu
Received: from ns311465.ip-188-165-201.eu ([127.0.0.1])
	by localhost (mail.brit-hotel-fumel.fr [127.0.0.1]) (amavisd-new, port 10026)
	with ESMTP id njxVFIa3775k for ;
	Mon,  5 Sep 2016 07:26:00 +0200 (CEST)
Received: from www.test-domaine.fr (localhost.localdomain [127.0.0.1])
	by ns311465.ip-188-165-201.eu (Postfix) with ESMTP id 2C48D63E1687
	for ; Mon,  5 Sep 2016 07:26:00 +0200 (CEST)
Received: from 2001:470:1f13:5c0:2::c6
        (SquirrelMail authenticated user postmaster@test-domaine.fr)
        by www.test-domaine.fr with HTTP;
        Mon, 5 Sep 2016 07:26:00 +0200
Message-ID: 
Date: Mon, 5 Sep 2016 07:26:00 +0200
Subject: tet mail
From: postmaster@test-domaine.fr
To: mon-gmail@gmail.com
User-Agent: SquirrelMail/1.4.23 [SVN]
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=test-domaine.fr;
	s=default; t=1473053160;
	bh=/t7V7d2aqZ/jpgluSJ0TCtZJ4yHQhR4n37KV2CO2JnI=;
	h=Date:Subject:From:To:Sender;
	b=c1hNSGOtzZEbxDyjaX/fE6kiYBISEWNDqd5XphzWXgctNVQj7/LU2SpF/K1tsgZT3
	 5MuehPU8F1P8st7cqXRRZxrvqIpuJCqdEcP3BwTu0/1n1BxmJErPDhslTJbol/OBRu
	 6aWNPiz4GIcmg/zmHsdyz4rrUBuExfoXhwVB8fmw=
T'as vu le
Message-ID:
Il faut commencer à lire à partir de là, vers le haut.


[ Règle d'or : on poste TOUT les entêtes sans exception - pas que ceux qui TE semble pas bon - car, si t'as pas compris, t'as zappé les indices qui peuvent nous dire ce qui se passe, et tu nous donne ce qui n'est pas faux ... résultat assuré : on va tous tourner en rond ]

Mon mail est donc posté par le CMS "squirrelmail" utilisant l'URL www.test-domaine.fr.

Puis, Squirrelmail injecte je mail dans le queue de postfix : localhost.localdomain [127.0.0.1], mon serveur nommé "ns311465.ip-188-165-201.eu" a bien reçu un mail pour destination mon-gmail@gmail.com

T'as vu mon serveur se nomme "ns311465.ip-188-165-201.eu" - un nom choisi par OVH - je n'ai pas retenu "tweetie" ....
( J'ai d'ailleurs jamais vu nie changé ce fichier /etc/hosts )

Puis, localement, la service "amavisd-new", sur la porte 10026 a reçu mon mail pour des traitements ....
Entre autre pour ceci 'X-Virus-Scanned"

Puis, de retour chez postfix :
Received: from localhost (localhost.localdomain [127.0.0.1])
(et tu pense qu'il s'agit d'un erreur ??
Mais non, le mail est toujours sur MON serveur)

Les entêtes : Received-SPF et Authentication-Results : injecté par gmail - on le traite à part.

le dernier - et sache : CE entête a été ajouté par gmail, les autres, plus bas, sont de mon propre serveur postfix :
Code:
Received: from mail.test-domaine.fr (mail.test-domaine.fr. [2001:41d0:2:927b::15])
        by mx.google.com with ESMTPS id x8si15806187wme.6.2016.09.04.22.26.01
        for 
        (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Sun, 04 Sep 2016 22:26:01 -0700 (PDT)
gmail a reçu un mail de l'IPv6 2001:41d0:2:927b::15
Le reverse DNS, comme le IPv4, est ok et c'est mail.test-domaine.fr - ce qui tombe bien, car mail.test-domaine.fr pointe justement (aprèzs vérification DNS) vers 2001:41d0:2:927b::15 et 5.196.43.182.
Mon mail est recu crypte par TLS (touit une affaire des certificats etc - un monde a part)

Gmail, bien sur, ne pourait JAM%AIS recevoir mon mail de localhost.localdomain [127.0.0.1] - il faut que ce soit mon IPv4 (au moins) et au mieux :
Received: from mail.test-domaine.fr (mail.test-domaine.fr. [2001:41d0:2:927b::15])
or : ce que mon serveur à annoncé pendant le transfert de mon mail (HELO mail.test-domaine.fr)

Ceci :
Code:
Received-SPF: pass (google.com: domain of postmaster@test-domaine.fr designates 2001:41d0:2:927b::15 as permitted sender) client-ip=2001:41d0:2:927b::15;
Authentication-Results: mx.google.com;
       dkim=pass header.i=@test-domaine.fr;
       spf=pass (google.com: domain of postmaster@test-domaine.fr designates 2001:41d0:2:927b::15 as permitted sender);
       dmarc=pass (p=REJECT dis=NONE) header.from=test-domaine.fr
indique que des divers tests ont été exécute, et ils sont tous Ok:
SPF
DKIM
DMARC


A savoir : mon /etc/master.cf :
la partie réception IPv6 :
Code:
[2001:41d0:2:927b::15]:smtp      inet    n       -       -       -       -       smtpd
  -o myhostname=mail.test-domaine.fr
  -o smtp_helo_name=test-domaine.fr
  -o syslog_name=test-domaine.fr-smtp-client-ipv6
  -o smtpd_tls_cert_file=/root/startssl/test-domaine.fr/ssl.crt
  -o smtpd_tls_key_file=/root/startssl/test-domaine.fr/ssl-decrypted.key
  -o smtpd_tls_CApath=/etc/ssl/certs
  -o smtpd_tls_security_level=may
  -o smtpd_tls_received_header=yes
  -o smtpd_sasl_auth_enable=no
T'as du voir la solution concernant ton "myhostname"

Réception IPv4 :
Code:
5.196.43.182:smtp      inet    n       -       -       -       -       smtpd
  -o myhostname=mail.test-domaine.fr
  -o smtp_helo_name=mail.test-domaine.fr
  -o syslog_name=test-domaine.fr-smtp-client-ipv4
  -o smtpd_tls_cert_file=/root/startssl/test-domaine.fr/ssl.crt
  -o smtpd_tls_key_file=/root/startssl/test-domaine.fr/ssl-decrypted.key
  -o smtpd_tls_CApath=/etc/ssl/certs
  -o smtpd_tls_security_level=may
  -o smtpd_tls_received_header=yes
  -o smtpd_sasl_auth_enable=no
Submission IPv4:
Code:
5.196.43.182:submission      inet    n       -       -       -       -       smtpd
  -o myhostname=mail.test-domaine.fr
  -o smtp_helo_name=mail.test-domaine.fr
  -o smtpd_tls_security_level=may
  -o smtpd_tls_auth_only=no
  -o smtpd_tls_cert_file=/root/startssl/test-domaine.fr/ssl.crt
  -o smtpd_tls_key_file=/root/startssl/test-domaine.fr/ssl-decrypted.key
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
  -o content_filter=amavis:[127.0.0.1]:10026
  -o milter_macro_daemon_name=ORIGINATING
  -o syslog_name=test-domaine.fr-submission
  -o smtpd_tls_CApath=/etc/ssl/certs
Puis, t'as compris, la même existe pour IPv6 ....
Et il existe aussi un pair de IPv4 et IPv6 concernant la réception SMTPS (porte 465)

Ceci est spécial :
Code:
test-domaine_fr unix  -       -       n       -       -       smtp
   -o smtp_bind_address6=2001:41d0:2:927b::15
   -o smtp_bind_address=5.196.43.182
   -o smtp_helo_name=mail.test-domaine.fr
   -o syslog_name=test-domaine.fr-transport
   -o smtp_tls_CAfile=/root/startssl/sub.class1.server.ca.pem
   -o smtp_tls_security_level=may
C'est la - en semble avec
sender_dependent_default_transport_maps = mysql:/etc/postfix/mysql-sdd_transport_maps.cf
(dans /etc/postfix/main.cf)
Je décodé le nom de domaine 'émetteur' - ici "test-domaine.fr" (un des mes domaines / URL's) vers quelque chose que je puisse utiliser dans master.cf (le "test-domaine_fr" au lieu de "test-domaine.fr" qui contient un point et ça va pas.) pour qu'il sélectionne le bon IPv4 et IPv6,; le nom (mail host) qu'il annonce au serveur en face, un prefixe pour le log, le bon certificat qui dit qu'il est "mail.test-domaine.fr)




Mon /etc/postfix/main.cf est relativement petit (130 linges) , et ce "myhostname", je ne le déclare même pas.
Mon master.cf est bien plus grand .... car la, je traite par domaine, pour IPv4 puis IPv6 comme envoyer et recevoir mes mails.

Didier Misson
04/09/2016, 20h58
Bonjour bbr18.

J'ai déjà certains éléments de config.

J'ai effectivement défini les Reverses dans mes IPs OVH

  • reverse pour chaque domaine.be puisque j'ai une IP par site / domaine
  • reverse pour le nom du serveur ct1234.misson.ovh


le Hostname ne correspond pas tout à fait au nom du serveur utilisé dans la config Postfix...
j'ai un nom du genre : ct1234-dm ou -d8 (pour Drupal 8, pour ma facilité dans ma liste de conteneur virtuel),
alors que le reverse de l'IP du serveur est ct1234.misson.ovh

Oui, je peux changer ça.
Mais pas sûr que ça soit critique.
Je vais faire quelques tests en modifiant ça.
ça va jouer sur l'acceptation ou pas comme spam, mais pas sur le "myhostname" utilisé par Postfix.

Dans les DNS OVH, j'ai les 2 définitions types A :
  • ct1234.misson.ovh --> 123.123.123.123
  • ct1234-d8.misson.ovh --> 123.123.123.123



Donc, le nom utilisé comme nom de serveur en Postfix existe dans les DNS
et pointe bien vers l'IP du serveur virtuel (vers la 1ère IP du serveur virtuel)

/etc/mailname

Je ne pense pas pouvoir utiliser /etc/mailname,
car j'ai PLUSIEURS domaines, donc je devrais mettre plusieurs noms dans /etc/mailname...

/etc/hosts
J'ai les 2 définitions :
123.123.123.123 ct1234-d8.misson.ovh ct1234-d8

je rappelle que de toute façon ça existe dans le DNS OVH,
donc il y bien résolution DNS sur ces noms, et même sur ct1234.misson.ovh

Postfix

dans /etc/postfix/main.cf , j'ai essayé ceci :

# myhostname = localhost.localdomain
# myhostname = smtp.$mydomain
myhostname = ct1234.misson.ovh
# myhostname = smtp.domain1.be

ce que je voudrais, c'est : myhostname = smtp.$mydomain
avec $mydomain qui prenne automatiquement la valeur correspondante aux domaines dont les mails sont envoyés.

en partique, la variable $mydomain est toujours VIDE
peut-être car le "myhostname" n'est interprété qu'une seule fois, lors du "service postfix start" ?

Sinon ... est-ce possible ?
et comment ?

Merci et bonne soirée

bbr18
04/09/2016, 18h51
tu devrais trouver quelques réponses ici : https://www.how-to.ovh/viewtopic.php?f=21&t=74

Didier Misson
04/09/2016, 12h02
Bonjour

Dans /etc/postfix/main.cf , je voudrais avoir "myhostname" qui prenne automatiquement des valeurs différentes en fonction de mes domaines :

ça devrait automatiquement devenir :

myhostname = smtp.mondomaine1.be
ou
myhostname = smtp.mondomaine2.fr
ou
myhostname = smtp.mondomaine3.com

Ce serait impec car j'ai déjà les emails envoyés sur l' IP précise de chaque domaine.

il faut donc une variable !


J'essaye :

myhostname = stmp.$mydomain

mais ça ne fonctionne pas, car $mydomain est vide !

Je commence seulement à comprendre Postfix... y a encore du boulot


Merci et bon dimanche

Didier Misson
04/09/2016, 04h09
dans Webmin / Servers / Postfix / General Option
quand j'essaye de modifier "What domain to use in outbound mail" ou " Internet hostname of this mail system" pour y mettre un nom,
j'ai une erreur :

Code:
Failed to save options : Postfix configuration error :
postfix: fatal: bad string length 0 < 1: mynetworks_style =


Merci

Didier Misson
04/09/2016, 03h27
Bonjour,

Les emails envoyés depuis mon dédié arrivent en SPAM dans ma boite gmail, et sont rejettés par Hotmail / Outlook.

La raison est un problème de config Postifx.
Les mails arrivent chez Gmail (ou Hotmail) avec :

Received: from localhost.localdomain
...
Message-Id: <20160904002332.11E6977B02D@localhost.localdomain>

C'est clairement une erreur de config Postfix / Webmin / Virtualmin
mais je ne trouve pas

Le serveur est Ubuntu 16.04
avec plusieurs IPs sur le serveur.

Les mails partent avec la bonne IP, correspondante à l' IP du site.
Le record SPF est bien configuré dans le DNS OVH.
D'ailleurs, le test SPF est PASS dans l'entête du mail.

La question est donc :
Comment changer dans Postfix pour ne plus avoir

Received: from localhost.localdomain

et que ce soit correct pour mondomaine1.be , mondomaine2.be ... etc

Merci