OVH Community, votre nouvel espace communautaire.

OVH-Release 3 : upgrade impossible depuis la 3.32 vers la 3.36


sich
20/09/2016, 12h19
le mieux étant de louer un autre serveur sur une distrib à jour, puis de migrer les services et d'arrêter l'ancien serveur...

Derek
20/09/2016, 11h04
Une distribution qu'on ne peut pas mettre à jour, avec des paquets obsolètes et une communication tardive quant à son avenir... on dirait bien qu'OVH a fait une erreur de proposer ses propres releases plutôt que d'offrir de simples modules venant se greffer sur des distributions existantes. Tous ceux qui ont fait ce choix comme moi à l'époque en sont pour leurs frais.
Est-ce qu'on peut au moins transformer sa R3 en CentOS classique ? J'imagine que non...

bbr18
20/09/2016, 10h21
lire le dernier post sur cette page : https://forum.ovh.com/showthread.php...l=1#post671088

buddy
20/09/2016, 10h20
Je ne pense pas qu ovh fera une release 4 non plus.

bbr18
20/09/2016, 09h30
il n'existe pas, c'est une distribution sauce ovh

Derek
19/09/2016, 14h03
OK merci pour les infos. Du coup j'abandonne l'idée de réparer ma distro... j'ai un peu de mal à comprendre pourquoi elle a été créée au départ vu le peu de doc disponible dessus et l'aspect très "OVH-only" qui rend complexe des choses simples. C'est moi ou est-ce que cette release maison était un délire de geek ?

buddy
19/09/2016, 13h09
généralement, quand tu sors de la release c'est fini...
Tu peux surement forcer l'installation de la mise à jour en bidouillant le script d'OVH mais rien ne garantit que çà fonctionnera toujours après.

Le mieux est d'abandonner cette release pour une avec des paquets à jour

Derek
19/09/2016, 12h56
J'ai certainement fait des trucs que je n'aurais pas du faire, à force d'essayer de faire un upgrade de PHP et d'installer certaines extensions vu la version périmée qui était sur la distribution, mais je ne me rappelle plus de ce que j'ai pu faire...
D'après ce que j'ai compris, tout ce que j'aurais à faire pour "réparer" mon installation serait de trouver un moyen d'installer le paquet RPM "OVH-Release" correspondant à la version 3.32 mais je n'ai aucune idée de comment faire ça. Il faudrait déjà que je sache où trouver ce paquet

buddy
19/09/2016, 11h39
est-ce que tu n'aurais pas installer un paquet en plus ou supprimer un paquet qui t'aurais fait sortir de la release "pure".

Sinon, sur le forum est beaucoup conseillé Debian + virtualmin. (très grosse comunauté pour Debian et ces variantes+ virtualmin qui est bien suivi)

https://www.how-to.ovh/viewtopic.php...ff8ad6ce0d#p29

Derek
19/09/2016, 09h11
Citation Envoyé par bbr18
essaie les mises à jour une par une : 3.32 vers 3.33, puis 3.33 vers 3.34 etc.
En fait c'est ce que fait le script, mais vu qu'il ne détecte même pas ma version courante il refuse même la première upgrade.
Citation Envoyé par bbr18
quant à la ml, elle est morte (comme cette distribution), il ne s'y passe rien
Bon et bien je n'ai plus qu'à tout migrer sur une autre distrib... quand je pense que j'avais choisi la distrib OVH en me disant que le support serait forcément meilleur avec un truc officiel, j'aurais mieux fait de me casser une jambe ce jour là.

bbr18
17/09/2016, 12h11
essaie les mises à jour une par une : 3.32 vers 3.33, puis 3.33 vers 3.34 etc.
quant à la ml, elle est morte (comme cette distribution), il ne s'y passe rien

cassiopee
17/09/2016, 02h20
Je ne sais pas si c'est encore valable, cf la fin du message d'annonce de la Release 3 :

https://forum.ovh.com/showthread.php...test-release-3

Derek
16/09/2016, 23h48
Merci pour vos réponses.
Disons que pour l'instant j'aimerais m'épargner une migration vers une autre distribution car j'ai pas mal de config custom et de services qui tournent
Du coup il y a un endroit où on peut voir les archives de la mailing list et s'y inscrire ?

cassiopee
16/09/2016, 20h14
Surtout pour quelqu'un qui connait déjà Debian (=> "Debian + Virtualmin" est un bon remplacement pour la Release 3)

janus57
16/09/2016, 18h39
Bonjour,

le seul support "rapide" serait sur la ML, car pas mal de personne sur ce forum dé-conseil fortement la R3 qui est obsolète.

Cordialement, janus57

Derek
16/09/2016, 17h19
Personne n'utilise cette distribution ? Il n'y a aucun moyen d'avoir du support dessus ?

Derek
25/08/2016, 18h33
Je gère un serveur dédié en OVH-Release 3 mais je suis perdu sur cette distribution: je suis un habitué Debian et d'après ce que j'ai compris même en suivant les guides CentOS ils ne s'appliquent pas forcément à la distribution OVH. Bref.

Je souhaite faire un upgrade de ma version 3.32 alors j'exécute :
Code:
#sh /root/patch-all-release-3.sh
Ce qui me renvoie:
Code:
... found OVH-Release 3
we do update OVH-Release3
+-------------------------------------------------------------------+
Sorry ... this update is not for your Systemversion !
+-------------------------------------------------------------------+
+-------------------------------------------------------------------+
Sorry ... this update is not for your Systemversion !
+-------------------------------------------------------------------+
+-------------------------------------------------------------------+
Sorry ... this update is not for your Systemversion !
+-------------------------------------------------------------------+
+-------------------------------------------------------------------+
Sorry ... this update is not for your Systemversion !
+-------------------------------------------------------------------+
J'ai pourtant la bonne version de base alors je fouille un peu dans les scripts d'upgrade pour trouver la cause:
Code:
CHECKRELEASE=$(/bin/rpm -qa | grep OVH-Release)
Ceci ne renvoie rien. En fait la commande /bin/rpm -qa ne me renvoie que 5 lignes et aucune ne contient la chaîne "OVH-Release":

Code:
#/bin/rpm -qa
gpg-pubkey-6b8d79e6-3f49313d
gpg-pubkey-00f97f56-467e318a
gpg-pubkey-c105b9de-4e0fd3a3
gpg-pubkey-0608b895-4bd22942
gpg-pubkey-11f63c51-3c7dc11d
J'ai bien l'impression que mon installation est mal en point. Comment dois-je procéder pour la réparer ?