OVH Community, votre nouvel espace communautaire.

Enregistrement de type CNAME sur www n'est pas publié par les DNS OVH


MisterJay
26/09/2016, 20h49
Merci !

Je confirme, il faut supprimer les entrées TXT. Il n'y a plus sur mes DNS que :
-entrées ns (2)
-entrée mx
-entrées srv (2)
-entrée CNAME (2)

Les modifs étaient visibles sur l'interface mais inexistantes en vérifiant dans "modifier mes entrées en mode textuel".

fritz2cat
02/07/2016, 16h09
Merci du feedback
F.

cnamer78
01/07/2016, 23h50
Le problème semble résolu.

Merci beaucoup à buddy, fritz2cat sur le forum et Yassine G. du support OVH,

Pour d'autres au cas ou, voici ce que j'ai fait (même si je ne comprends pas et n'identifie pas ce qui formellement a corrigé le problème) , certaines attentes ou étapes doivent d'ailleurs être non nécessaires.

Entre chaque étape à partir de l'étape 2, je vérifiais avec DIG si c'était OK


1 - J'ai désactivé l'option DNSSEC (interface OVH - écran 'informations générales' )

J'ai attendu une heure (bizarrement d'ailleurs cette option montrait une cercle d'avancement qui tournait en boucle et une erreur sur DNSSEC est apparue dans les 'opérations en cours')


2 - J'ai réinitialisé la zone (interface OVH) avec l'option écran 'Zone DNS' - Bouton ''Réinitialiser la configuration' - Choix 'Oui, je veux réinitialiser ma zone DNS avec les entrées minimales'

J'ai attendu une heure sans toucher aucune entrée créée par défaut.


3 - J'ai supprimé toutes les entrées créées par défaut TXT liées au www

J'ai attendu une heure

Remarque : Cette opération clairement est au cœur de la résolution et du fait que toutes mes modifications du www n'étaient pas publiées


4 - J'ai créé l'entrée CNAME qui me posait problème par l'écran 'Zone DNS' - Bouton 'Ajouter une entrée' (je n'ai pas utilisé l'écran 'redirection')

J'ai attendu une heure

J'ai pu vérifier qu'elle était enfin publiée sur Internet et correcte.


5 - J'ai recréé toutes les entrées dans la zone DNS autres qui m'étaient nécessaires (notamment entrée m.expstart.fr pour WIX).

J'ai vérifié qu'elle était aussi correctement publiée.


6 - J'ai modifié comme le demande WIX l'enregistrement type A du .expstart.fr (adresse IP différente de celle par défaut configurée par OVH lors de réinitialisation de la zone)

Encore merci à tous ceux ayant participé à la résolution de mon problème et la réactivité très forte de Buddy et Fritz2cat.

fritz2cat
01/07/2016, 17h18
Et supprime DNSSEC tant que ta situation n'est pas stabilisée.

buddy
01/07/2016, 16h31
Le mieux est de réinitialiser la zone dns je crois. Attendre 5 à 10 minutes Et tout reconfigurer.. (le minimum syndical en supprimant les TXT et autres trucs inutiles)

cnamer78
01/07/2016, 16h28
Bon, voici ou j'en suis à cette heure.

Sur les conseils de l'assistance OVH, j'ai supprimé les enregistrements TXT liés au www.expstart.fr

Puis j'ai supprimé et recrée l'enregistrement CNAME du www

Un progrès, je peux maintenant voir l'enregistrement CNAME www dans l'import de zone en mode texte et si je fais un import cela fonctionne sans erreur.

Mais j'ai fait cela à 13h26 et toujours pas d'enregistrement publié sur les DNS OVH (testé avec DIG et KLOTH sur les serveurs de noms OVH).

Pour fritz2cat, j'avais bien la ligne sans espace au début et un point derrière le .net

fritz2cat
01/07/2016, 13h12
www IN CNAME www230.wixdns.net.
la ligne doit commencer en 1è position. (pas de blancs pour commencer)
La ligne se termine par .net. (avec un point derrière net)

cnamer78
01/07/2016, 12h31
J'ai essayé déjà, j'ai une erreur en import.

Zone is not valid : line 22: www.expstart.fr: CNAME and other data

buddy
01/07/2016, 12h31
çà m'a lair ok ...

ce n'est pas "académique" mais supprime le CNAME du www.ndd.fr puis essaye de le rajouter 10 minutes après ...

fritz2cat
01/07/2016, 12h30
Donc en mode textuel, tes entrés www sont manquantes ?
Ajoute la ligne www IN CNAME dans le mode textuel pour voir ?

cnamer78
01/07/2016, 12h12
Voici les copies d'écran de l'interface OVH sur ce domaine : Zone DNS, Redirection et Zone en mode textuel






fritz2cat
01/07/2016, 12h11
est-ce possible que ce soit anycast.me le fautif dans cette histoire ?

cnamer78
01/07/2016, 11h45
Voici ce que j'ai dans l'interface OVH : Zone DNS, Redirection, Zone en mode textuel


Lien vers mon image

Lien vers mon image

Lien vers mon image

buddy
01/07/2016, 10h56
tu pourrais faire un impr écran de la zone DNS ?

cnamer78
01/07/2016, 10h55
C'est ce que j'essaie désespérément de faire depuis plus de 8 jours.

L'enregistrement CNAME est bien présent dans les onglets 'Zone DNS' et 'Redirection' mais jamais pris en compte par les DNS OVH

Et ce qui d'ailleurs montre que quelque chose ne va pas c'est que si je veux modifier la zone en mode texte, dans le contenu de la zone (le fichier texte que l'interface présente), jamais l'enregistrement www n'y figure.

Par contre le CNAME m.expstart.fr lui est parfaitement fonctionnel dès le début.

C'est comme si les process OVH refusaient d'intégrer l'enregistrement www.

Et ce problème existe sur expstart.fr et expstart.com

fritz2cat
01/07/2016, 10h47
Pour l'instant il n'y a aucune adresse qui fonctionne,
Le site chez wix: m point expstart point fr (hébergé chez wix sur le serveur www230.wixdns.net)
au lieu d'afficher une page web, renvoie une redirection en http vers www point expstart point fr
et cette dernière adresse (www) n'est pas définie.

Sur le panel OVH tu devrais ajouter un CNAME qui fait correspondre www230.wixdns.net. comme cible de ton www.

cnamer78
01/07/2016, 10h38
Le domaine est acheté et géré techniquement par OVH (je commence à me demander si c'était une bonne idée au vue de ce problème).

La partie hébergement du site www (web principal) et m (site mobile) est chez WIX.

fritz2cat
30/06/2016, 21h55
Le record www est effectivement absent.
$ dig www.expstart.fr any @ns200.anycast.me

; <<>> DiG 9.10.3-P4 <<>> www.expstart.fr any @ns200.anycast.me
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58619
;; flags: qr aa rd; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;www.expstart.fr. IN ANY

;; ANSWER SECTION:
www.expstart.fr. 3600 IN TXT "3|welcome"
www.expstart.fr. 3600 IN TXT "l|fr"
www.expstart.fr. 3600 IN RRSIG TXT 7 3 3600 20160730141718 20160630141718 13385 expstart.fr. q+4YZim1iyM3Sj5fzdTq9n8TtUNqNWvfsCjquVq3UvM5c01Q4H uRkC1H eEzhEtTIghaiik9DRrZibnI6+vQy+5YB6lVMoFqFczpcq0YxMx OgkicJ ezwBOq1xGOQlcPsxpyeOD8GsfePZZL7ag/5hQwwc/kRZW2myBuUM/8fA LMY=

;; Query time: 39 msec
;; SERVER: 46.105.207.200#53(46.105.207.200)
;; WHEN: Thu Jun 30 21:55:03 CEST 2016
;; MSG SIZE rcvd: 254
Pas de 'A' ni de 'CNAME'.
Edit: le domaine expstart.fr est hébergé sur Google, et la version mobile chez Wix. Est-ce intentionnel ?

cnamer78
30/06/2016, 17h21
Je n'ai pas trouve d'onglet 'redirection web', j'ai juste sur l'interface OVH l'onglet 'redirection'.

J'ai supprimé la redirection www dans cet onglet, puis recrée dans l'onglet zone DNS le CNAME www. et attendu 15 mn

Mais toujours le même symptôme en testant aussi dans le lien que tu m'as donné.

J'avais créé aussi à l'origine un CNAME m.expstart.fr pointant sur le même nom qui lui a toujours fonctionné.

Le problème semble uniquement toucher le record www

buddy
30/06/2016, 16h49
Supprimes tout dans l'onglet Redirection web
Tape le CNAME dans l'interface graphique.
Attend 10 min et regarde si tu la vois sur cette page https://toolbox.googleapps.com/apps/...200.anycast.me.

cnamer78
30/06/2016, 16h08
J'ai un message d'erreur uniquement quand je le crée avec le mode importation texte (le message est 'Zone is not valid : line 22: www.expstart.fr: CNAME and other ').

Si j'utilise l'interface OVH soit par l'écran 'Zone DNS', soit par l'écran 'Redirection', aucun message d'erreur et l'enregistrement apparaît bien dans la liste des enregistrements de la zone (mais jamais dans la zone texte présentée par l'option importation) mais n'est jamais rendu public (jamais activé sur les DNS ?)

buddy
30/06/2016, 16h03
As-tu un message d'erreur quand tu veux créer un cname ?
https://www.ovh.com/fr/g1604.mutuali..._de_type_cname

cnamer78
30/06/2016, 15h57
Merci, Désolé je ne pensais pas que c'était nécessaire, voici

le domaine est expstart.fr

le CNAME est www230.wixdns.net.

buddy
30/06/2016, 15h51
Si tu veux de l'aide sur le forum, il nous faut le nom de domaine et le CNAME que tu souhaites mettre en place ..

cnamer78
30/06/2016, 15h42
Bonjour

Depuis plus d'une semaine je tente désespérément de rendre visible sur les DNS publics internet un enregistrement www de mon domaine acheté et géré par OVH et qui doit pointer sur un CNAME (hébergement WIX - méthode par pointage).

L'enregistrement (crée par Redirection ou par Zone DNS, j'ai essayé les deux possibilités) apparaît bien sur l'interface OVH de gestion DNS dans les options Zone DNS et Redirection mais bizarrement jamais dans le fichier texte issu de l'option 'Modifier en mode textuel'.

Cet enregistrement n'est jamais actif au niveau Internet, les outils de type nslookup divers essayés n'arrivent pas à trouver une valeur CNANE pour le www.

Je n'ai pas d'enregistrement de type A sur ce www bien entendu.

J'ai essayé de réinitialiser (option entrées minimales ou non) la zone DNS avec l'interface OVH mais cela ne change rien. J'ai aussi essayé de supprimer le record www et de le recréer. Mais là aussi même symptôme.

Si j'essaie de créer le record www en mode texte, l'importation de la zone DNS par l'outil OVH affiche une erreur systématiquement.

J'ai essayé de faire cela sur mes deux domaines (.com et .fr) et c'est exactement le même problème sur les deux.

J'ai crée un ticket d'assistance OVH il y a 6 jours mais il est toujours désespérément sans réponse.

SI quelqu'un à une solution ou si le support OVH passe par là, merci d'avance.