OVH Community, votre nouvel espace communautaire.

Problème FTP


Boulvard
16/06/2016, 16h22
Question standard que je n'ai pas vu posée.

* Ton site pointe dans quel répertoire ?

Va sur ton "Hébergement", clique sur ton nom de domaine et regarde dans "multi site". quel est le dossier racine ? "www" ou autre chose ?

Quailove81
16/06/2016, 13h55
Hopefully someday the HTML will work properly Sorel!

Cehem-63
13/06/2016, 11h48
Bonjour,

Pouvez-vous regarder sous FTP quels sont les droits du répertoire www, ils doivent être au moins en lecture pour Other, c'est-à-dire 555 ou 755. Si vous avez pu poser des fichiers, c'est que le premier chiffre est un 7 mais le dernier doit être 5.

Personnellement j'ai 505 sur www, je le passe à 705 temporairement chaque fois que je dois poser un fichier directement sous www. Si c'est dans un sous répertoire, ce n'est pas nécessaire, il suffit que le sous-répertoire soit en 705.

SorelG04
13/06/2016, 11h24
Ah je croyais que tu parlais de l'assistance d'OVH haha.

Le site ne fonctionne pas non plus avec des pages en HTML, je viens de tester.

Gaston_Phone
12/06/2016, 22h34
Citation Envoyé par Cehem-63
Oui, enfin peu importe, je voudrais surtout qu'il vérifie si ça marche avec un simple fichier html, si déjà ça ne marche pas, on se posera d'autres questions.
Tout à fait d'accord sur ce point là.

Cehem-63
12/06/2016, 22h30
Oui, enfin peu importe, je voudrais surtout qu'il vérifie si ça marche avec un simple fichier html, si déjà ça ne marche pas, on se posera d'autres questions.

Gaston_Phone
12/06/2016, 21h55
Citation Envoyé par Cehem-63
Peut-être que le php n'est pas démarré sur votre hébergement, ou qu'il s'est arrêté,
Hum! Hum! Le PHP à l'arrêt sur du mutualise!

Le script bonjour.php ci-après fonctionne avec toutes les version de PHP.
Code PHP:
   echo "Bonjour. Nous sommes le ".date ("Y-m-d H:i:s")."
"
;
?>

Cehem-63
12/06/2016, 21h47
Bonsoir,

Citation Envoyé par SorelG04
Cehem-63 : Bah comme je l'ai dit, ce lien affiche la page d'erreur 404 Not Found.
Peut-être que le php n'est pas démarré sur votre hébergement, ou qu'il s'est arrêté, ou qu'il n'est pas à la bonne version. Pouvez vérifier si un simple fichier html fonctionne. Posez avec ftp un fichier index.html ne contenant que du texte à afficher "Bonjour", et ensuite collez l'adresse de votre site dans le navigateur (sans index.html), le texte doit s'afficher "Bonjour". Si cela ne marche pas il faudra voir pourquoi. Si cela marche, ce serait un problème avec le php.

Gaston_Phone
12/06/2016, 19h13
Citation Envoyé par SorelG04
Pas de soucis, merci quand même pour ton aide !
J'appellerai l'assistance demain oui.
Je me proposais de t'aider en direct via le logiciel TeamViewer.

SorelG04
12/06/2016, 19h11
Pas de soucis, merci quand même pour ton aide !
J'appellerai l'assistance demain oui.

Gaston_Phone
12/06/2016, 19h03
Désolé SorelG04 de pas pouvoir t'aider plus via le forum.
Il manque des informations que tu dois voir mais que l'on ne connait pas.

Il reste l'assistance en direct.

SorelG04
12/06/2016, 18h46
Avec 705 j'avais déjà essayé de toute façon : c'était la valeur par défaut et ça ne marchait pas.

Cehem-63 : Bah comme je l'ai dit, ce lien affiche la page d'erreur 404 Not Found.

Gaston_Phone : D'accord, je suis ennuyeux mais qu'est-ce qu'un cluster ? (Et où je peux le trouver ?)

J'ai fait attention aux majuscules. Après la procédure du bonjour.php ne semble pas correspondre à l'erreur 404 non ?

Sur OVH j'ai vu que l'erreur 404 pouvait venir d'un "problème d'écriture URL" ; j'ai fait quelques recherches qui parlent de faire des manipulations à propos de l'URL rewriting. (Je ne sais pas si ça vous dit quelque chose.)

Gaston_Phone
12/06/2016, 18h39
Citation Envoyé par SorelG04
Cehem-63 : Le répertoire www a l'attribut 705, je vais essayer avec 755.
-->
Citation Envoyé par Gaston_Phone
Avec FileZilla, créer le dossier /www et lui mettre les attributs 705.

Citation Envoyé par SorelG04
Que donne > "LoginFTP.clusterxxx.ovh.net/bonjour.php " ? Là ça me dépasse par contre, je remplace quoi par quoi pour savoir ?
LoginFTP : Ton identifiant de connexion
clusterxxx : Ton cluster (chez moi, c'est cluster010

Citation Envoyé par SorelG04
J'ai bien suivi la procédure bonjour.php, j'ai créé le fichier dans un bloc-note avec la ligne de code qui était indiquée, je l'ai correctement nommé et je l'ai glissé dans le dossier /www du FTP (qui est réapparu suite à la procédure de back up). Mais le lien vers la page bonjour.php affiche une erreur 404 comme n'importe quelle page.
Attention aux MAJUSCULES/minuscules

- - - Mise à jour - - -

Mail envoyé.

Cehem-63
12/06/2016, 18h29
Avec 705 ça devrait marcher.

Moi je dirais plutôt : qu'est ce que cela donne si vous mettez www.geoffreyhumbert.com/bonjour.php dans la barre d'adresse de votre navigateur ?

SorelG04
12/06/2016, 17h10
(Désolé Gaston, je n'avais pas vu tous tes messages. Je te réponds de suite.)

J'ai bien suivi la procédure bonjour.php, j'ai créé le fichier dans un bloc-note avec la ligne de code qui était indiquée, je l'ai correctement nommé et je l'ai glissé dans le dossier /www du FTP (qui est réapparu suite à la procédure de back up). Mais le lien vers la page bonjour.php affiche une erreur 404 comme n'importe quelle page.

Oui, je suis en mutualisé.

Cehem-63 : Le répertoire www a l'attribut 705, je vais essayer avec 755.

Que donne > "LoginFTP.clusterxxx.ovh.net/bonjour.php " ? Là ça me dépasse par contre, je remplace quoi par quoi pour savoir ?

Cehem-63
12/06/2016, 16h52
Oui, merci de ton aide. Mais il est en mutualisé ou pas?

Gaston_Phone
12/06/2016, 16h38
@ Cehem-63, il me semble que SorelG04 ne comprend pas très bien ce que nous lui demandons de faire.

En particulier, le test du script bonjour.php est un minimum avant d'aller plus loin.

En fin de matinée je lui ais posté un message d'aide, toujours sans réponse.

Cehem-63
12/06/2016, 16h34
Bonjour,

Citation Envoyé par SorelG04
Cehem-63 : J'aimerais bien pouvoir réinitialiser mais je ne sais pas si c'est possible et, si ça l'est, comment je peux le faire. A priori je n'ai rien trouvé dans mon interface utilisateur sur OVH mais j'ai peut-être loupé quelque chose.
Non, autant pour moi, il n'y a pas moyen de réinitialiser l'espace dans l'interface de gestion. Mais est-ce que vous pouvez depuis FTP supprimer et ajouter des fichiers? Et est-ce vous pourriez : recréer le répertoire www si il a été supprimé, lui donner la permission 755, puis réinstaller Wordpress (que ce soit en demandant l'installation par OVH (ce que je vous déconseille plus haut) ou en l'installant vous même (ce que je vous conseille plus haut))?

Gaston_Phone
12/06/2016, 16h32
Que donne l'accès : LoginFTP.clusterxxx.ovh.net/bonjour.php ?

SorelG04
12/06/2016, 16h13
Gaston_Phone : Oui, j'ai mis le script bonjour et il y est toujours. Ça ne change rien.

Cehem-63 : J'aimerais bien pouvoir réinitialiser mais je ne sais pas si c'est possible et, si ça l'est, comment je peux le faire. A priori je n'ai rien trouvé dans mon interface utilisateur sur OVH mais j'ai peut-être loupé quelque chose.

Cehem-63
12/06/2016, 11h38
Autant pour moi , il n'y a pas de fonction réinitialisation sur le panneau d'administration. Mais si vous faites ce que vous a dit Gaston_Phone, ça devrait marcher : recréer le répertoire www et lui donner les droits 705 ou 755 .

Gaston_Phone
12/06/2016, 11h26
Citation Envoyé par SorelG04
En fait c'est toujours l'erreur 404 qui s'affiche.
J'ai fait une restauration de sauvegarde sur OVH à 3 jours, quand je n'avais pas encore de soucis, mais ça n'a rien changé. :/
Je viens de mettre un message sur ton profil.

Cehem-63
12/06/2016, 11h20
Bonjour,

Vous êtes en mutualisé? N'y a-t-il pas moyen, depuis l'espace d'administration, de réinitialiser l'hébergement? Cela remettrait tout d'aplomb, après vous redemanderiez une instance de Wordpress ou que sais-je.
Mais (si la réinitialisation existe) je vous conseille d'installer Wordpress vous même au lieu d'utiliser les installations de OVH. Il faut simplement demander une base SQL auparavant (pas de supplément de prix). Pour installer Wordpress : téléchargez l'archive sur le site de Wordpress, posez là par ftp sur votre www, elle sera automatiquement désarchivée, et ensuite suivez le mode opératoire d'installation que vous trouverez également sur le site de Wordpress.

Gaston_Phone
12/06/2016, 11h12
Y as-tu mis le script de test : /www/bonjour.php ?

SorelG04
12/06/2016, 10h34
Désolé, j'avais abandonné pour hier soir.

L'URL de mon site est www.geoffreyhumbert.com

En fait c'est toujours l'erreur 404 qui s'affiche.

J'ai fait une restauration de sauvegarde sur OVH à 3 jours, quand je n'avais pas encore de soucis, mais ça n'a rien changé. :/

Gaston_Phone
11/06/2016, 23h29
Déjà l'abandon ? ? ?

Gaston_Phone
11/06/2016, 23h12
Le fichier /www/.htaccess n'est pas utile pour le test de /www/bonjour.php.

Domaine ? ? ?

SorelG04
11/06/2016, 23h07
Ça ne marche pas...

En fait je n'ai plus non plus le fichier htaccess... Y a pas juste un moyen de réinitialiser les fichiers de départ ?

Gaston_Phone
11/06/2016, 23h02
URL ?

Dans le dossier mets le script /www/bonjour.php --> OVH - Erreur 500 sur votre site Internet et teste le.

SorelG04
11/06/2016, 22h46
C'est ce que j'ai fait mais ça ne marche quand même pas :/

Gaston_Phone
11/06/2016, 22h17
Avec FileZilla, créer le dossier /www et lui mettre les attributs 705.

SorelG04
11/06/2016, 21h45
Bonjour,

Avant toute chose, excusez-moi si je ne poste pas au bon endroit mais je n'ai, semble-t-il, pas trouvé de catégorie plus adaptée à mon problème.

J'ai pris un hébergement avec nom de domaine chez OVH pour un site web personnel en septembre dernier. Je m'en servais pour un petit site que j'avais codé en HTML/CSS l'été dernier ; mais je souhaite le faire évoluer et donc le supprimer et passer à WordPress pour le rendre plus dynamique. J'ai donc supprimé le site en passant par FileZila mais je crois avoir supprimé le dossier /www ou d'autres choses de ce genre, et depuis, plus moyen d'héberger quoi que ce soit. (J'ai fait un site WordPress en local mais j'ai beau l'envoyer via FileZila, rien ne s'affiche sur mon nom de domaine)

J'ai vu que je pouvais passer via l'interface OVH pour lancer un site WordPress aussi, en allant dans mon compte : Domaines > Tous mes domaines, et je sélectionne mon domaine, je fais "mettre en place mon site", et je peux choisir "Blog". Ça marchait mais depuis que j'ai supprimé tout mon site, ça me dit que je ne peux pas faire ça car " Vous n'avez plus assez d'espace disponible sur cet hébergement. Afin de pouvoir réaliser cet opération vous pouvez booster votre offre en cliquant ici."
Pourtant quand je vais dans "Hébergements" et que je regarde l'espace disque, j'ai 17Mo d'occupés sur 100Go.

Je n'y comprends plus rien. Si vous pouvez faire quelque chose pour moi...