OVH Community, votre nouvel espace communautaire.

Drupal 8 sur hébergement mutualisé


emicoma
03/06/2016, 15h43
Bonjour
j'ai 2 sites drupal 8 fonctionnels en mutualisé.
comment installer drush 8 ?
j'ai suivi ce tuto http://www.drupalfacile.org/question...-pour-drupal-8
puis créé un fichier .bashrc à la racine de l'hebergement cotnenant export PATH="~:$PATH"
(fichier drush à la racine de l'hebergement, et site dans un dossier /2016)
en lançant source .bashrc pour recharger
la commande 'drush' me donne :

X-Powered-By: PHP/5.4.45
Content-type: text/html

et rien de plus...

Merci de votre aide

vcasse
18/05/2016, 11h52
Bonjour Mathieu14,

Il s'agit d'un soucis sur Drupal. Mais cela n'empêche pas son installation.

Je vous invite à lire le ticket chez Drupal : https://www.drupal.org/node/2639878

Cordialement,
Vincent

mathieu14
18/05/2016, 11h49
oui il est bien configuré avec la version stable.

buddy
18/05/2016, 10h15
Si tu regardes dans le manager, section Hébergement puis si tu cliques sur
Version PHP globale 5.6 Modifier la configuration,
et que tu édites la configuration php, tu as bien "stable" ?
https://www.ovh.com/fr/news/a2206.he...ment-execution

si non impose le dans le manager.

Ludo.H
18/05/2016, 09h23
Bonjour,

Si vous faites un phpinfo sur votre espace web vous pouvez voir quelque chose comme :

Code:
Zend OPcache
Opcode Caching 	Up and Running
Optimization 	Enabled
Startup 	OK
Shared memory model 	mmap
Cache hits 	246649
Cache misses 	11158
Used memory 	467865284
Free memory 	68065420
Wasted memory 	940208
Interned Strings Used memory 	4194280
Interned Strings Free memory 	24
Cached scripts 	10784
Cached keys 	12329
Max keys 	32531
OOM restarts 	0
Hash keys restarts 	0
Manual restarts 	0

mathieu14
18/05/2016, 00h43
merci. J'ai appliqué le patch à drupal 8 et l'erreur a bien disparu, mais j'ai toujours le message CachePHP OPcode : non activé
voici mon fichier .ovhconfig

app.engine=php
app.engine.version=5.6
http.firewall=none
environment=production
container.image=stable

Ludo.H
17/05/2016, 17h09
Bonjour,

Il s'agit d'un problème lié à Drupal, pour lequel un patch existe mais n'a toujours pas été intégré à leur version stable:

-> https://www.drupal.org/node/2639878
-> https://forum.ovh.com/showthread.php...l=1#post664910

Cdt,

mathieu14
17/05/2016, 16h31
Bonjour,

j’essaie d'installer drupal 8 sur mon hébergement performance 1 et j'obtiens le message d'erreur suivant :
http://hpics.li/80c6095

2ème questions, je suis actuellement sur une offre d'hébergement performante 1 et j'aimerai savoir si il y a une offre cloud facile à utiliser pour un débutant ? c'est quoi la différence entre VPS Cloud, VPS SSD et Cloud public (je veux que mon site soit stocké en France et pouvoir configurer apache).

C'est pour un site e-commerce sous drupal.

Merci d'avance