OVH Community, votre nouvel espace communautaire.

Mcrypt avec ubuntu + Plesk


lxwfr
10/05/2016, 16h22
Citation Envoyé par djulian
ps : je viens juste de m'apercevoir que le paquet mcrypt n'est pas disponible pour Xenial ; https://launchpad.net/ubuntu/xenial/+source/php-mcrypt

Comment faire ? Merci
Tu t'es troupé sur le lien et la version xenial est la version 16.04 (plesk n'est pas encore disponible), tu es bien
Citation Envoyé par djulian
ii libmcrypt4 2.5.8-3.1ubuntu1 amd64 De-/Encryption Library
ii plesk-php56-mcrypt 5.6.20-ubuntu14.04.16040512 amd64 Standard PHP module provides mcrypt library support
sur U-14.04.
Tiens je l'ai trouvé en https://forum.ubuntu-fr.org/viewtopic.php?id=1626151 (FR)

même question trouver sur https://forum.ovh.com/showthread.php...2-Ubuntu-14-04

Vous avez aussi PHP.net pour avoir plus d'information

djulian
08/05/2016, 22h18
Bonjour à tous j'ai une erreur sur mon prestashop :

Fatal error: Call to undefined function mcrypt_decrypt() in /var/www/vhosts/vps******.ovh.net/httpdocs/classes/Rijndael.php on line 70

Donc je fais un : sudo apt-get install php5-mcrypt il me dit : Impossible de trouver le paquet php5-mcrypt

Je tente de faire : sudo php5enmod mcrypt , il me retourne : WARNING: Module mcrypt ini file doesn't exist under /etc/php5/mods-available

Quand je fais un dpkg j'ai :

ii libmcrypt4 2.5.8-3.1ubuntu1 amd64 De-/Encryption Library
ii plesk-php56-mcrypt 5.6.20-ubuntu14.04.16040512 amd64 Standard PHP module provides mcrypt library support

Donc on peut voir que mcrypt est installé ?

ps : je viens juste de m'apercevoir que le paquet mcrypt n'est pas disponible pour Xenial ; https://launchpad.net/ubuntu/xenial/+source/php-mcrypt

Comment faire ? Merci