OVH Community, votre nouvel espace communautaire.

Updates fantômes sur Debian, tiens ?


lxwfr
21/05/2016, 20h23
ta pas ajouté un mauvais repo-deb /etc/source.list (à vérifier)

janus57
11/05/2016, 17h40
Bonjour,

pourquoi s'amuser à trifouiller les dépôts ?
Car de mémoire y a un client LE inclus dans Virtualmin/webmin
Version 1.791 (7th March 2016)

When attaching files to an email message or uploading files, multiple can now be selected at the same time.
Added an option for automatically renewing Let's Encrypt certificates.
If the Let's Encrypt client is not installed, Webmin will use its own built-in client code to request a certificate.
Included the latest version of the Authentic Theme.
More German, Norwegian and Catalan translation updates.
(Au passage si y a pas Let's encrypt c'est parce que wheezy est en LTS et que les déôts de Jessie sont verrouillé car stable, donc seulement les MAJs de sécu et pas d'upgrade du logiciel normalement).

Cordialement, janus57

sabinou
11/05/2016, 14h45
Citation Envoyé par madri2
letsencrypt n'est ni disponible en wheezy ni en jessie, donc si tu retires ce dépot tu n'aura plus les maj de letsencrypt

https://packages.debian.org/stretch/letsencrypt
Han. Je n'aurais pas cru que letsencrypt n'existerait que en version stretch, pas même en Jessie ou Wheezy. Je tenais pour évident que c'était un bug de faire appel à des backports. Donc, non, en fait, c'est légitime O_o

En somme, le cafouillage, dans ce cas, se situe du côté de mon panel qui a tort de m'envoyer des mails listant les backports, plutôt que du côté de letsencrypt. Bon, ça aurait été mieux d'avoir ça en version wheezy, mais voilà...

Je ne vois pas trop comment m'en dépatouiller, mais au moins, merci de m'avoir répondu, Madri!

Ah, je me demande, si quelqu'un sait...
Je présume qu'il n'y a aucun moyen de "restreindre" les packages parcourus pour des updates ? Genre: uniquement *letsencrypt* ?
(99.99% de certitude qu'on ne peut pas, mais je demande au cas où )

madri2
09/05/2016, 23h51
letsencrypt n'est ni disponible en wheezy ni en jessie, donc si tu retires ce dépot tu n'aura plus les maj de letsencrypt

https://packages.debian.org/stretch/letsencrypt

sabinou
09/05/2016, 21h33
Bon, j'ai pu avancer, avec de l'aide.

Il s'avère finalement que, en date du 2 mai 2016, j'ai un "wheezy-backports.list" qui est apparu dans /etc/apt/sources.list.d

Au début, je ne voyais pas POURQUOI j'ai eu ça qui s'est rajouté, mais en comparant les dates de fichier, je crois pouvoir le lier à la seule activité serveur manuelle le même jour, mon installation de letsencrypt (en suivant ce guide https://www.virtualmin.com/node/38853 ).

Dites, s'il vous plaît, à votre avis, je peux me permettre de désactiver /etc/apt/sources.list.d/wheezy-backports.list ( disons : /etc/apt/sources.list.d/wheezy-backports.list.niet ), ou ça risque de causer des problèmes à letsencrypt ?

Mon souci, c'est que j'ai cherché, mais je n'arrive pas à trouver d'explications claires pour Debian Wheezy, letsencrypt, et backport, comme mots clés, en recherche web... Au moins, je sais qu'il n'y a plus à s'en faire et que je peux ignorer les emails de notifications de mises à jour vers des backports sans me faire de mauvais sang.

Si quelqu'un de plus expérimenté s'y retrouve, j'apprécierai grandement de l'aide ou une opinion, merci !

sabinou
06/05/2016, 11h23
Hello tous,

Sur mon dédié (host-32 d'il y a maintenant trois ans, avec webmin + virtualmin à jour sur Debian Wheezy), j'ai un truc étrange bien que sans gravité (donc, pas de panique), depuis deux jours, je peux vous demander votre avis ?

Voilà : mon serveur est configuré pour m'envoyer automatiquement un email pour me notifier lorsqu'il y a des mises à jour à installer.

Cependant, pour les deux dernières séries de mises à jour mentionnées par email, quand je vais sur mon serveur, justement, rien, nada, Virtualmin ne trouve aucune mise à jour lui-même.

Je me dis que c'est un cafouillage mineur, une histoire de cache, allez savoir, alors je me connecte en SSH en root, et
apt-get update && apt-get upgrade -y

... mais toujours rien

Même topo pour le second email mentionnant des mises à jour, apt-get update, apt-get upgrade, rien à faire.

Bon, bien sûr, ça n'est pas grave, mais c'est simplement intriguant. Peut-être que je passe à côté d'un truc utile à savoir.
Vous avez déjà eu connaissance de situations pareilles, votre panel qui vous envoie un email au sujet de mises à jour fantômes ?
Il y aurait une solution, ou il suffit de patienter suffisamment longtemps ?

Merci si vous avez votre idée là-dessus

Ah, pour référence, si vous voulez, c'était ça les updates mentionnées dans mes deux mails.
Code:
An update to postfix from 2.9.6-2 to 2.11.2-1~bpo70+1 is available.
An update to bind9 from 9.8.4.dfsg.P1-6+nmu2+deb7u10 to 9.9.5.dfsg-4~bpo70+1 is available.
An update to spamassassin from 3.3.2-5+deb7u3 to 3.4.0-2~bpo70+1 is available.
An update to spamc from 3.3.2-5+deb7u3 to 3.4.0-2~bpo70+1 is available.
An update to postgresql-client from 9.1+134wheezy4 to 9.4+165+deb8u1~bpo7+1 is available.
An update to postgresql-client-common from 134wheezy4 to 165+deb8u1~bpo7+1 is available.
An update to postgresql-common from 134wheezy4 to 165+deb8u1~bpo7+1 is available.
An update to mailman from 2.1.15-1+deb7u1 to 2.1.18-2~bpo70+1 is available.
An update to subversion from 1.6.17dfsg-4+deb7u11 to 1.8.10-6+deb8u2~bpo70+1 is available.
An update to dovecot-core from 2.1.7-7+deb7u1 to 2.2.13-11~bpo70+1 is available.
An update to dovecot-gssapi from 2.1.7-7+deb7u1 to 2.2.13-11~bpo70+1 is available.
An update to dovecot-imapd from 2.1.7-7+deb7u1 to 2.2.13-11~bpo70+1 is available.
An update to dovecot-ldap from 2.1.7-7+deb7u1 to 2.2.13-11~bpo70+1 is available.
An update to dovecot-mysql from 2.1.7-7+deb7u1 to 2.2.13-11~bpo70+1 is available.
An update to dovecot-pgsql from 2.1.7-7+deb7u1 to 2.2.13-11~bpo70+1 is available.
An update to dovecot-pop3d from 2.1.7-7+deb7u1 to 2.2.13-11~bpo70+1 is available.
An update to dovecot-sieve from 2.1.7-7+deb7u1 to 2.2.13-11~bpo70+1 is available.
An update to dovecot-sqlite from 2.1.7-7+deb7u1 to 2.2.13-11~bpo70+1 is available.
Updates can be installed at ...
An update to postfix from 2.9.6-2 to 2.11.2-1~bpo70+1 is available.
An update to spamassassin from 3.3.2-5+deb7u3 to 3.4.0-2~bpo70+1 is available.
An update to spamc from 3.3.2-5+deb7u3 to 3.4.0-2~bpo70+1 is available.
An update to postgresql-client from 9.1+134wheezy4 to 9.4+165+deb8u1~bpo7+1 is available.
An update to postgresql-client-common from 134wheezy4 to 165+deb8u1~bpo7+1 is available.
An update to postgresql-common from 134wheezy4 to 165+deb8u1~bpo7+1 is available.
Updates can be installed at ...