OVH Community, votre nouvel espace communautaire.

Problème acivation SSL


buddy
11/05/2016, 19h52
Citation Envoyé par buddy
Apparement ovh à déjà reçu 250k certificats créer en moins de 48h.
Donc encore 10 jours apparement pour créer les 1.25M manquants
Cf
https://mobile.twitter.com/olesovhco...36216404459525

Apparemment, c'est pour dans quelques jours / quelques heures
https://twitter.com/ovh_fr/status/729978722212827136

chaveziste
07/05/2016, 13h14
Bonjour,
Je ne sais pas si le problème viens de là, mais depuis hier j'ai des liens de mon site qui redirige en https et qui m'envoie sur une page d'avertissement de firefox :
"La connexion n'est pas sécurisée"

En me connectant sur OVH et tache en cours j'ai vu un truc avec le ssh (désolé j'ai pas noté le message exact) et le problème a disparu après avoir vidé tous les caches (sur wordpress supercache et cdn ovh).

Ce matin rebelote, j'ai eu le même problème, j'ai essayé de bidouiller, puis j'ai du réinstaller mon site, facilement et rapidement avec l’excellent Akeeba backup, et lors de la réinstallation Akeeba m'a indiqué qu'il devait modifier la base de donnée pour que toutes mes url redirige en http et non en https, donc il y aurait eu une modification de quelque chose dans la base de donnée, mais est-ce que cela vient d'ovh ou d'un plugin je ne sais pas ?

buddy
06/05/2016, 09h17
Citation Envoyé par Ludo.H
Bonjour,

Oui c'est générer en partie, on a ensuite pris un peu de temps pour optimiser les choses.
Pour le nombre, c'est coté letsencrypt, j'ai pas les chiffres de ce qui reste à faire.
Un ETA à 10 jours a été annoncé, il faut leur laisser le temps de traiter la demande.

Cdt,
Apparement ovh à déjà reçu 250k certificats créer en moins de 48h.
Donc encore 10 jours apparement pour créer les 1.25M manquants
Cf
https://mobile.twitter.com/olesovhco...36216404459525

ppaky
29/04/2016, 10h58
La première url était bien dans le chemin indiqué , mais celle avec le "font" non
Plus qu'une et c'est bon

buddy
29/04/2016, 10h53
Je ne sais pas comment marche prestashop, mais je dirais dans les fichiers du thème.

apparement, c'est dans un dossier themes / nom du theme / puis surement un fichier du style header ou quelque chose du genre ...

avec notepad++ vous pouvez ouvrir tous les fichiers de votre thème et chercher dans lequel il y a le lien fonts.googleapis.com

ppaky
29/04/2016, 10h50
Ou puis je modifier cela ? Ça doit être vite fait mais je ne sais pas où trouver leur emplacement

buddy
29/04/2016, 10h46
il y a déjà


puis le plus important je pense car récupéré au chargement de la page par tous les navigateurs


si c'est possible, il faudrait mettre

ou

ppaky
29/04/2016, 10h41
Elle est en ligne vous pouvez y accéder.

buddy
29/04/2016, 10h37
non, aucun problème.
Mais sinon vous faites avec firefox, afficher le code source de la page puis CTRL+F http:// vous devriez les trouver rapidement

ppaky
29/04/2016, 10h36
Je peux mettre le site en ligne quelque instant si vous souhaitez , si ça ne pose pas de soucis particulier pour me référencement etc..

buddy
29/04/2016, 10h23
Oui, le site étant hors ligne, je ne peux pas vous aider.

Bon courage.

NB: pensez à vider le cache de votre navigateur à chaque modif pour la voir apparaître.

ppaky
29/04/2016, 10h20
Mon domaine c'est paak-apparel.com
Mais pour le moment il est en maintenance , il me reste quelques détails à terminer avant de le mettre en ligne.
Jai trouvé quelque lien encore en http que j'ai corrigé mais il doit en rester d'après Firefox.

buddy
29/04/2016, 10h06
si tu veux donnes nous le domaine on regardera.

Le contenu mixte c'est du http:// qui traine dans la page. généralement des liens vers des images / CSS.

Normalement, une fois que tu as forcé le https, prestashop corrige les liens. après c'est possible qu'il faille éditer à la main les thèmes perso ..

ppaky
29/04/2016, 10h05
Sur ma page d'accueil firefox détecte du contenu mixte comment puis le corriger ?

buddy
29/04/2016, 10h03
de rien.

désolé pour l'incompréhension.

tld = top level domain

ppaky
29/04/2016, 09h59
Cela fonctionne bien ! Avant je remplaçait vraiment par ".tld" je ne savais pas que ça correspondait à .com .fr etc.. Du coup j'ai mis .com et cela fonctionne, merci

buddy
29/04/2016, 09h53
Je n'ai pas bien compris, mais il faut remplacer tonsite.tld par , par exemple, maboutique.fr ou maboutique.com (enfin le nom de domaine complet).

ppaky
29/04/2016, 09h52
Lorsque je tape https://monsite.tld mon navigateur me redirige vers une erreur de chargement

- - - Mise à jour - - -

Ah d'accord je ne savais pas que tld regroupait toutes les extensions ..

buddy
29/04/2016, 09h45
Citation Envoyé par ppaky
@buddy Lorsque je réalise cette étape "Puis tout en haut dans Activer le SSL cliquez sur : "Cliquez ici pour utiliser le protocole HTTPS avant d'activer le mode SSL."" une fenêtre s'ouvre en page introuvable c'est normal ?
Je ne sais pas, je ne connais pas prestashop, le mieux est de chercher de l'aide sur les forums dédiés à prestashop.

vérifie quand même que l'url est bonne. (si tu te trompes en tapant https://tonsite.tld, çà ne marche plus ..

Jikoo
29/04/2016, 09h30
Citation Envoyé par Ludo.H
@Jikoo les modifications d'IP sont les bonnes, pour moi https://www..com fonctionne très bien.
Oui, Ludo. Tout fonctionne normalement après le changement d'adresse. Merci à vous et @buddy.

ppaky
29/04/2016, 09h11
@buddy Lorsque je réalise cette étape "Puis tout en haut dans Activer le SSL cliquez sur : "Cliquez ici pour utiliser le protocole HTTPS avant d'activer le mode SSL."" une fenêtre s'ouvre en page introuvable c'est normal ?

buddy
29/04/2016, 09h03
Google t'indique qu'il faut faire encore 2 ou 3 manips : https://www.evxonline.com/guides/70-...restashop.html

ppaky
29/04/2016, 09h01
Que dois-je faire pour régler ce soucis car je suis nuis pas un spécialiste des langages informatiques ..

Ludo.H
29/04/2016, 08h59
Bonjour,

@ppaky, votre SSL est bien là et est bien configuré.

Cependant votre .htaccess fait la redirection : https -> http du coup vous n'utiliser pas le https.
Cela vient probablement de votre configuration prestashop.

Cdt,

Ludo.H
29/04/2016, 08h47
Bonjour,

@Jikoo les modifications d'IP sont les bonnes, pour moi https://www..com fonctionne très bien.

@ppaky je regarde

Cdt,

ppaky
29/04/2016, 08h38
Bonjour,
Cela fait plus de 48 h que j'ai acheté le certificat ssl, il est noté certificat ssl "oui" dans hébergement. Cependant la connexion est toujours considéré comme non sécurisé sur mon site.

Jikoo
28/04/2016, 22h50
Merci buddy.
J'en ai trouvé une sur le manager OVH (46.105.x.x).
Je teste le changement d'IP.

buddy
28/04/2016, 22h41
Généralement les ips avec ssl commencent par 46.xx

Essaye de regarder par mail si tu n'as pas une ip de ce style.

Jikoo
28/04/2016, 20h04
Citation Envoyé par buddy
quel est ton site ou l'ip vers laquelle il pointe ?
Hello buddy,
213.186.33.19

buddy
28/04/2016, 20h02
quel est ton site ou l'ip vers laquelle il pointe ?

Jikoo
28/04/2016, 19h44
Ludo.H, je vous contacte par mail.
Je suis un ancien beta testeur du SSL https://forum.ovh.com/showthread.php/104868 et je viens de perdre l'accès sécurisé sur le site (= plus d'accès en SSL/TLS sur mon site :/). Pourtant, sur le manager, il est marqué dans "Informations générales" : Certificat SSL --> Oui
Je pense qu'il faut que que change une adresse IP ou DNS.

romainfl
28/04/2016, 13h23
Super !
Merci bien !

Ludo.H
28/04/2016, 11h14
Bonjour,

Oui c'est générer en partie, on a ensuite pris un peu de temps pour optimiser les choses.
Pour le nombre, c'est coté letsencrypt, j'ai pas les chiffres de ce qui reste à faire.
Un ETA à 10 jours a été annoncé, il faut leur laisser le temps de traiter la demande.

Cdt,

buddy
28/04/2016, 10h49
Il est possible de savoir où ça en est (en nombre)
Par curiosité.

Exemple 0.2M sur les 1.5M totaux.

Je pensais que vous aviez déjà commencer à les faire générer par letsencrypt.

Ludo.H
28/04/2016, 10h32
Bonjour,

Ce sera en effet automatique.
Il faut attendre que letsencrypt génère les 1.5 Millions de certificats.

https://twitter.com/olesovhcom/statu...08706494619649

Cdt,

buddy
27/04/2016, 20h56
c'est automatique normalement (il suffit de taper l'adresse avec https://tonnomdedomaine.tld

Le 25 Avril sur la mailling list, ils annonçaient :
ETA 10 jours :
---------
- Bouton d'accés aux logs séparés pour les multisites
- Le SSL pour tous

romainfl
27/04/2016, 20h51
Et pour les cert Let's Encrypt, on passe par où ?

ppaky
25/04/2016, 19h32
Bonjour, je viens de passer commande , tout devrait fonctionner, merci!
Lorsqu'il sera activé j'ajouterais [Résolu] sur mon sujet !

Ludo.H
25/04/2016, 11h12
Bonjour,

Vous devriez pouvoir désormais commander un SSL.

Cdt,

ppaky
23/04/2016, 12h48
Bonjour,
Mon nom de domaine est paak-apparel.com.
Je vous remercie, tenez moi au courant lorsque je pourrais acheter le certificat ssl

Ludo.H
22/04/2016, 13h03
Bonjour,

Pouvez vous me communiquer votre nom de domaine ou votre NIC que je supprime la référence au certificat Let's encrypt.
Comme ceci vous pourrez acheter un certificat via le Manager.

Cdt,

ppaky
21/04/2016, 18h50
Ou puis je joindre le support?
J'ai appelé toute la journée sans réponse ..
Cordialement,
Pierre

Ludo.H
21/04/2016, 18h22
Bonjour,

Vous possédez déjà un certificat SSL gratuit (let's encrypt).
Il devrait très bientôt être possible de l'utiliser à la demande (en cours de déploiement).
Si vous tenez vraiment à utiliser un certificats SSL autre (payant) il faut joindre le support.

Cdt,

ppaky
21/04/2016, 18h11
Bonjour, j'ai souscrit à une offre perso2014 il y a un peu plus d'un mois ( sans SSL) cependant dans mon espace client dans la catégorie hébergement il est écrit "Certificat SSL : Oui".
Aujourd'hui mon site est encore en construction il est donc en maintenance et je souhaite y ajouter le SSL via OVH cependant je n'y parvient pas puisqu'il m'annonce que je le possède déjà.

Par conséquent je me suis rendu sur la page ssl de ovh pour le commander , il me demande d'y entrer mon nom de domaine cependant après deux possibilités s'offrent à moi : Vous êtes le titulaire du nom de domaine et souhaitez le renouveler
Vous êtes le titulaire du nom de domaine et souhaitez le gérer dans votre manager

La seconde me redirige vers mon espace client donc inutile puisque le certificat ssl est sur "oui" et par conséquent on ne me propose pas de l'acheter. La première me propose des offres mais aucune n'est au prix de 60€TTC comme indiqué précédemment sur la page.
Je me demande donc que dois je faire pour avoir le ssl sur mon site.

Dans l'attente de lire vos réponses.