OVH Community, votre nouvel espace communautaire.

Comment augmenter la memoire alloue au Php


chaveziste
02/10/2016, 09h50
Ok, merci !

"A mes yeux, seule la ligne de commande « ini_set( 'memory_limit', '512M' ); » est utile et nécessaire.
Mais je ne suis pas spécialiste de Wordpress. "

Moi non plus je ne suis pas spécialiste, mais je me suis dis qu'il était logique de tout mettre à 512.

Si il y a un spécialiste de wordpress qui peut donner son avis, cela m’intéresse, pour l'instant j'ai fais la modif que sur un petit site, je vais attendre un peu avant de changer l'autre.

Gaston_Phone
02/10/2016, 09h38
Citation Envoyé par Cehem-63
Non je pense que ses grands yeux c'était uniquement pour te dire "alors, t'as essayé, quoi, oui ou non!?!?!"
Voui. Tout à fait.

- - - Mise à jour - - -

A mes yeux, seule la ligne de commande « ini_set( 'memory_limit', '512M' ); » est utile et nécessaire.
Mais je ne suis pas spécialiste de Wordpress.

Cehem-63
02/10/2016, 09h31
Bonjour,

Non je pense que ses grands yeux c'était uniquement pour te dire "alors, t'as essayé, quoi, oui ou non!?!?!"

chaveziste
02/10/2016, 09h19
Bonjour,

Je viens de le faire, j'ai changé cela sur mon fichier wp-config.php :

define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

ini_set( 'memory_limit', '512M' );

Et cela a l'air de fonctionner sans problème, mais je vois les grands yeux de Gaston_phone, est-ce qu'il y a des risques ?

Gaston_Phone
15/04/2016, 18h54
As-tu essayé ? ? ?

janus57
15/04/2016, 15h29
Bonjour,

ou sinon il suffit de passer à PHP-FPM pour voir cette limité passer à 512M =)

Cf : http://fpm5.6-check.cluster015.ovh.net/phpinfo.php

Cordialement, janus57

Gaston_Phone
15/04/2016, 12h42
S.G.D.G. essaie dans tes scripts : ini_set('memory_limit', '256M');

- - - Mise à jour - - -

Essaie le bout de script suivant :
Code PHP:
echo "Taille mémoire ="memory_get_usage() ."
\n"
;
ini_set('memory_limit''256M');
echo 
"Taille mémoire ="memory_get_usage() ."
\n"


hesopia
15/04/2016, 11h10
Citation Envoyé par Nowwhat
Exact.
Cette valeur est codé dans le "php.ini", un des ces fichiers de config qui n'est (logiquement) pas accessible sur un serveur mutualisé.
J'ai le même souci. J'ai installé un thème qui nécessite des plugins.

Dans le "system status" du thème, j'ai le message suivant : "40 MB - We recommend setting memory to at least 128MB.
To import classic demo data, 256MB of memory limit is required.
Please define memory limit in wp-config.php file."

J'ai modifié le "wp-config.php" mais j'ai toujours le même message d'erreur.
Pouvez-vous m'aider svp.
Merci d'avance,

Nowwhat
13/04/2016, 12h54
Exact.
Cette valeur est codé dans le "php.ini", un des ces fichiers de config qui n'est (logiquement) pas accessible sur un serveur mutualisé.

Gaston_Phone
13/04/2016, 11h47
Citation Envoyé par furfing
comment puis-je augmenter la memoire alloue au php sous wordpress ?

40 MB - We recommend setting memory to at least 128MB.
To import classic demo data, 256MB of memory limit is required.
Il me semble qu'en mutualisé PERSO, la taille mémoire maximum disponible est 64 Mo.

furfing
13/04/2016, 09h36
bonjour a tous,

je suis en mutualise.

comment puis-je augmenter la memoire alloue au php sous wordpress ?

40 MB - We recommend setting memory to at least 128MB.
To import classic demo data, 256MB of memory limit is required.
Please define memory limit in wp-config.php file. To learn how, see: Increasing memory allocated to PHP.

j'ai effectue la modif dans le wp-conf. mais il semble que cela ne change rien.

merci