OVH Community, votre nouvel espace communautaire.

SSL certificat invalide


fritz2cat
09/04/2016, 14h16
+1 pour la qualité du support !

kuzko
08/04/2016, 17h42
Citation Envoyé par Ludo.H
Votre configuration pour PHP est la suivante :

Dans votre racine (/homez.713/nuabee) :

Code:
# cat .ovhconfig 
app.engine=phpcgi
app.engine.version=5.6
http.firewall=none
environment=development
Cependant dans votre répertoire www (/homez.713/nuabee/www) :

Code:
# cat www/.ovhconfig 
app.engine=php
app.engine.version=5.5
http.firewall=none
environment=production
Vous êtes donc bien en php 5.5 pour le site hébergé dans www.

J'ai retesté sur plusieurs machine, avec différents navigateur.
La page se charge en SSL sans soucis.

Cdt,
Ok, bon et bien merci, une réécriture de ma zone dns, un flush complet de mes caches sur mon infra et une modification du .ovhconfig me permettent de me connecter.
topic solved !

Ludo.H
08/04/2016, 17h18
Votre configuration pour PHP est la suivante :

Dans votre racine (/homez.713/nuabee) :

Code:
# cat .ovhconfig 
app.engine=phpcgi
app.engine.version=5.6
http.firewall=none
environment=development
Cependant dans votre répertoire www (/homez.713/nuabee/www) :

Code:
# cat www/.ovhconfig 
app.engine=php
app.engine.version=5.5
http.firewall=none
environment=production
Vous êtes donc bien en php 5.5 pour le site hébergé dans www.

J'ai retesté sur plusieurs machine, avec différents navigateur.
La page se charge en SSL sans soucis.

Cdt,

janus57
08/04/2016, 17h10
Bonjour,

vos DNS ne sont surement pas à jour :
Envoi d'une requête 'ping' sur nuabee.fr [46.105.39.218]
Envoi d'une requête 'ping' sur www.nuabee.fr [46.105.39.218]
J'ai comme DNS : opennicproject.org + google en fallback.

Cf : http://digwebinterface.com/?hostname...h&nameservers=

EDIT :
Code:
curl -LI https://nuabee.fr
HTTP/1.1 200 OK
Set-Cookie: mediaplanBAK=R129291918; path=/; expires=Fri, 08-Apr-2016 17:17:13 G                                                                                                                                                             MT
Date: Fri, 08 Apr 2016 16:11:47 GMT
Content-Type: text/html; charset=utf-8
Connection: keep-alive
Set-Cookie: mediaplan=R2045162885; path=/; expires=Fri, 08-Apr-2016 17:17:13 GMT
Server: Apache
X-Powered-By: PHP/5.5.31
Set-Cookie: fd63d8bd45c2b66d550923f99f3fb45b=26071401ff5dd9dcd350812f65ab7e78; p                                                                                                                                                             ath=/; secure; HttpOnly
Set-Cookie: da87c95e35e244de4ef1f52a1c965357=fr-FR; path=/; secure
Set-Cookie: jfbconnect_permissions_granted=deleted; expires=Thu, 01-Jan-1970 00:                                                                                                                                                             00:01 GMT; Max-Age=0; path=/
P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
Expires: Wed, 17 Aug 2005 00:00:00 GMT
Last-Modified: Fri, 08 Apr 2016 16:11:47 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Vary: Accept-Encoding
Cordialement, janus57

kuzko
08/04/2016, 16h54
Citation Envoyé par Ludo.H
Tout est marqué dans mes précendants messages :

Dans le DNS :

1/ Si vous voulez du SSL : 46.105.39.218
2/ Si vous ne voulez pas du SSL : 213.186.33.17

Et le curl fonctionne bien :
[/code]
Alors non, déja la version de PHP ne corresponds pas a ce que j'ai demandé dans l'espace client (5.5 vs 5.6):
https://i.imgsafe.org/40e929a.jpg
ensuite mon curl complet ne passe pas et ca se confirme sur n'importe quel navigateur que le SSL ne passe pas :
https://i.imgsafe.org/728b826.jpg
L'IP dans le DNS corresponds a l'hote qui héberge le certificat SSL, mais non toujours pas. et il n'y a pas de 403, que ce soit en https en acceptant le certificat et une exception de securité ou en http, le site charge bien, mais sans ssl correct.

Ludo.H
08/04/2016, 16h35
Tout est marqué dans mes précendants messages :

Dans le DNS :

1/ Si vous voulez du SSL : 46.105.39.218
2/ Si vous ne voulez pas du SSL : 213.186.33.17

Et le curl fonctionne bien :

Code:
curl -LI https://nuabee.fr                               
HTTP/1.1 301 Moved Permanently
Set-Cookie: mediaplanBAK=R129296274; path=/; expires=Fri, 08-Apr-2016 16:54:08 GMT
Date: Fri, 08 Apr 2016 15:34:34 GMT
Content-Type: text/html; charset=iso-8859-1
Connection: keep-alive
Set-Cookie: mediaplan=R2045162885; path=/; expires=Fri, 08-Apr-2016 16:33:08 GMT
Server: Apache
Location: https://www.nuabee.fr/
Cache-Control: max-age=86400
Expires: Sat, 09 Apr 2016 15:34:34 GMT
Vary: Accept-Encoding

HTTP/1.1 403 Forbidden
Set-Cookie: mediaplanBAK=R129324588; path=/; expires=Fri, 08-Apr-2016 16:34:09 GMT
Date: Fri, 08 Apr 2016 15:34:36 GMT
Content-Type: text/html
Connection: keep-alive
Set-Cookie: mediaplan=R2045162885; path=/; expires=Fri, 08-Apr-2016 16:33:08 GMT
Server: Apache
X-Powered-By: PHP/5.5.31
Set-Cookie: fd63d8bd45c2b66d550923f99f3fb45b=6cfa23e13c2ebc7693e3b92f20cd3bb2; path=/; secure; HttpOnly
Set-Cookie: da87c95e35e244de4ef1f52a1c965357=fr-FR; path=/; secure
Cache-Control: max-age=86400
Expires: Sat, 09 Apr 2016 15:34:35 GMT
Vary: Accept-Encoding

kuzko
08/04/2016, 16h31
Citation Envoyé par Ludo.H
Bonjour,

C'est normal.

Le cluster où vous êtes hébergé est bien cluster006.ovh.net (213.186.33.17)
Par contre vous avez souscrit à un certificats SSL, la machine portant votre certificats est 46.105.39.218.

Pour faire simple (et je simplifie beaucoup) :

SANS SSL = client --> OVH --> Cluster006 (213.186.33.17) --> ServeurWeb (10.xxx)
AVEC SSL = client --> OVH --> HostedSSL (46.105.39.218) --> ServeurWeb (10.xxx)

Mais pour accéder à vos fichier, etc... vous passer toujours par le cluster006.
C'est juste que votre certificats est portée par une machine spécifique.

Cdt,
Ok, je saisis petit a petit, mais quelle IP dois-je indiquer dans mon DNS? l'une ou l'autre peu importe?
et Curl se plaint bien :

:~$ curl -LI https://ssl6.ovh.net -H "host: nuabee.fr"
HTTP/1.1 301 Moved Permanently
Set-Cookie: mediaplanBAK=R129293007; path=/; expires=Fri, 08-Apr-2016 16:33:08 GMT
Date: Fri, 08 Apr 2016 15:27:33 GMT
Content-Type: text/html; charset=iso-8859-1
Connection: keep-alive
Set-Cookie: mediaplan=R2045162885; path=/; expires=Fri, 08-Apr-2016 16:35:56 GMT
Server: Apache
Location: https://www.nuabee.fr/
Cache-Control: max-age=86400
Expires: Sat, 09 Apr 2016 15:27:33 GMT
Vary: Accept-Encoding

curl: (51) SSL: no alternative certificate subject name matches target host name 'www.nuabee.fr'

:~$ curl -LI https://www.nuabee.fr -H "host: nuabee.fr"
curl: (51) SSL: no alternative certificate subject name matches target host name 'www.nuabee.fr'

Ludo.H
08/04/2016, 16h27
Bonjour,

C'est normal.

Le cluster où vous êtes hébergé est bien cluster006.ovh.net (213.186.33.17)
Par contre vous avez souscrit à un certificats SSL, la machine portant votre certificats est 46.105.39.218.

Pour faire simple (et je simplifie beaucoup) :

SANS SSL = client --> OVH --> Cluster006 (213.186.33.17) --> ServeurWeb (10.xxx)
AVEC SSL = client --> OVH --> HostedSSL (46.105.39.218) --> ServeurWeb (10.xxx)

Mais pour accéder à vos fichier, etc... vous passer toujours par le cluster006.
C'est juste que votre certificats est portée par une machine spécifique.

Cdt,

kuzko
08/04/2016, 16h13
Citation Envoyé par Ludo.H
J'ai testé sur une machine, tout fonctionne bien :

Code:
# dig +short nuabee.fr                         
46.105.39.218

# curl -LI https://nuabee.fr -H "host: nuabee.fr"
HTTP/1.1 301 Moved Permanently
[...]
S'il y avait un soucis curl se plaindrait.
Par contre arrivé sur votre site j'obtiens un 403.

Cdt,
Bon alors je vous fais part d'un truc bizarre qui se passe avec le DNS :
regardez bien les images et cherchez bien l'erreur, en premier on vois que OVH m'indique comme IP 46.105.39.218
https://i.imgsafe.org/4f9c200.jpg
Ovh me donne cluster6 OVH comme hote :
https://i.imgsafe.org/4f3faa5.jpg
or :
https://i.imgsafe.org/2d34093.jpg
https://i.imgsafe.org/2d4e594.jpg

je veux bien croire que l'hébergement mutualisé est complexe, mais qu'on me donne une IP dans mon manager qui est pas celle de l'hote, faut m'expliquer?

Ludo.H
08/04/2016, 15h56
J'ai testé sur une machine, tout fonctionne bien :

Code:
# dig +short nuabee.fr                         
46.105.39.218

# curl -LI https://nuabee.fr -H "host: nuabee.fr"
HTTP/1.1 301 Moved Permanently
[...]
S'il y avait un soucis curl se plaindrait.
Par contre arrivé sur votre site j'obtiens un 403.

Cdt,

kuzko
08/04/2016, 15h38
Citation Envoyé par buddy
Il faut attendre plusieurs heures pour la propagation des DNS.

Si tu veux que çà aille plus vite chez toi, tu peux redémarrer électriquement ta box internet puis vider le cache DNS sur ton PC

Démarrer -> Exécuter -> tapez cmd
Dans la fenêtre DOS, tapez ipconfig /flushdns
nan mais j'ai verifié que j'ai la nouvelle bonne ip, c'est quasiment immédiat la, et puis si je n'avais pas la bonne ip, pourquoi mon site tournais encore avant mais m'affichais l'erreur?

buddy
08/04/2016, 15h33
Citation Envoyé par kuzko
Bon, l'IP a changée ok, mais j'ai toujours l'avertissement.https://i.imgsafe.org/928ee8f.jpg

Il faut attendre plusieurs heures pour la propagation des DNS.

Si tu veux que çà aille plus vite chez toi, tu peux redémarrer électriquement ta box internet puis vider le cache DNS sur ton PC

Démarrer -> Exécuter -> tapez cmd
Dans la fenêtre DOS, tapez ipconfig /flushdns

Ludo.H
08/04/2016, 15h29
Citation Envoyé par kuzko
Merci, mais ma question est donc la suivante, les IP des mutualisés changent souvent? et sans prévenir? m'enfin bref, merci beaucoup.
EDIT : Edit : heu ca ne change rien au problème : j'ai toujours un soucis de certificat sur https://www.nuabee.fr
Non les IP n'ont pas changé depuis des lustres.
Par contre il semblerait que le NIC Admin ai fait les changement de DNS, dans les logs :

Code:
2016-04-05 	: de63294-ovh add an entry in a DNS-Zone : .nuabee.fr A 213.186.33.17
2016-04-05 	: de63294-ovh delete an entry in a DNS-Zone : .nuabee.fr A 46.105.39.218
Cdt,

kuzko
08/04/2016, 15h28
Bon, l'IP a changée ok, mais j'ai toujours l'avertissement.https://i.imgsafe.org/928ee8f.jpg

kuzko
08/04/2016, 15h19
Citation Envoyé par buddy
chez moi, ton domaine pointe sur 213.186.33.17 ce qui est l'ip du cluster 6, il me semble que le SSL passe par une autre ip.
Ok, mon IP d'hôte d'hébergement a changé un peu trop vite et j'ai survolé ma configuration, merci !
Edit : heu ca ne change rien au problème : j'ai toujours un soucis de certificat sur https://www.nuabee.fr
- - - Updated - - -

Citation Envoyé par Ludo.H
Bonjour,

Je vois bien votre SSL.
Par contre votre configuration DNS n'est pas bonne.

Le champ "A" de votre domaine pointe vers l'IP du cluster "213.186.33.17" et non vers celle du hostedssl : "46.105.39.218"
Si vous changer l'IP dans le DNS tout devrait fonctionner normalement.

Cdt,
Merci, mais ma question est donc la suivante, les IP des mutualisés changent souvent? et sans prévenir? m'enfin bref, merci beaucoup.
EDIT : Edit : heu ca ne change rien au problème : j'ai toujours un soucis de certificat sur https://www.nuabee.fr

Ludo.H
08/04/2016, 15h13
Bonjour,

Je vois bien votre SSL.
Par contre votre configuration DNS n'est pas bonne.

Le champ "A" de votre domaine pointe vers l'IP du cluster "213.186.33.17" et non vers celle du hostedssl : "46.105.39.218"
Si vous changer l'IP dans le DNS tout devrait fonctionner normalement.

Cdt,

buddy
08/04/2016, 15h13
chez moi, ton domaine pointe sur 213.186.33.17 ce qui est l'ip du cluster 6, il me semble que le SSL passe par une autre ip.

kuzko
08/04/2016, 15h09
Citation Envoyé par buddy
Tu avais bien un certificat SSL payant @50€ HT/an ?

Tu as bien vérifié l'ip vers laquelle çà pointe.
Oui, et oui, l'ip du serveur pointé par le certificat correspond a mon hote et ce qui est indiqué dans ma zone A du nom de domaine.

buddy
08/04/2016, 15h09
c'est du spam je pense.

kuzko
08/04/2016, 15h08
Citation Envoyé par dannytrinh1996
what is your domain name, right, speak more clearly so that i can support you more.
wut?

buddy
08/04/2016, 15h06
Citation Envoyé par kuzko
Le voici : nuabee.fr
Tu avais bien un certificat SSL payant @50€ HT/an ?

Tu as bien vérifié l'ip vers laquelle çà pointe.

kuzko
08/04/2016, 14h58
Le voici : nuabee.fr

Ludo.H
08/04/2016, 14h42
Bonjour,

Pouvez-vous communiquer votre nom de domaine ?

Cdt,

kuzko
08/04/2016, 14h34
Bonjour,

Depuis 3 jours, je me prends des erreurs de certificats invalides (ssl certificate missmatch et ssl_error_bad_cert_domain, bah oui le certificat est edité pour ssl6.ovh.net et pas mon nom de domaine) et tous les navigateurs me disent que ma connection est possible pas sécurisé...
Alors vu que je peux pas laisser ca comme ca, cela fais pas serieux, que puis-je faire? il se passe quoi car je n'avais pas ce problème il n'y a même pas une semaine?
j'ai regardé mon .htaccess, j'ai bien les bonnes lignes conseillées par OVH ici : https://www.ovh.com/fr/hebergement-w..._mutualise.xml
Que dois-je faire maintenant?