OVH Community, votre nouvel espace communautaire.

Erreur FAILED_SSL_HANDSHAKE_EXCEPTION sur un paiement en ligne


Matmusia
25/07/2016, 16h53
Bonjour,

J'utilise le module SystemPay ainsi q'un certificat TLS géré par Let's Encrypt.

Contrairement aux messages précédents, j'ai toujours une erreur FAILED_SSL_HANDSHAKE_EXCEPTION renvoyée par les serveurs SystemPay lorsqu'ils tente de contacter une des URLs de notification en https.

webleon
07/04/2016, 08h56
Bonjour,

pareil chez moi ça refonctionne, merci !!

Bonne journée,
Thierry

flopet
07/04/2016, 08h03
Idem pour moi, tout refonctionne comme avant !
Content de voir que le forum est plus respectueux que la hotline

jstaeble
06/04/2016, 20h52
Bonsoir,

Le problème semble être résolu. Mes paiements sont bien notifiés ce soir.

Beluc
06/04/2016, 17h37
Citation Envoyé par jstaeble
Bonjour,

J'utilise sur mon site https://www.wydstjohn.com le paiement en ligne avec Payzen. L'URL de notification est en https.
Jusqu'à hier soir, aucun soucis. Tout se passait correctement et les paiements reçus étaient validés via cette URL de notification.

Or depuis aujourd'hui, les notifications sont rejetées avec cette erreur : FAILED_SSL_HANDSHAKE_EXCEPTION. Mon certificat SSL est tout neuf (installé début mars), et je n'ai rien touché entre hier et aujourd'hui.

En passant l'URL en http, le problème se résout, mais ce n'est tout de même pas normal !

Quelqu'un a-t-il une idée de ce qui se passe ?

Merci.
Jean-Baptiste
Bonjour,
je viens de changer la liste des ciphers acceptés.
voyez vous une évolution ?
Cdlt,

webleon
06/04/2016, 17h04
(mon premier et mon dernier message n'apparaissent pas, ils sont soumis à modération, sûrement à cause d'url ?)

Pour ma part la requête provient d'un système de paiement (payzen ou systempay), donc on ne peut pas appliquer cette modif, mais merci de l'avoir postée, ça servira à d'autres. Pour l'instant on en est à 24h de panne. Puis nous y sommes pour rien, c'est du mutualisé avec un ssl sur lequel on a aucune maîtrise, il faut juste qu'il fonctionne correctement...

Bonne soirée,
Thierry

webleon
06/04/2016, 16h50
Citation Envoyé par flopet
J'ai eu le même problème.
J'ai résolu le problème en tapant dans le code mais je suis content de voir qu'il y a bien eu quelque chose de votre côté car au téléphone, c'est à peine si on ne m'a pas dit que j'étais un menteur incompétent...

Si ça peut intéresser, j'ai ajouté les lignes suivantes à mes appels CURL :


PS: Je viens de retester à l'instant (en retirant les lignes de code) et le problème est toujours présent.
Merci pour les lignes de code mais pour les sites qui utilisent payzen ou systempay, le curl ne se fait pas depuis notre site, on est donc complètement tributaire de la config OVH. 24h de panne pour l'instant. L'analyse par Qualys https://www.ssllabs.com/ssltest/analyze.html montre bien un pb dans les handshake on dirait ...

A suivre
Thierry

flopet
06/04/2016, 16h39
J'ai eu le même problème.
J'ai résolu le problème en tapant dans le code mais je suis content de voir qu'il y a bien eu quelque chose de votre côté car au téléphone, c'est à peine si on ne m'a pas dit que j'étais un menteur incompétent...

Si ça peut intéresser, j'ai ajouté les lignes suivantes à mes appels CURL :
curl_setopt($handle, CURLOPT_SSLVERSION, CURL_SSLVERSION_TLSv1);
curl_setopt($handle, CURLOPT_SSL_CIPHER_LIST, 'ECDHE-RSA-AES256-SHA');
PS: Je viens de retester à l'instant (en retirant les lignes de code) et le problème est toujours présent.

jstaeble
06/04/2016, 10h02
Bonjour,

J'ai remis la notification en HTTPS et je surveille les erreurs. Je vous tiens au courant.

webleon
06/04/2016, 09h56
Citation Envoyé par vcasse
Bonjour,

Nous avons eu un incident hier soir. C'est peut être lié.
Est ce que vous avez toujours le soucis ?

Cordialement,
Vincent
Bonjour,

Chez moi oui, souci toujours présent, dernier test à 10h46.
J'ai ouvert un ticket 2016040619019381

Merci
Thierry

vcasse
06/04/2016, 09h16
Bonjour,

Nous avons eu un incident hier soir. C'est peut être lié.
Est ce que vous avez toujours le soucis ?

Cordialement,
Vincent

webleon
06/04/2016, 08h24
Bonjour,

J'ai exactement la même erreur, en hébergement mutualisé OVH. Mon site utilise systempay.
Effectivement la solution de supprimer le https n'est pas convenable, on le met justement pour protéger les transactions.
Je suis aussi dans l'attente d'une solution, mais je vais poster un ticket à ce sujet dans le support.

Bonne journée,
Thierry

jstaeble
05/04/2016, 20h25
Bonjour,

J'utilise sur mon site https://www.wydstjohn.com le paiement en ligne avec Payzen. L'URL de notification est en https.
Jusqu'à hier soir, aucun soucis. Tout se passait correctement et les paiements reçus étaient validés via cette URL de notification.

Or depuis aujourd'hui, les notifications sont rejetées avec cette erreur : FAILED_SSL_HANDSHAKE_EXCEPTION. Mon certificat SSL est tout neuf (installé début mars), et je n'ai rien touché entre hier et aujourd'hui.

En passant l'URL en http, le problème se résout, mais ce n'est tout de même pas normal !

Quelqu'un a-t-il une idée de ce qui se passe ?

Merci.
Jean-Baptiste