OVH Community, votre nouvel espace communautaire.

Problème OpenSSL v0.9.8o


flopet
06/04/2016, 17h34
J'ai finalement résolu mon problème en ajoutant les lignes suivantes à mon code ? :
curl_setopt($curl, CURLOPT_SSLVERSION, CURL_SSLVERSION_TLSv1);
curl_setopt($curl, CURLOPT_SSL_CIPHER_LIST, 'ECDHE-RSA-AES256-SHA'); // Il faudra peut-être changer la valeur en fonction du certificat utilisé
C'est quand même dommage de devoir faire ça au bout de plusieurs mois alors que tout fonctionnait correctement jusqu'ici.

vcasse
06/04/2016, 10h15
Citation Envoyé par flopet
Bonjour vcasse,

Je viens de tester mais l'image ne semble pas être prise en compte.

Voici le contenu de mon .ovhconfig :
Bonjour Flopet,

Pourrais tu effectuer un phpinfo et vérifier la présence du mot "Mongo" ?
Utilises tu bien le port 83 ?
Attention : il se peut que wordpress effectue une redirection.

Cordialement,
Vincent

jstaeble
05/04/2016, 21h39
Bonjour,

Je rencontre un problème similaire avec mon paiement en ligne : https://forum.ovh.com/showthread.php...ement-en-ligne
Y aurait-il eu des modifications sur le SSL OVH aujourd'hui ?

flopet
05/04/2016, 18h51
Bonjour vcasse,

Je viens de tester mais l'image ne semble pas être prise en compte.

Voici le contenu de mon .ovhconfig :
; pour plus d'informations sur ce fichier:
; http://www.ovh.com/fr/g1175.format_du_point_ovhconfig

container.image=jessie.i386.r5
app.engine=php
app.engine.version=5.6

http.firewall=none
environment=development

vcasse
05/04/2016, 18h48
Bonjour flopet,

Nous sommes en train de déployer une infrastructure permettant de change d'environnement d'exécution à la volée.
Il est possible de la tester ici : https://forum.ovh.com/showthread.php...ble-drupal8%29

Elle devrait être disponible dans les jours qui viennent pour tout le monde.

N'hésitez pas à remonter vos feedbacks

Cordialement,
Vincent

flopet
05/04/2016, 18h24
Bonjour à tous,

J'utilise sur une offre perso un Wordpress (à jour) et un plugin maison faisant des appels à une API REST (via l'API HTTP de Wordpress mais j'ai le même problème en utilisant CURL) hébergée également sur cet hébergement (CodeIgniter).
Tout fonctionnait correctement jusqu'à aujourd'hui où j'obtiens l'erreur suivante sans avoir changé quoi que ce soit : "error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure".

Cette erreur suggère que l'hébergement est repassé à une version plus ancienne d'OpenSSL (0.9.8o d'après le phpinfo qui est bien une version obsolète).
De ce fait, toutes les fonctionnalités importantes du site ne fonctionnent plus ce qui représente un manque à gagner très important.

Certains d'entre vous rencontrent-ils le même problème ?

J'ai tenté d'appeler OVH mais comme d'habitude, ça ne répond pas ...

EDIT : J'ai enfin eu un technicien après 1h d'attente qui me dit que ça vient de mon code (on voit bien qu'il n'y connait rien en dev) et qui me dit me transférer vers le service incident pour en fait me raccrocher au nez ... Bravo OVH !!!