OVH Community, votre nouvel espace communautaire.

Upgrade vers jessie, pas de boot


arowan
30/03/2016, 11h11
Et si tu démarrais sur un kern du netboot?

Nowwhat
29/03/2016, 09h09
Également possible:

Inspecte /etc/default/grub
Trouve ceci
#GRUB_DEFAULT=x

Inspecte /boot/grub/grub.cfg - cherche les 'menuentry'

Choisi ton kernel (== numéro de 'menuentry') , et adapte
GRUB_DEFAULT=x
en conséquence (x est le numéro d'ordre)

Un coup de "update-grub"
et redémarrage.

Tout ça en mode rescue, après avoir mounté et chrooté.

Attention avec les kernel non-ovh (va voir /var/log/dmesg) : un kernel générique ne possède peut être pas tout le support hardware, spécifique au hardware d'OVH (c'est rare, mais ça arrive).
( Normalement, quand on choisi un nouveau kernel (par exemple 4.5 d'ici kernel.org - pourquoi pas) on utilise le config d'OVH (ici : ftp://ftp.ovh.net/made-in-ovh/bzImage/) d'un kernel déjà préparé le plus récent, et on utilise ce config pour compiler un nouveau. )

Arn_aud
28/03/2016, 23h44
Salut Nowwhat et merci pour la réponse.

Je me suis répondu il y a 5 min, mais apparemment le message est en attente de modération à cause d'un lien.
Le problème est résolu : comme j'ai installé un noyau debian ne venant pas d'OVH, j'ai dû faire un :

mv /etc/grub.d/06_OVHkernel /etc/grub.d/11_OVHkernel
grub-mkconfig
update-grub2

pour changer la priorité de boot des noyaux et c'était réglé.

Nowwhat
28/03/2016, 23h35
Salut,

Mes 'kernel' (initrd.img, etc) sont dasn /boot/, rien est dans /
Le MAJ d'apache2.4 est prévisible - suis passé par là.
"systemd", j'accepté aussi, mais je regretté un peu le vieux 'init'.
Mais un reboot m'a pas posé de soucis non plus (de mémoire, ça date, le passage vers Jessie).

Si un 'fdisk' (réparation disques) ne donne rien (en mode rescue) et mode rescue fonctionne bien - t'as accès à tes partions, sauvegarde tout (SFTP).
Puis de demande un clean install et tu restaure tes sites / bases / paramétrage.

Après mount des tes partitions, possible de chroot ?
T's sur que t'as qu'un /dev/sda ?? Pas un raid0 ou 1 ?
Smartctl t'as dit que tout est ok ?

T'as bien suivi le doc uniquement (il existe qu'un doc concernant ce sujet), c'est lui : https://www.debian.org/releases/stab...rading.fr.html

https://www.debian.org/releases/stab...html#nownownow

Arn_aud
28/03/2016, 23h27
Résolu : https://www.isalo.org/wiki.debian-fr...ebian_chez_ovh. et https://forum.kimsufi.com/showthread...y-jessie/page2

Arn_aud
28/03/2016, 22h52
Bonsoir,

Suite à une mise à jour vers jessie, je n'ai plus d'accès direct au serveur après le boot.
La mise à jour logicielle s'est plutôt bien passée, même si il a fallu refaire tous les fichiers de configurations de apache, ce n'était pas un problème.
Donc à l'issue de l'installation des nouveaux paquets, serveur web, mails, tout ça fonctionnaient bien.

Jusqu'au moment du redémarrage fatidique, qui m'a séparé de mon serveur préféré.
Le ping est ok, mais je n'accède ni à mes pages web, ni via ssh à mon serveur.

En mode rescue, je vois ( pas de lien symbolique initrd.img et vmlinuz à la racine ) qu'il manque un noyau ( ??? ), alors j'installe les paquets linux-base, linux-image-amd64, firmware-linux-free et linux-image-3.16.0-4-amd64, puis je fais un update-grub2 suivi d'un grub-install /dev/sda ( le tout en chroot ).

Cela n'a malheureusement pas suffi à récupérer le serveur lors d'un nième reboot.
Les logs ne disent rien et s'arrêtent au moment du premier reboot ( problème avec systemd ? ), donc je suis dans le brouillard total ( pas de ipmi configuré dans mon compte ).

J'ai naturellement une sauvegarde quotidienne des dossiers /home, /etc et /var, et j'aimerais faire une réinstallation complète qu'en dernier recours. Une idée pour sauver ma soirée ?

Merci d'avance.