OVH Community, votre nouvel espace communautaire.

Redirection de l'ancien site vers le nouveau sur le même hébergement


sebj1977
23/03/2016, 02h55
Bizarre Bizarre

Bonjour j ai des messages qui ne sont pas passer

Donc j'ai bien suivi ta méthode

Il me reste donc a supprimer wordpress dans l'affichage dans la barre d'adresse et régler le problème Typolight

encore merci pour votre aide

Sébastien

sebj1977
23/03/2016, 02h42
PS j'oubliai j'ai du remplacer l'index du site Typolight je l'ai renommé en index2.php et je n'ai plus accès au site une idée

Merci d'avance

sebj1977
23/03/2016, 02h37
Bonjour voila après quelques ennuis au niveau des DNS je repars

Donc voila ce qui a été fait

fichier .htaccess

Options -Indexes
Options -Multiviews
Options +FollowSymLinks
SetEnv REGISTER_GLOBALS 0
SetEnv PHP_VER 5
RewriteEngine On

# Pages d'erreur
ErrorDocument 401 /wordpress/page-derreur/
ErrorDocument 402 /wordpress/page-derreur/
ErrorDocument 403 /wordpress/page-derreur/
ErrorDocument 404 /wordpress/page-derreur/
ErrorDocument 500 /wordpress/page-derreur/
ErrorDocument 404 /wordpress/page-derreur/

Fichier index.php

header("HTTP/1.1 301 Moved Permanently");
header("Location: http://www.domaine.com/wordpress/index.php");
exit;
?>

résultat

www.domaine.fr .com sont rediriger vers www.domaine.com/wordpress/

j'aimerais qu'il soit afficher www.domaine.com dans la barre d'adresse plutôt que www.domaine.com/wordpress/

Merci d'avance

Sébastien

sebj1977
20/03/2016, 12h44
Citation Envoyé par Gaston_Phone
Tu peux appliquer une redirection simple par index.php compatible avec les robots de GOOGLE.
Voir l'exemple --> CMS - JOOMLA - Installation chez OVH
Pour résumé

J'ai fais

un fichier .htaccess

Options -Indexes
Options -Multiviews
Options +FollowSymLinks
SetEnv REGISTER_GLOBALS 0
SetEnv PHP_VER 5
RewriteEngine On

puis un fichier index.php

header("HTTP/1.1 301 Moved Permanently");
header("Location: http://www.domaine.com/wordpress/index.php");
exit;
?>

résultat

www.domaine.com pointe vers www.domaine.com/wordpress/index.php ici tous va bien

le problème est l'affichage de URL qui est www.domaine.com/wordpress/au lieu de www.domaine.com/

autre problème www.domaine.com/typolight renvoie au login de typolight sans pouvoir avoir accès au site

merci pour cette avancée

Sébastien

Gaston_Phone
20/03/2016, 09h56
Tu peux appliquer une redirection simple par index.php compatible avec les robots de GOOGLE.
Voir l'exemple --> CMS - JOOMLA - Installation chez OVH

sebj1977
20/03/2016, 04h22
Bonjour

Pour un client j'ai un site www.domaine.com qui pointe vers www.domaine.com/typolight
Sur le même hébergement j'ai un deuxième sites www.domaine.com/wordpress

L'objectif serai d'avoir www.domaine.com qui pointe vers www.domaine.com/wordpress
Et de garder l’accès de l'ancien site sur www.domaine.com/typolight

J'ai tenté une redirection dans l'interface ovh qui ma créer une boucle de redirection
J'ai remis les information par défaut copiées avant la modification

Merci d'avance pour votre aide

Sébastien