OVH Community, votre nouvel espace communautaire.

A vos feedbacks : changement de configuration (compatible drupal8)


vcasse
21/04/2016, 17h18
Bonjour à tous,

Nous venons de prodder les environnements d'exécution pour tous les hébergements web.
Je vous invite à poursuivre les discussions sur ce post : https://forum.ovh.com/showthread.php...370#post668370

Cordialement,
Vincent

Jikoo
18/04/2016, 00h27
Citation Envoyé par vcasse
Avant la fin du mois, ce nouveau système sera en production sur tous nos clusters.
Je viens de tester l'utilisation de MySQLnd , et ça marche nickel sur cluster010 avec un 90plan:
- PHP 7.0.5 + mysqlnd 5.0.12-dev
- PHP 5.6.20 + mysqlnd 5.0.11-dev
Génial !
Merci la team.

vcasse
12/04/2016, 12h18
Citation Envoyé par Cimarronweb
Bonjour,
Je viens de mettre en place votre solution provisoire, sans effet à notre problème de communication avec le serveur de notre partenaire.
Par avance merci pour votre aide.
Pierre
Bonjour,

Vous pouvez m'en dire plus ? Quelle est l'erreur ?

Cordialement,
Vincent

Cimarronweb
12/04/2016, 12h13
Bonjour,
Je viens de mettre en place votre solution provisoire, sans effet à notre problème de communication avec le serveur de notre partenaire.
Par avance merci pour votre aide.
Pierre

vcasse
08/04/2016, 10h05
Bonjour emicoma,

Avant la fin du mois, ce nouveau système sera en production sur tous nos clusters.

Cordialement,
Vincent

emicoma
07/04/2016, 19h27
Je viens d'installer un site drupal 8 selon vos directives, tout marche parfaitement sur le port 83
j'aimerais savoir quand (environ) on pourra s'affranchir de ce :83 ?
ou comment le 'camoufler' en attendant, genre monsite;com sans port derriere ?
merci..

am63
07/04/2016, 13h38
Effectivement ça marche !

Merci !

vcasse
07/04/2016, 12h07
Citation Envoyé par am63
Je tente de tester le container.image dans le ovhconfig, mais ça ne marche pas sur tous les hébergements que je gère !

container.image=jessie.i386.r5 donne bien openssl 1.x (c'est ce qui m'intéresse, vis à vis de la sandbox paypal) sur un hebergement pro ;

Cependant, sur un hébergement perso cluster 15, ça marche pas... Sur un perso cluster10, c'est ok. Va comprendre !

preuve : http://www.lesgrimoiresdestephane.fr:83/public/tt.php ; évidemment, le .ovhconfig est bien à la racine / et non pas dans /www.

Je comprends bien que c'est du beta pour l'instant tout ça, mais faudrait-il préciser que ça ne marche que pour certains types d'offres (ou alors tout le parc mutualisé n'a pas encore été mis à jour).

Feedback de la team ovh sur ce sujet ?
Bonjour am63,

Le cluster15 est de nouveau fonctionnel sur le port 83
Merci pour le feedback.

Cordialement,
Vincent

am63
07/04/2016, 10h07
Merci !

vcasse
07/04/2016, 10h02
Citation Envoyé par am63
Je tente de tester le container.image dans le ovhconfig, mais ça ne marche pas sur tous les hébergements que je gère !

container.image=jessie.i386.r5 donne bien openssl 1.x (c'est ce qui m'intéresse, vis à vis de la sandbox paypal) sur un hebergement pro ;

Cependant, sur un hébergement perso cluster 15, ça marche pas... Sur un perso cluster10, c'est ok. Va comprendre !

preuve : http://www.lesgrimoiresdestephane.fr:83/public/tt.php ; évidemment, le .ovhconfig est bien à la racine / et non pas dans /www.

Je comprends bien que c'est du beta pour l'instant tout ça, mais faudrait-il préciser que ça ne marche que pour certains types d'offres (ou alors tout le parc mutualisé n'a pas encore été mis à jour).

Feedback de la team ovh sur ce sujet ?
Il semble que ce soit un soucis de notre coté pour ce cluster. On regarde.

Cordialement,
Vincent

vcasse
07/04/2016, 09h48
Citation Envoyé par Iwazaru
Bonsoir,

J'ai une application PHP qui utilise git pour vérifier la disponibilité d'une nouvelle version et se mettre à jour si besoin. J'imagine que ce n'est pas un usage très répandu, mais bon... j'ai une quinzaine de sites utilisant cette application, donc c'est bien pratique. J'utilise Gitlib : http://gitonomy.com/doc/gitlib/master/

En activant l'image et en accédant à la page de mise à jour avec le port 83, j'ai une erreur PHP :
sh: 1: git: not found

Sur le port 80, tout va bien.
Bonjour lwazaru,

On regarde pourquoi cette différence existe. On te tiens au courant.

Cordialement,
Vincent

- - - Mise à jour - - -

Citation Envoyé par MM-Chris
Bonjour,

Sans vouloir faire mon chat noir, j'ai modifié le .ovhconfig pour faire pointer l'image sur jessie.i386.r5 et tenté de lancer mon site : http://monsite.com:83 : Erreur ERR_CONNECTION_REFUSED

J'ai oublié quelque chose ?
Bonjour MM-Chris,

Peux tu me communiquer le nom de domaine de ton site, que l'on regarde l'origine du probléme ?

Cordialement,
Vincent

am63
07/04/2016, 09h27
Je tente de tester le container.image dans le ovhconfig, mais ça ne marche pas sur tous les hébergements que je gère !

container.image=jessie.i386.r5 donne bien openssl 1.x (c'est ce qui m'intéresse, vis à vis de la sandbox paypal) sur un hebergement pro ;

Cependant, sur un hébergement perso cluster 15, ça marche pas... Sur un perso cluster10, c'est ok. Va comprendre !

preuve : http://www.lesgrimoiresdestephane.fr:83/public/tt.php ; évidemment, le .ovhconfig est bien à la racine / et non pas dans /www.

Je comprends bien que c'est du beta pour l'instant tout ça, mais faudrait-il préciser que ça ne marche que pour certains types d'offres (ou alors tout le parc mutualisé n'a pas encore été mis à jour).

Feedback de la team ovh sur ce sujet ?

MM-Chris
06/04/2016, 10h53
Citation Envoyé par vcasse
Salut tarzanjane,

Oui c'est possible : la configuration s'applique sur tout l'hébergement.
Mais pour le moment, elle n'est appliquée que sur le port 83 (c'est à dire http://monsupersite.ovh:83), donc les utilisateurs du site ne seront pas impactés actuellement.

Cordialement,
Vincent
Bonjour,

Sans vouloir faire mon chat noir, j'ai modifié le .ovhconfig pour faire pointer l'image sur jessie.i386.r5 et tenté de lancer mon site : http://monsite.com:83 : Erreur ERR_CONNECTION_REFUSED

J'ai oublié quelque chose ?

Iwazaru
05/04/2016, 23h34
Bonsoir,

J'ai une application PHP qui utilise git pour vérifier la disponibilité d'une nouvelle version et se mettre à jour si besoin. J'imagine que ce n'est pas un usage très répandu, mais bon... j'ai une quinzaine de sites utilisant cette application, donc c'est bien pratique. J'utilise Gitlib : http://gitonomy.com/doc/gitlib/master/

En activant l'image et en accédant à la page de mise à jour avec le port 83, j'ai une erreur PHP :
sh: 1: git: not found

Sur le port 80, tout va bien.

MaximeCorson
04/04/2016, 14h48
Bonjour et merci pour la mise en place de cette nouvelle configuration système.

De notre coté, nous avons pu effectuer avec succès des paiements via l'API sandbox de Paypal.
Quand pensez-vous pouvoir procéder au déploiement en production de ces configurations (port 80 et/ou 443) ?

Merci d'avance pour votre retour.
Cordialement,

OliV--
01/04/2016, 17h14
Bonjour,

une tâche OVH avait été ouverte pour Paypal
http://travaux.ovh.net/?do=details&id=16848

Du coup, j'ai tenté la manip et comme Orang Gila j'ai toujours OpenSSL/0.9.8o
Impossible de tester Paypal checkout sur la Sandbox

https://www.paypal-knowledge.com/inf...n_US&direct=en

Ca va commencer à être tendu niveau temps....

Orang Gila
01/04/2016, 16h14
Bonjour,

Comme je l'ai déjà écrit dans plusieurs posts, PHP et CURL d'OVH contiennent la version openSSL 0.9.8 au lieu de la version openSSL 1.0.1 nécessaire au bon fonctionnement sur la sandbox de Paypal. Elle sera obligatoire au mois de juin 2016.
Le SAV est au courant ....

etannouss
01/04/2016, 14h25
Bonjour,

Merci de ton retour. Oui j’espère bien , pas que pour moi mais pour les autres clients. Franchement dans une entreprise comme OVH ça ce fait pas .

En tous cas merci pour ton aide.

Cordialement
Elias

vcasse
01/04/2016, 14h19
Bonjour Elias,

Nous avons en effet eu un soucis de communication en interne. Nous fesons en sorte que cela ne se reproduise plus.
Je suis sincèrement désolé que tu n'ai pas été aiguillé correctement.

Le support va revenir vers toi pour tes demandes.

Cordialement,
Vincent

etannouss
31/03/2016, 17h16
Bonjour,

j’étais en contact avec le service technique de OVH depuis des semaines et je viens juste d'avoir une réponse concernant ceci. Et il m'affirmait que vos systèmes sont en 64 bits. C'est pour cela j'ai acheter les plugins.

Le plugin concernée permet d'importer des produit depuis le site aliexpress dans les sites que j'ai ! Mais malheureusement ces plugin sont en 64 bits et vos systèmes sont en 32bit. Du coup l'import de produit ne fonctionne pas.

Cordialement
Elias

vcasse
31/03/2016, 16h34
Bonjour etannouss,

Actuellement, nous ne proposons que des systèmes 32 bits.
Pourriez vous me fournir des informations à propos du plugins qui nécessite un système 64 bits ?

Cordialement,
Vincent

etannouss
31/03/2016, 14h28
Bonjour,

J'ai deux sites sur lequel j'ai installé wordpress dessus, et j'ai acheter des plugins aliexpress, qui fonctionne sur un System de 64bit que j'ai ajouter a wordpress.

En fin, après des semaines j'ai su que le système d'exploitation était en 32 bit !

Actuellement je veux tester les plugin, donc j'ai suivie la procédure et j'ai changer le fichier .ovhconfig et j'ai essayer d’accéder avec le port 83 . Mais j'ai eu aucun changement le système est toujours en 32bit !

Quelqu'un peu m'aider pour savoir comment basculer sur le système 64bit pour pouvoir tester mes plugin .

Merci de votre aide.

vcasse
31/03/2016, 13h34
Bonjour manu225,

Nous finalisons nos tests actuellement. Vos feedbacks sont bons donc ca devrait aller vite. Une question de jours si on ne tombe pas sur de mauvaises surprises.

Cordialement,
Vincent

manu225
30/03/2016, 16h55
Bonjour,

Merci pour les infos.
Effectivement le .ovhconfig n'était pas à la racine de mon dossier.
Maintenant qu'il y a est la connexion à la sandbox Paypal s'effectue sans souci avec CURL

Y a-t-il une date de prévu pour le passage de cette configuration en production ?

adudouit
29/03/2016, 14h29
Citation Envoyé par manu225
J'avais dans mon fichier .ovhconfig container.image=jessie.i386.r4, j'ai donc corrigé pour container.image=jessie.i386.r5
Effectivement, il y a eu une mise à jour de la configuration, qui a amené un changement de révision. D'où les potentiels problèmes de stabilité de la bêta évoqués plus haut ; mais ce n'est pas de là que vient l'erreur.

Citation Envoyé par manu225
Le fichier .ovhconfig est pourtant bien dans mon dossier /www et correct à priori.
Citation Envoyé par vcasse
1 / Est ce que le fichier de .ovhconfig à la racine contient bien "container.image=jessie.i386.r5" ?
Citation Envoyé par vcasse
QUELQUES DETAILS TECHNIQUES
L'option "container.image=nom_dimage_valide_parmi_une_liste _fournie" doit être obligatoirement spécifiée dans le .ovhconfig qui est à la racine de votre dossier utilisateur.
L'erreur est ici. Il s'agit de la racine de votre dossier utilisateur, et non pas de l'hébergement/site/sous-site/etc. en question. Cette option impacte *tous* les sites d'un même compte, d'où sa spécification à un niveau indépendant de toute notion de site. Il y aura toujours un dossier $HOME.
Ce fichier peut être incomplet, en ne contenant que cette directive (-> ).

manu225
29/03/2016, 13h49
Bonjour,

Oui j'utilise bien le port 83 pour faire mes tests.
J'avais dans mon fichier .ovhconfig container.image=jessie.i386.r4, j'ai donc corrigé pour container.image=jessie.i386.r5 mais toujours le même problème.
En faisant le test du phpinfo je ne trouve pas mongo que ce soit en testant à la racine ou sur un sous dossier.

Le fichier .ovhconfig est pourtant bien dans mon dossier /www et correct à priori.

vcasse
25/03/2016, 17h26
Bonjour manu225,

Je viens de faire le test, et je n'ai aucun soucis (avec le même code).
Par contre, quand je désactive l'image, j'obtiens la même erreur.

Alors quelques pistes :
1 / Est ce que le fichier de .ovhconfig à la racine contient bien "container.image=jessie.i386.r5" ?
2 / Vérifiez que vous êtez bien sur le port 83 comme sur cette adresse "www.urldetest.com:83"

Pour vérifier si cela fonctionne, vous pouvez créer un fichier phpinfo.php contenant "". Si la page contient le terme "mongo", c'est bon. Sinon c'est pas actif !

Cordialement,
Vincent

vcasse
25/03/2016, 15h45
Bonjour manu225,

Merci pour ce bout de code. Je regarde si on reproduit le soucis et si le nouvel environnement le modifie.

Cordialement,
Vincent

manu225
25/03/2016, 13h53
Citation Envoyé par vcasse
Salut Manu225,

Comment récupérer vous ce log ?

Est ce que paypal tente de se connecter sur le port 83 ?

Cordialement,
Vincent
Bonjour,

Il s'agit d'une erreur CURL récupérer en PHP. Voici le bout de code :

Code:
// Step 2: POST IPN data back to PayPal to validate
$ch = curl_init('https://www.sandbox.paypal.com/cgi-bin/webscr');
curl_setopt($ch, CURLOPT_POST, 1);
curl_setopt($ch, CURLOPT_RETURNTRANSFER,1);
curl_setopt($ch, CURLOPT_POSTFIELDS, $req);
curl_setopt($ch, CURLOPT_HTTPHEADER, array('Connection: Close'));
	
if( !($res = curl_exec($ch)) ) {
	echo 'Error CURL : '.curl_error($ch)."\r\nRequest : ".$req);

adudouit
23/03/2016, 11h40
Citation Envoyé par WP-Ju
les problèmes actuels viennent du fait que la version bêta utilise un port différent du port standard (80)
Ainsi que de la bêta elle-même ; par exemple, le maintien de certains programmes/versions qui ne sont plus supportés peut poser quelques problèmes de stabilité. En ce moment, nous cherchons à corriger un problème apparu sur PHP avec (uniquement) le couple 5.3/CGI (car la compilation de cette version est très capricieuse et demande des outils dépréciés depuis quelques temps déjà...).
Et les problèmes de paquets manquants, puisque l'objectif est de les relever pour les y intégrer ; ainsi, la prochaine révision de la nouvelle configuration apportera, par exemple, Python 3, suite à un besoin remonté par un utilisateur après quelques essais.

Citation Envoyé par WP-Ju
Autrement dit, il n'y a aucun soucis particulier à faire cette mise à jour sur un site en production pour le moment ?
C'est une bêta pour relever les problèmes.
La nouvelle configuration est globalement stable (et ne devrait pas avoir de raison de ne pas l'être), mais rien n'est garanti, et aucun support ne peut être apporté ; et si ça n'avait pas été par le port 83, il aurait fallut amener un contrat-type d'avant-première pour y accéder.
Par exemple, l'utilisation de mysqlnd n'est pas anodine, car il n'est désormais plus possible de spécifier un encodage différent de celui du serveur de base de données ; ainsi, seul l'utf-8 peut être utilisé. Ou alors, le fait que le nom de l'image soit amené à changer : avec les montées de révision lors de la bêta, et avec un autre schéma de nommage lors du passage en production. Et prenez en compte que le port 83 n'est qu'une solution temporaire.

Donc non, ce n'est pas recommandé pour de la production.

WP-Ju
23/03/2016, 08h46
Bonjour,

Citation Envoyé par adudouit
Pile là où le système de bêta pèche. Version courte : non, avec un "mais".
La nouvelle configuration supporte très bien Wordpress. Mais, Wordpress redirigeant en permanence sur le port 80 par défaut, dans les conditions de la bêta c'est plus difficile. À moins d'empêcher cela, non (pour l'instant).
Si j'ai bien compris, les problèmes actuels viennent du fait que la version bêta utilise un port différent du port standard (80). Autrement dit, il n'y a aucun soucis particulier à faire cette mise à jour sur un site en production pour le moment ?

Merci de votre réponse !

adudouit
22/03/2016, 17h05
Citation Envoyé par den44
Bonjour pouvons nous avoir la même chose avec un wordpress ?
Pile là où le système de bêta pèche. Version courte : non, avec un "mais".
La nouvelle configuration supporte très bien Wordpress. Mais, Wordpress redirigeant en permanence sur le port 80 par défaut, dans les conditions de la bêta c'est plus difficile. À moins d'empêcher cela, non (pour l'instant).

den44
22/03/2016, 14h32
Bonjour pouvons nous avoir la même chose avec un wordpress ?
Merci

vcasse
17/03/2016, 12h41
Salut Manu225,

Comment récupérer vous ce log ?

Est ce que paypal tente de se connecter sur le port 83 ?

Cordialement,
Vincent

manu225
17/03/2016, 10h26
Bonjour,

Je viens de faire quelques tests et à priori toujours le même problème de SSL lors de la connexion à la sandbox Paypal :
error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

7tonin
16/03/2016, 18h42
Ok, je n'avais pas tenu compte du message #14
Autrement dit container.image=jessie.i386.r4 n'était pas dans le niveau 1, mais dans le niveau 2 (mauvais endroit)

Et voilà après retour dans le droit chemin :
http://dev.monsite.tld/phpinfo.php#module_mysql dit php 5.6.17 avec mysql 5.1.73
http://dev.monsite.tld:83/phpinfo.php#module_mysql dit php 5.6.19 avec mysqlnd 5.0.11-dev - 20120503

adudouit
16/03/2016, 08h52
Citation Envoyé par 7tonin
http://dev.monsite.tld/phpinfo.php#module_mysql dit php 5.6.17 avec libmysql 5.1.73
http://dev.monsite.tld:83/phpinfo.php#module_mysql dit php 5.6.19 avec libmysql 5.1.73
Je pense que vous vous trompez. La libmysql n'existe tout simplement plus sur cette nouvelle configuration, car elle a été remplacée par mysqlnd. Vous devriez donc plutôt voir apparaître
Code:
mysqlnd 5.0.11-dev
avec la version 5.6.19 (pour la nouvelle configuration).

Pour l'explication, PHP peut utiliser deux drivers pour MySQL : la libmysql, externe, ou le driver mysqlnd, maintenu par les développeurs de PHP. Ce dernier est plus souvent mis à jour, mieux maintenu, et offre plus de fonctionnalités, d'où ce choix.

adudouit
16/03/2016, 08h46
Citation Envoyé par tarzanjane
Code:
Warning: Zend OPcache API is restricted by "restrict_api" configuration directive in system_requirements() (line 244 of core/modules/system/system.install).
Pouvez-vous m'éclairer ?
Bien entendu.

Il s'agit malheureusement d'un problème lié à Drupal 8, et à des vérifications beaucoup trop strictes sur OPcache (-> ). Ce qui explique que vous l'ayez retrouvé après avoir ajouté la ligne (s'il s'agit bien de la ligne container.image), l'erreur était déjà présente avant.
Je ne peux que vous conseiller d'appliquer le correctif proposé sur le bug report de Drupal, en attendant qu'il soit disponible sur leur version stable.

7tonin
15/03/2016, 21h45
J'obtiens à très peu près les même messages.
J'ai en outre ajouté un fichier pour lire le phpinfo.

http://dev.monsite.tld/phpinfo.php#module_mysql dit php 5.6.17 avec libmysql 5.1.73
http://dev.monsite.tld:83/phpinfo.php#module_mysql dit php 5.6.19 avec libmysql 5.1.73

or il nous faudrait libmysql > 5.5.3

Je dirais qu'on s'approche encore... ô patience, quand tu nous tiens en haleine

tarzanjane
15/03/2016, 17h58
Bonjour,

J'ai testé l'installation et j'ai une erreur. Voici ce que j'ai fait :
1 - J'ai ajouté la ligne "container.image=jessie.i386.r4" dans le fichier .ovhconfig, à la racine du site.
Code:
; pour plus d'informations sur ce fichier:
; http://www.ovh.com/fr/g1175.format_du_point_ovhconfig

container.image=jessie.i386.r4

app.engine=php
app.engine.version=5.6

http.firewall=none
environment=production
2 - J'ai transféré Drupal dans un sous-dossier "www/dev/"

3 - J'ai créé un sous-domaine "http://dev.monsite.tld" qui redirige vers le sous-dossier précédemment créé

4 - Lorsque j'accède à l'installateur via l'adresse "http://dev.monsite.tld:83/", j'ai plusieurs erreurs qui s'affichent
Code:
Warning: Zend OPcache API is restricted by "restrict_api" configuration directive in system_requirements() (line 244 of core/modules/system/system.install).
system_requirements('install')
drupal_check_profile('standard', Array)
install_check_requirements(Array)
install_verify_requirements(Array)
install_run_task(Array, Array)
install_run_tasks(Array)
install_drupal(Object)
Code:
Cache PHP OPcode	Non activé
PHP OPcode caching can improve your site's performance considerably. It is highly recommended to have OPcache installed on your server.
Ce sont les même erreurs qu'avant l'ajout de la ligne, ce qui me donne l'impression qu'elle n'a pas été prise en compte.

Pouvez-vous m'éclairer ?

adudouit
15/03/2016, 17h37
Citation Envoyé par 7tonin
Ce que je comprends, c'est que le fichier /.ovhconfig porte sur tous les répertoires du même niveau d'arborescence, ainsi que sur leurs sous-répertoires. À la manière de l'influence des fichiers .htaccess. Donc pour infléchir les instructions du /.ovhconfig à la racine ovh, il est possible d'en créer d'autres dans les sous répertoires voulus.
Exactement. Il existe deux "niveaux de .ovhconfig" :
- celui situé à la racine de votre dossier utilisateur ($HOME) (1); et,
- celui situé à la racine du site web ($DOCUMENT_ROOT) (2).
Les possibles autres n'étant pas pris en compte. Les informations contenues dans le niveau 2 remplaceront celles du niveau 1 pour le site concerné, et celles non-spécifiées seront prise depuis le niveau 1 (idem en l'absence d'un .ovhconfig). En l'absence d'un niveau 1, les informations sont celles par défaut de l'hébergement (-> ).
Défaut < 1 < 2 ; l'existence du défaut est garantie, les autres niveaux peuvent ne pas exister ou être incomplets.

MAIS, pour la directive container.image, il n'existe pas de niveau 2. Elle doit donc être spécifiée dans votre $HOME/.ovhconfig, qui peut ne contenir que cette ligne.

Est-ce plus clair ainsi ?

Gaston_Phone
14/03/2016, 21h05
C.q.f.d.

7tonin
14/03/2016, 20h59
Ce que je comprends, c'est que le fichier /.ovhconfig porte sur tous les répertoires du même niveau d'arborescence, ainsi que sur leurs sous-répertoires. À la manière de l'influence des fichiers .htaccess. Donc pour infléchir les instructions du /.ovhconfig à la racine ovh, il est possible d'en créer d'autres dans les sous répertoires voulus.

Gaston_Phone
14/03/2016, 18h11
Citation Envoyé par vcasse
/www/mon premier site/.ovhconfig ne porterait que sur /www/mon premier site/ sauf pour la variable container.image qui n'est prise en compte que dans /.ovhconfig
OK, il ne te reste plus qu'à donner ces exemples concrets dans le #1.

vcasse
14/03/2016, 18h04
Salut Gaston,

Pas de soucis

Ainsi, si j'ai bien compris :

/.ovhconfig porterait sur /www/mon second site
/www/mon premier site/.ovhconfig ne porterait que sur /www/mon premier site/
/www/mon premier site/.ovhconfig ne porterait que sur /www/mon premier site/ sauf pour la variable container.image qui n'est prise en compte que dans /.ovhconfig

Gaston_Phone
14/03/2016, 18h02
Citation Envoyé par vcasse
Code:
├──  .ovhconfig
├──  www 
│    └── mon premier site
│    │    └── .ovhconfig
│    └── mon second site
Désolé Vincent, je vais finir par me faire mal voir.
Mais c'est celui-ci qui est le plus clair pour moi :
/
/.ovhconfig
/www/
/www/mon premier site/
/www/mon premier site/.ovhconfig
/www/mon second site/
Ainsi, si j'ai bien compris :
  • /.ovhconfig porterait sur /www/mon second site
  • /www/mon premier site/.ovhconfig ne porterait que sur /www/mon premier site/

vcasse
14/03/2016, 17h34
Citation Envoyé par Gaston_Phone
Désolé Vincent mais pour moi c'est toujours aussi peu clair.
Si j'avais du culot je proposerai :

/
/.ovhconfig
/www/mon premier site/
/Site_2/.ovhconfig
/Site_2/mon second site/
Mais peut-être suis-je complêtement à coté de la plaque.
Non c'est plutôt ;
/
/.ovhconfig
/www/
/www/mon premier site/
/www/mon premier site/.ovhconfig
/www/mon second site/
J'ai modifié de nouveau le premier message. Est ce plus clair dans ce format ?

Cordialement,
Vincent

Gaston_Phone
14/03/2016, 17h24
Citation Envoyé par vcasse
Salut Gaston_phone,
Feedback accepté. C'est plus lisible là ?
$HOME/
.
..
.ovhconfig
www/
mon premier site/
.ovhconfig
mon second site/
Désolé Vincent mais pour moi c'est toujours aussi peu clair.
Si j'avais du culot je proposerai :
/
/.ovhconfig
/www/mon premier site/
/Site_2/.ovhconfig
/Site_2/mon second site/
Mais peut-être suis-je complêtement à coté de la plaque.

tarzanjane
14/03/2016, 17h23
Citation Envoyé par tarzanjane
S'il y a plusieurs sites internet sur le même hébergement, cela peut-il jouer sur leur comportement et leur affichage ?
Citation Envoyé par vcasse
Salut tarzanjane,

Oui c'est possible : la configuration s'applique sur tout l'hébergement.
Mais pour le moment, elle n'est appliquée que sur le port 83 (c'est à dire http://monsupersite.ovh:83), donc les utilisateurs du site ne seront pas impactés actuellement.

Cordialement,
Vincent
Merci

vcasse
14/03/2016, 17h20
Salut tarzanjane,

Oui c'est possible : la configuration s'applique sur tout l'hébergement.
Mais pour le moment, elle n'est appliquée que sur le port 83 (c'est à dire http://monsupersite.ovh:83), donc les utilisateurs du site ne seront pas impactés actuellement.

Cordialement,
Vincent

tarzanjane
14/03/2016, 17h17
S'il y a plusieurs sites internet sur le même hébergement, cela peut-il jouer sur leur comportement et leur affichage ?

vcasse
14/03/2016, 17h07
Salut Gaston_phone,

Feedback accepté. C'est plus lisible là ?

On prend aussi des feedbacks sur cette nouvelle configuration !

Cordialement,
Vincent

Gaston_Phone
14/03/2016, 17h04
Citation Envoyé par vcasse
\ .
\ ..
\ .ovhconfig
\ www/
| \ mon premier site/
| | \ .ovhconfig
| \ mon second site/
Hum! Hum! Je n'ai pas très bien compris ce que signifiait le double "Pipe" --> | | \ ?

vcasse
14/03/2016, 16h51
Bonjour à tous,

Depuis quelques mois, la version 8 du CMS Drupal est sortie. Vous êtes nombreux à vouloir le déployer sur nos hébergements web mais jusqu'à maintenant, ce n'était pas possible. La configuration des hébergements web n'était pas compatible avec la configuration demandée par Drupal. Nous avons vérifié l'impact de ce changement de configuration : il aurait modifié le fonctionnement de certains sites web.

C'est le principe même des hébergements web depuis toujours. Pour assurer la qualité de service et le prix, la configuration est la même pour l'ensemble des clients.

Désormais, grâce aux technologies des containers, nous pouvons vous proposer différents environnements d'exécution pour vos hébergements ; vous pouvez désormais alterner entre plusieurs systèmes, à chaud, pour une souplesse acrue. Et ainsi, les intéressés pourront enfin installer Drupal 8 !

Nous avons besoin avant tout de feedback sur cette technologie. Pour tous vos feedbacks, vous pouvez utiliser ce topic. N'hésitez pas à nous dire quelles sont les configurations qui vous intéressent.


NOTE INFORMATIVE
Cette technologie n'est pas encore stable dans sa version actuelle. OVH vous déconseille de l'utiliser pour vos sites en production.
OVH ne pourra pas vous aider en cas de problème sur cette avant-première, aucun support n'est fourni.
La version stable ne sera founie après tests concluants.


COMMENT L'ACTIVER ?
La mise à jour s'effectue au sein de votre fichier .ovhconfig. Vous pouvez définir quelle image vous souhaitez utiliser. Par exemple, pour bénéficier de l'image de bêta avec les configurations récentes :
Code:
container.image=jessie.i386.r5
Si aucune image n'est renseignée, c'est celle par défaut qui est utilisée.

QUELQUES DETAILS TECHNIQUES
L'option "container.image=nom_dimage_valide_parmi_une_liste _fournie" doit être obligatoirement spécifiée dans le .ovhconfig qui est à la racine de votre dossier utilisateur.
Prenons un cas d'exemple : pour ce cas, toutes les options du fichier $HOME/www/mon premier site/.ovhconfig seront utilisées pour "mon premier site" SAUF container.image qui sera récupérée depuis le $HOME/.ovhconfig ; quant à "mon second site", comme avant, l'absence de .ovhconfig résultera sur l'utilisation de celui du $HOME. Les deux sites verront leur plate-forme d'exécution changer.
Code:
├──  .ovhconfig
├──  www 
│    └── mon premier site
│    │    └── .ovhconfig
│    └── mon second site

CE QUE PROPOSE L'IMAGE "jessie.i386.r4"
- les versions 5.3, 5.4, 5.5, 5.6 et 7.0 de PHP
- les extensions PHP mysqlnd, memcached, redis, mongo, imagick qui complètent celles déjà supportées
- OpenSSL compatible TLS1.2 (ce qui va intéresser les utilisateurs de la sandbox paypal !)

Cette liste sera mise à jour au fur et à mesure des rajouts effectués.

LIMITATIONS ACTUELLES
- afin de vérifier la stabilité, l'utilisation du nouveau système ne se fera qu'en accédant à votre site par le port 83 avant la mise en production globale
- un seul nouveau système proposé, aligné sur Debian Jessie
- des outils/modules/etc. manquants, l'objectif étant de les relever pour les y rajouter

A vos feedbacks !

Merci à vous.


Cordialement,
L'équipe des hébergements web