OVH Community, votre nouvel espace communautaire.

Erreur "Too many connections (1040)"


nipson
13/03/2016, 09h51
Bonne idée,

Le forum étant dans le sous-répertoire "forum" du site, je vais faire un Disallow: /forum/ dans le fichier robots.txt

Merci pour ton aide

buddy
13/03/2016, 00h42
Si les robots n'ont pas les permissions pour lire ton forum, je te conseillerai de mettre un robots.txt avec Disallow: /

http://robots-txt.com/ressources/rob...-disallow-all/

çà limitera le fait que les robots reviennent et ne génère des requêtes ...

nipson
12/03/2016, 22h56
Je vais suivre ton conseil Nowwhat en désactivant déjà les plugins qui sont le moins utiles et si ça se reproduit je désactiverai les autres progressivement.
Le soucis c'est que le pb est arrivé seulement 2 fois en 2 mois, donc pas si facile à reproduire.

En tout cas merci pour vos réponses
Bonne soirée

Nowwhat
12/03/2016, 22h09
Citation Envoyé par nipson
.....
  • Add User,
  • Auto database backup,
  • Board Announcements,
  • External Links Open in New Window,
  • FAQ manager,
  • Pages,
  • Pages: TinyMCE WYSIWYG Add-on,
  • Precise Similar Topics,
  • Recent Topics,
  • Scroll To Top,
  • Simple phpBB FAQ,
  • Snowstorm & Lights
Et quand tu vire (désactive) tout ce petit famille, t'as plus d'erreur, c'est ça ?
Nuance : enlève un par un tes plugins, jusqu'à l'erreur s'arrête.

Ce qui n'est pas forcement le ca, mais ce qui arrive souvent : un morceau de code, non-natif au CMS d'origine (autrement dit : le plugin) va
soit instancier un accès à la base des données - au mi chemin le plugin se plante .... la connexion MySQL n'est pas fermé et va rester ouverte un certains temps (quelqe minutes avant de mourir en douce ) et très vite tu arrive à la limite maximal ..... avec le résultat Erreur "Too many connections (1040)"
soit : un plugin plante tout connement .... avec le même résultat que plus haut.


Un CMS d'origine (WP, PHPBB3,etc ) sans plugins, c'est stable et fiable.
Les plugins ... ils ne sont pas écrit par les mêmes auteurs, et probablement pas testé dans toutes les cas figures et situations.

nipson
12/03/2016, 19h55
Merci buddy pour ta réponse,

Mon forum tourne avec PHPBB 3.1.4

Citation Envoyé par buddy
as-tu beaucoup de plug ins ?
J'ai actuellement 12 plugins .
Pour ceux qui connaissent:
  • Add User,
  • Auto database backup,
  • Board Announcements,
  • External Links Open in New Window,
  • FAQ manager,
  • Pages,
  • Pages: TinyMCE WYSIWYG Add-on,
  • Precise Similar Topics,
  • Recent Topics,
  • Scroll To Top,
  • Simple phpBB FAQ,
  • Snowstorm & Lights


Citation Envoyé par buddy
Ton forum est il "lisible" dans les bots ?
Il y a 47 bots dans le groupe Robots (définis à l'installation de PHPBB), mais leur groupe n'a aucun accès au forum (via les permissions).

Une idée ?
Merci

buddy
12/03/2016, 18h44
OVH limite à 30 connexions simultanées sur la base de données. çà doit venir de là.

as-tu beaucoup de plug ins ?
Ton forum est il "lisible" dans les bots ?

Ton forum est il à jour ?
PAr exemple phpbb 3.1 permet de réduire le duplicate content (différentes URLs qui affichent le même contenu).

nipson
12/03/2016, 15h08
Bonjour,

J'administre modestement un forum basé sur PHPBB3 en hébergement mutualisé.
Il s'agit d'un petit forum privé (connexion obligatoire) de 130 utilisateurs avec, à ce jour, un maximum de 12 connections simultanées.

Depuis le début de l'année, j'ai eu deux fois le message d'erreur suivant, qui se traduit par une impossibilité d'accéder au forum pour tous les utilisateurs, voire même impossibilité d'accéder à phpmyadmin:

"General Error
SQL ERROR [ mysql4 ]
Too many connections [1040]
An sql error occurred while fetching this page. Please contact an administrator if this problem persists."

Avez-vous une idée d'où ça peut provenir ?

Merci d'avance pour votre aide