OVH Community, votre nouvel espace communautaire.

Partage FTP... en écriture ?


manup
20/05/2016, 14h22
Bonjour, merci mais depuis j'ai totalement laissé tombé cette solution.

Stuntman
20/05/2016, 12h35
Quel est le format du disk ? NTFS? FAT32 ?
Est-ce qu'il serait possible d'avoir une capture d'écran de la partie Content Sharing ?
Est-ce que le CIFS/Samba fonctionne ?

manup
07/03/2016, 13h35
Citation Envoyé par Luigi_B
Pour pouvoir utiliser cette fonctionnalité il y a des pré-requis à effectuer
Où trouver ces prérequis ?

Et où trouver la description du type d'utilisateur WLAN_user, ma 2nde question de mon post intial.

Citation Envoyé par Luigi_B
Il faut pour cela au préalable créer un nouvel utilisateur dans le modem en allant dans Toolbox puis dans User managment, il faut impérativement mettre le nouvel user en droit LAN_Admin.

Une fois cela fait, il faudra aller dans ToolBox/Content sharing/Configure et bien vérifier si le disque dur est bien cochée dans la « List of connected disks » et que server Enabled soit coché dans FTP Server
Dans l'aide :
LAN_Admin : Cet utilisateur peut uniquement effectuer des configurations LAN via n'importe quel canal d'accès de n'importe quelle origine
C'est pas un peu beaucoup pour un user FTP ?

Mais sinon, même comportement que précédemment décrit.

J'ajoute que si le fichier est bien créé vide sur le remote (i.e. le DD USB au cul du modem) par l'opération, il est aussi possible de l'y supprimer par FTP...

Et par anticipation d'éventuelles questions, le DD n'est pas plein : il indique 250Go libres.

Luigi_B
07/03/2016, 12h43
Bonjour.

Pour pouvoir utiliser cette fonctionnalité il y a des pré-requis à effectuer

Il faut pour cela au préalable créer un nouvel utilisateur dans le modem en allant dans Toolbox puis dans User managment, il faut impérativement mettre le nouvel user en droit LAN_Admin.

Une fois cela fait, il faudra aller dans ToolBox/Content sharing/Configure et bien vérifier si le disque dur est bien cochée dans la « List of connected disks » et que server Enabled soit coché dans FTP Server

Cordialement.

Luigi.B

manup
06/03/2016, 23h19
Citation Envoyé par laurentm
car ce pauvre modem-routeur n'en peut plus des utilisateurs qui veulent lui faire faire le café, les photocopies et le ménage (serveur SMB/CIFS, FTP, SIP, etc...)
Juste lui faire faire ce qu'il est supposé faire...

Pour le reste c'est pas exclu, c'était pas la question mais merci quand même.

laurentm
06/03/2016, 23h06
Ce serait quand même bien plus performant d'acheter un petit serveur du genre Synology (le moins cher, ou alors d'occasion)
car ce pauvre modem-routeur n'en peut plus des utilisateurs qui veulent lui faire faire le café, les photocopies et le ménage (serveur SMB/CIFS, FTP, SIP, etc...)
Car il faudrait penser à mettre un fail2ban sinon ce serveur sera très vite attaqué et piraté par force brute. Ce genre de fonctions est bien étudié par les fabricants de NAS les plus courants, mais pas du tout par Technicolor, dont l'interface confuse ramène 20 ans en arrière.

manup
06/03/2016, 12h10
Bonjour,

Sur mon modem Technicolor TG788vn est connecté en USB un DD que je souhaite "partager" en externe par FTP, notamment pour y recevoir des sauvegardes (tar.bz2).

J'ai donc activé le serveur FTP dans la section Partage de contenu.

Je parviens bien à me connecter à mon adresse IP fixe avec un client FTP en utilisant un compte Administrateur pour cette connexion.

Je peux alors passer des get, mais chaque put se solde par :
Code:
ftp> put monfichier.tar.bz2
local: monfichier.tar.bz2 remote: monfichier.tar.bz2
200 PORT command successful
150 Connecting to port 32800
Puis rien.
Le port change à chaque fois.
Quand j'abort le transfert, je constate que monfichier.tar.bz2 est créé vide sur le DD USB.

Ma 1ère question : comment s'y prendre pour parvenir à copier des fichiers via FTP sur ce serveur ?

Ma 2nde question : ne voulant pas me connecter FTP avec un compte Administrateur du modem, j'ai créé un compte "sauve" de type WLAN_user. Or ce type d'utilisateur n'est pas documenté, à quoi correspond-t-il donc (même si cela ne change pas le 1er point).

Merci.