OVH Community, votre nouvel espace communautaire.

Mysql plante à l'ajout d'un article Wordpress


janus57
05/03/2016, 12h51
Bonjour,

tuning-primer.sh
suffit de recherche ce terme sur google puis https://launchpad.net/mysql-tuning-primer ensuite on l'enregistre sur le VPS et on le fait tourner.

Cordialement, janus57

Kos95
05/03/2016, 10h13
Citation Envoyé par janus57
Bonjour,


et vous appliquer ce que les 2script donne comme conseil en commun car si une chose identique est donné par 2sources différente cela est plus "sûr" que 1source unique donc applicable, puis le reste est à vérifier au K par K.

Rappel : avec MySQL après chaque changement attendre 48 à 72H pour voir l'impact de la modification.

Note : si c'est un problème de RAM cela ne risque pas de s'arranger avec le tuning de MySQL, ce sera peut être pire si la consommation augmente.

Cordialement, janus57
Veuillez bien vouloir m'excuser pour ma réponse tardive mais je n'ai pas réussi à installer le 2ème script.

Par contre j'ai rajouter ceci :

open-files-limit=4510
dans /etc/mysql/mysql.conf.d/mysqld.cnf

Ainsi que
mysql soft nofile 65535
mysql hard no file 65535
dans /etc/security/limits.conf

Pour le moment ça à l'air de bien tourner.

janus57
29/02/2016, 21h09
Bonjour,

mysqltuner et tuning-primer.sh
et vous appliquer ce que les 2script donne comme conseil en commun car si une chose identique est donné par 2sources différente cela est plus "sûr" que 1source unique donc applicable, puis le reste est à vérifier au K par K.

Rappel : avec MySQL après chaque changement attendre 48 à 72H pour voir l'impact de la modification.

Note : si c'est un problème de RAM cela ne risque pas de s'arranger avec le tuning de MySQL, ce sera peut être pire si la consommation augmente.

Cordialement, janus57

Kos95
29/02/2016, 20h30
Citation Envoyé par janus57
Bonjour,

faut pas tout prendre d'internet mais comme l'a dit @buddy un petit mysqltuner et tuning-primer.sh (pour voir 2résulats et voir ce qui est en commun comme optimisation).

Sinon il faut aussi regarder la RAM au cours du temps (avec un munin ou autre système de monitoring).

Au Passage je sais pas combien vous payez ce VPS, mais je pense que les nouveaux VPS de OVH serait bien, car ceux de 2014 en OpenVZ c'est pas le top, et surtout les nouveau en minimum 2Go pour 2.99€ HT.

Cordialement, janus57
Bonsoir

Voici un récapitulatif de MysqlTuner :

General recommendations:
Run OPTIMIZE TABLE to defragment tables for better performance
When making adjustments, make tmp_table_size/max_heap_table_size equal
Reduce your SELECT DISTINCT queries without LIMIT clauses

Variables to adjust:
query_cache_type (=1)
tmp_table_size (> 16M)
max_heap_table_size (> 16M)
Que me conseillez vous de faire ? Je suis un peu perdu pour le coup

J'utilise justement un vps de 1go de ram édition 2014 et je compte prochainement passer sur un 2016

janus57
28/02/2016, 20h49
Bonjour,

faut pas tout prendre d'internet mais comme l'a dit @buddy un petit mysqltuner et tuning-primer.sh (pour voir 2résulats et voir ce qui est en commun comme optimisation).

Sinon il faut aussi regarder la RAM au cours du temps (avec un munin ou autre système de monitoring).

Au Passage je sais pas combien vous payez ce VPS, mais je pense que les nouveaux VPS de OVH serait bien, car ceux de 2014 en OpenVZ c'est pas le top, et surtout les nouveau en minimum 2Go pour 2.99€ HT.

Cordialement, janus57

Kos95
28/02/2016, 19h53
@Buddy : Merci pour le tuto

@Janus57 : voici le code d'erreur présent dans le fichier var/log/syslog au moment du crash

Feb 28 19:04:18 vps177068 mysqld_safe[238]: 160228 19:04:18 mysqld_safe Number of processes running now: 0
Feb 28 19:04:18 vps177068 mysqld_safe[238]: 160228 19:04:18 mysqld_safe mysqld restarted
Feb 28 19:04:23 vps177068 mysqld_safe[238]: 160228 19:04:23 mysqld_safe Number of processes running now: 0
Feb 28 19:04:23 vps177068 mysqld_safe[238]: 160228 19:04:23 mysqld_safe mysqld restarted
Feb 28 19:04:28 vps177068 mysqld_safe[238]: 160228 19:04:28 mysqld_safe Number of processes running now: 0
Feb 28 19:04:28 vps177068 mysqld_safe[238]: 160228 19:04:28 mysqld_safe mysqld restarted
Feb 28 19:04:30 vps177068 mysqld_safe[238]: 160228 19:04:29 mysqld_safe Number of processes running now: 0
Feb 28 19:04:30 vps177068 mysqld_safe[238]: 160228 19:04:30 mysqld_safe mysqld restarted
Je dois donc optimiser MYSQL ? Suite à mes recherches personnelles je suis tomber sur ceci sur internet en parlant d'optimisation:

# autoriser MySQL à utiliser toute la memoire cache
query_cache_limit = 16M
Dans mon fichier /etc/mysql/mysql.conf.d la commande est de :

query_cache_limit = 1M
Je passe sur 16 ?

janus57
28/02/2016, 19h16
Bonjour,

perso quand je vois ceci :
Code:
2016-02-26 19:06:48 21562 [Warning] Buffered warning: Changed limits: max_open_files: 1024 (requested 5000)

2016-02-26 19:06:48 21562 [Warning] Buffered warning: Changed limits: table_open_cache: 431 (requested 2000)
Quelque chose me dit qu'il serait temps d'optimiser MySQL pour coller au besoins et surtout de vérifier la consommation, car si MySQL se fait kill par le OOM le simple fait de le mettre à jour ne va pas arranger les choses.

D'ailleurs que dit le syslog au moment du kill de MySQL ?

Cordialement, janus57

buddy
28/02/2016, 18h59
non, mais tu peux l'automatiser avec un cron dans le fichier /etc/crontab

12 6 * * * root /usr/bin/apt-get update && apt-get upgrade -y

Le soucis est peut être ailleurs non ?

est-ce que çà ne serait pas ton VPS qui sature sa ram ou mysql qui plante ?

tu as MySQLTuner qui te donne des conseils pour optimiser ta base de données

Kos95
28/02/2016, 18h52
Eh bien visiblement le soucis a disparu avec un simple
sudo apt-get update && sudo apt-get upgrade
Pourtant je fais cette manipulation une fois par semaine... je vais surveiller le problème pour voir si ça va définitivement mieux, en tout cas merci

J'utilise Webmin pour avoir une interface graphique, est-il possible d'automatiser le "apt-get update/upgrade" avec une commande ? Pour MYSQL j'avais réussi à contourner mon soucis en programmant un "service mysql start" si ce dernier crash

buddy
28/02/2016, 18h33
c'est étonnant toutes ses erreurs ?

As-tu fais des mises à jour récemment ?
Tout est bien à jour ?

sudo apt-get update && sudo apt-get upgrade (sous ubuntu)

tu as quelle version ?

Pour mysql, as-tu essayé de le redémarrer ?

sinon ce message d'erreur laisse penser que wordpress n'utilise pas une "syntaxe" très à jour ....
[Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).

Kos95
28/02/2016, 18h27
Bonjour

Je possède un VPS gamme 2014 avec 1go de ram sous ubuntu server.

Ma configuration WP actuelle
- Version de WordPress : 4.4.2
- Version de PHP/MySQL : php5

Comme l'indique le titre MYSQL plante à chaque publication d'article...

160226 19:06:46 mysqld_safe Number of processes running now: 0
160226 19:06:46 mysqld_safe mysqld restarted
2016-02-26 19:06:48 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2016-02-26 19:06:48 0 [Note] /usr/sbin/mysqld (mysqld 5.6.28-0ubuntu0.15.04.1) starting as process 21562 ...
2016-02-26 19:06:48 21562 [Warning] Buffered warning: Changed limits: max_open_files: 1024 (requested 5000)

2016-02-26 19:06:48 21562 [Warning] Buffered warning: Changed limits: table_open_cache: 431 (requested 2000)

2016-02-26 19:06:48 21562 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
2016-02-26 19:06:48 21562 [Note] Plugin 'FEDERATED' is disabled.
2016-02-26 19:06:48 21562 [ERROR] Function 'innodb' already exists
2016-02-26 19:06:48 21562 [Warning] Couldn't load plugin named 'innodb' with soname 'ha_innodb.so'.
2016-02-26 19:06:48 21562 [ERROR] Function 'federated' already exists
2016-02-26 19:06:48 21562 [Warning] Couldn't load plugin named 'federated' with soname 'ha_federated.so'.
2016-02-26 19:06:48 21562 [ERROR] Function 'blackhole' already exists
2016-02-26 19:06:48 21562 [Warning] Couldn't load plugin named 'blackhole' with soname 'ha_blackhole.so'.
2016-02-26 19:06:48 21562 [ERROR] Function 'archive' already exists
2016-02-26 19:06:48 21562 [Warning] Couldn't load plugin named 'archive' with soname 'ha_archive.so'.
2016-02-26 19:06:48 21562 [Note] InnoDB: Using atomics to ref count buffer pool pages
2016-02-26 19:06:48 21562 [Note] InnoDB: The InnoDB memory heap is disabled
2016-02-26 19:06:48 21562 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2016-02-26 19:06:48 21562 [Note] InnoDB: Memory barrier is not used
2016-02-26 19:06:48 21562 [Note] InnoDB: Compressed tables use zlib 1.2.8
2016-02-26 19:06:48 21562 [Note] InnoDB: Using Linux native AIO
2016-02-26 19:06:48 21562 [Note] InnoDB: Using CPU crc32 instructions
2016-02-26 19:06:48 21562 [Note] InnoDB: Initializing buffer pool, size = 128.0M
Killed
160226 19:06:48 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended
Il n'y aurait pas un soucis au niveau de : "InnoDB: Initializing buffer pool, size = 128.0M" ?

Ma base de donnée possède 600 articles, j'ai tenté de l'optimiser avec un plugin wordpress mais sans succès.

Je vous en remercie par avance !