OVH Community, votre nouvel espace communautaire.

Erreur lors de la connexion à la base de données


Gaston_Phone
19/02/2016, 19h18
Citation Envoyé par Kobat
Si ce n'est pas la solution je suivrais votre conseil (je n'ai pas de droits d'accès 777, seulement des 755 que j'ai modifié en 705 pour les dossiers, et j'ai désactivé mon .htaccess, ça ne donne rien non plus)
Les droits d'accès 777 sont interdits par OVH car ils ouvrent toutes les portes aux malfaisants.
705 -> Dossiers
604 -> Fichiers

Kobat
19/02/2016, 16h26
Citation Envoyé par Gaston_Phone
Fait le test du script /www/bonjour.php --> OVH - Erreur 500 sur votre site Internet
Merci Gasto_Phone, quelqu'un a une autre piste (allez voir sur mon billet : https://forum.ovh.com/showthread.php...NNECTION_RESET

Si ce n'est pas la solution je suivrais votre conseil (je n'ai pas de droits d'accès 777, seulement des 755 que j'ai modifié en 705 pour les dossiers, et j'ai désactivé mon .htaccess, ça ne donne rien non plus)

Je vous répondrez sur mon billet pour ne pas parasiter celui-ci.

Merci

Nowwhat
19/02/2016, 16h02
Citation Envoyé par monblogestunrom
....
Pas moins de deux ans sans problèmes majeurs sur mon site ! Tout allait bien, donc jusqu'à hier... En effet, mon hébergeur OVH m'informe que ma base de données est surchargée !
Rajoute à ta liste de "tâches d'un admin d'un site" : SURVEILLER la base des données

Citation Envoyé par monblogestunrom
....
Aussitôt, non seulement j'en rachète une mais je purge la base de données existante et recalcule le quota, devenu bon par la suite...
Donc : t'as reçu un mail avec l'adresse de ce serveur, ainsi que l’utilisateur, le mot de passe et le nom de la base.

Citation Envoyé par monblogestunrom
....
Sauf que... entre temps, j'ai modifié le mot de passe aussi bien sur mon phpadmin ainsi que sur mon ftp via le www.
Sauf que le mot de passe de ta base, il ne se change pas avec phpadmin (c'est quoi ça ??) ça : https://phpmyadmin.ovh.net/ ? - mais dans le Manager de ton hébergement.

Si tout va bien, t'as accès à ton ancienne base, et le nouveau.
Avec https://phpmyadmin.ovh.net/ bien sur.
Dans ta nouvelle base, toutes le tables doivent être présent - avec le même préfixe qu'avant, probablement "wp_".
Compareles données entre ces deux serveur MySQL - ils ont les même tables ? Dans chaque tables il y a le même nombre d’enregistrements ??
===> Attention : copier (importer !) une base des plusieurs Mega octets, avec https://phpmyadmin.ovh.net/ , ça ne marche pas. Ce sujet a été traité des milliers (non : plus encore) sur ce forum. Ce n'est pas hyper compliquer, mais on est obligé de réfléchir avant de procéder.

Je me répète : la base est nien intégralement présent sur ton ouveau serveur MySQL ?

Si oui, et le fichier /www/wp-config.php a été modifié en conséquence (pas comme "et hoppa, je remplace les "" pour des '' ou des `` comme ailleurs sur ce forum) - donc les 4 lignesà modifier et je vous jure : ça marche !!!
En tout cas, ça marche pour moi comme ça depuis 2001.

Citation Envoyé par monblogestunrom
....
Fatal error: Uncaught Error: Call to undefined function wp_cache_phase2() in /home/maphilos/www/wp-content/plugins/wp-super-cache/wp-cache-phase1.php:353 Stack trace: #0 /home/maphilos/www/wp-settings.php(267): wp_cache_postload() #1 /home/maphilos/www/wp-config.php(102): require_once('/home/maphilos/...') #2 /home/maphilos/www/wp-load.php(37): require_once('/home/maphilos/...') #3 /home/maphilos/www/wp-admin/maint/repair.php(10): require_once('/home/maphilos/...') #4 {main} thrown in /home/maphilos/www/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 353
T'as installé un cache.
Ok.
Dans ce cas, A tout moment, il faut savoir "vider" ce cache, et ceci sans accéder à ton espace 'admin' de WP (car, quand ça foire, t'as plus accès au partie admin).

Gaston_Phone
19/02/2016, 15h59
Citation Envoyé par Kobat
Personnellement, je peux me connecter à ma base de donnée via phpMyAdmin mais impossible d'accéder à mes sites que ce soit en tapant l'url ou par l'admin Wordpress...
Fait le test du script /www/bonjour.php --> OVH - Erreur 500 sur votre site Internet

Kobat
19/02/2016, 15h34
J'ai un problème similaire mais qui n'est peut-être pas dû à la même chose, je viens de faire un billet : https://forum.ovh.com/showthread.php...NNECTION_RESET

Peut-être que ça aidera si j'ai des réponses positives

Personnellement, je peux me connecter à ma base de donnée via phpMyAdmin mais impossible d'accéder à mes sites que ce soit en tapant l'url ou par l'admin Wordpress...

L.YA
19/02/2016, 15h33
Bonjour,

Je me suis permis de regarder et... je crois que vous avez eu la main un peu lourde sur la purge .

En effet, la table wp_options est vide, il en va de même pour d'autres tables tels que wp_posts et presque toutes les autres, wordpress doit avoir besoin de certaines options qu'il ne trouve plus.

Je vous recommande de restaurer la sauvegarde d'hier et de re-purger les données qui sature la base (en évitant de vider certaines tables comme wp_options).

PS : L'erreur renvoyé par wordpress, même si elle peut porter à confusion, n'est à première vue, pas causé par de mauvais login/pass mais par plusieurs tables vides alors qu'elles devraient contenir un minimum d'information.

buddy
19/02/2016, 15h30
question bête, mais as-tu bien vérifié le log in, le mot de passe, le nom et l'adresse du serveur de ta base de données ?
il arrive souvent que les utilisateurs en le tapant inverse 2 lettres ou 2 chiffres.

monblogestunrom
19/02/2016, 14h17
Bonjour à tous,
Pas moins de deux ans sans problèmes majeurs sur mon site ! Tout allait bien, donc jusqu'à hier... En effet, mon hébergeur OVH m'informe que ma base de données est surchargée !
Aussitôt, non seulement j'en rachète une mais je purge la base de données existante et recalcule le quota, devenu bon par la suite...
Sauf que... entre temps, j'ai modifié le mot de passe aussi bien sur mon phpadmin ainsi que sur mon ftp via le www.
Je me suis dit, ça va aller maintenant !
Et bien pas du tout !!! Non seulement, je n'arrive pas à me connecter à mon administration du blog et le message suivant apparaît sans arrêt lorsque j'essaie de consulter mon blog, via Google par exemple :

Erreur lors de la connexion à la base de données

ou alors... une Erreur 500
J'ai bien entendu contacté l'assistance de OVH qui me renvoie sur un webmaster chevronné car ce n'est pas une erreur de leur part...
Nous sommes vendredi, à la veille d'un weekend où mes lecteurs fidèles viennent souvent visiter le site. Je suis catastrophée car je ne sais plus comment faire !
Si vous avez une petite idée, ça serait vraiment génial et je vous en serais reconnaissante toute ma vie ! Merci d'avance...
Marie Da Cruz de http://monblogestunroman.com

Voici ce que ça donne à l'instant lorsque j'essaie de me connecter avec wordpress :

Fatal error: Uncaught Error: Call to undefined function wp_cache_phase2() in /home/maphilos/www/wp-content/plugins/wp-super-cache/wp-cache-phase1.php:353 Stack trace: #0 /home/maphilos/www/wp-settings.php(267): wp_cache_postload() #1 /home/maphilos/www/wp-config.php(102): require_once('/home/maphilos/...') #2 /home/maphilos/www/wp-load.php(37): require_once('/home/maphilos/...') #3 /home/maphilos/www/wp-admin/maint/repair.php(10): require_once('/home/maphilos/...') #4 {main} thrown in /home/maphilos/www/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 353