OVH Community, votre nouvel espace communautaire.

édition fichier css impossible ...et seulement les css !!!


nostromo2122
21/02/2016, 13h04
Merci loic pour ces precisions
Mon idée c'est de standardiser le pus possible et d'avoir un ohconfig en php7 fpm, un htaccess pour les reglages de base (addtype, deflate, mod_expires), un htaccess par domaine pour mod_rewrite, et je mets les back office dans des sous domaines qui seront hébergés sur l'IP indepentante de geocache.
Bonne journée

Gaston_Phone
19/02/2016, 20h38
Merci Loïc.

L.YA
19/02/2016, 19h35
Ce n'est clairement pas possible (quoi que en php-cgi, on peut bidouiller... mais c'est mal) si jamais on met plusieurs .ovhconfig et que l'on navigue sur le site avec des url de type "superdomaine.fr/monsite1" et "superdomaine.fr/monsite2". Si c'est des domaines différents (domain1.fr et domain2.fr) ça devrait passer (d'après mes tests sa passe en tout cas !).

Cependant, c'est de la "bidouille", on recommande de n'en utiliser qu'un par hébergement.

Gaston_Phone
19/02/2016, 19h25
Citation Envoyé par L.YA
Vous pouvez placer à la racine de l'hébergement un .ovhconfig avec une version php "de base". Puis, pour dans la racine d'un domaine, un second .ovhconfig avec une autre version de php.
Il me semblait qu'un de vos collègues de la Team OVH avait dit que ce n'était pas possible.

L.YA
19/02/2016, 18h29
Bonsoir nostromo2122,

Vous pouvez placer à la racine de l'hébergement un .ovhconfig avec une version php "de base". Puis, pour dans la racine d'un domaine, un second .ovhconfig avec une autre version de php. Par contre, la version de php 5.2 ne sera pas disponible (5.3 et supérieur uniquement). Sa localisation dans l'arborescence n'aura pas d'importance dans le cas d'un sous-domaine/multi-domaine.

Il faut s'assurer que le site ayant un .ovhconfig spécifique soit bien accédé par un sous-domaine/multi domaine.

Par ailleurs, ce qui ne marchera pas c'est d'utiliser deux fois un .ovhconfig avec la même version de php-fpm (aucun soucis en phpcgi) avec une valeur sur la variable "environment" différente.

nostromo2122
19/02/2016, 13h43
Bonjour LYA,

Alors, par rapport a mon poste initial, il se trouve que tous les domaines sur cette hébergement sont dorenavant impactés (un géré par ovhconfig, et les 7 autres gérés par htaccess), ce qui n'etait pas le cas quelques jours auparavant.

Vos explications pourraient me suffire, si vous pouviez egalement m'expliquer comment j'organise l'hebergement pour que tous les domaines soit gérées par un ovhconfig sauf un domaine qui doit rester en php 5.2 quelques semaines encore :
a) je mets un ovhconfig dans www (qui englobe tout les domaines), et un htaccess en 5.2 a la racine du domaine problematique,
b) ou je sors ce domaine du www pour le mettre au meme niveau (racine de l'hebergement), ovhconfig dans www et htaccess dans l'autre ?
c) c'est pas possible ?
C'est pas tres clair dans vos guides pour les multi domaines... et comme vous parler de conflit j'ai pas fait de test pour essayer...

Autre question, est ce que les 90 plans sont impactés par geocache ?

Merci d'avance et bonne journée

L.YA
18/02/2016, 18h04
Bonjour nostromo2122,

Après vérification, en mode "production", les fichiers statiques du type css etc sont gardés en cache quelques minutes. Je poursuis mes tests. (Ce qui confirme les infos données dans le guide ovh)

Les mises en cache plus longue se font exclusivement si votre site le demande via les header qu'il ajoute. Ici, par mod_expire.

J'en reviens aussi à ma première explication. Via le .htaccess de fetesdelalavande.fr, la configuration mod_expire présente va conserver certaines extensions (dont les css) 7 jours en cache chez vos visiteurs et au geocache.
De ce fait, s'ils sont modifiés, sa ne sera visible que 7 jours plus tard (le principe du cache).

Concernant le flush du geocache (cdn de base), il y a en effet un problème avec la commande disponible sur le manager qui effectue le flush que pour le domaine principal mais pas les sous-domaine (la fonctionnalité est en développement et sera disponible sur le manager).
(Je peux cependant le forcer de mon côté en attendant).

- Si vous ne souhaitez pas utiliser geocache, il faut modifier l'entrée DNS du domaine.
- Si vous souhaitez ponctuellement désactiver son usage à des fins de développement, il faut modifier l'option environment dans le .ovhconfig en mode "development".

Si je n'ai pas répondu à votre question (ou mal compris le problème, c'est possible aussi ! ), discutons-en et essayons de comprendre. Avec les informations que j'ai en ma possession pour le moment, le comportement du cache me semble normal au vu des instructions mod_expire du fichier .htaccess .

nostromo2122
18/02/2016, 16h34
Bonjour,

Le probleme n'est pas resolu, il empire : authentifaction .htaccess mise en place vers 12h30 et a 16h c'est toujours pas pris en compte ... ça gave cette histoire. (soit dit en passant, on devrait pouvoir choisir ce qui est mis en cache...)

je viens de changer l'ip pour me passer de geocache, mais c'est pas la solution 1) compte tenu du delai de propagation, 2) faut le faire sur tous les domaines, 3) la correspondance en IPV6 c'est quoi ?

Je veux bien utiliser ovhconfig et tout passer en php7 (je ne demande que ça meme php7) , sauf un domaine qui doit rester en php5.2 encore quelques semaines, mais comment je fais pour eviter les conflits ?
a) je mets un ovhconfig dans www (ca englobe tout les domaines), et un htaccess 5.2 a la racine du domaine problematique,
b) ou je sors ce domaine du www pour le mettre au meme niveau (racine de l'hebergement), ovhconfig dans www et htaccess dans l'autre ?
c) c'est pas possible ?

Merci d'avance


@ALain31000 : normalement d'apres la faq ovh, avec ovhconfig tu es sensé desactiver le cache en basculant du mode production vers le mode developpement dans ton ovhconfig... (saiuf que quand j'ai fait ça l'autre jour, ça n'a rien fait... vu que le ovhconfig devait etre lui aussi en cache )

ALain31000
12/02/2016, 22h37
Citation Envoyé par nostromo2122
Bonjour ALain31000

Pour aider lya, pourrais tu communiquer ta version php, les regles de ton ovhconfig, et ton filer s'il te plait ?
Merci
Je n'utilise pas PHP, mais du html5/css.
Le php est réglé sur AUTO, le filer est 92, et dans l'ovh config il y a:
app.engine=phpcgi
app.engine.version=AUTO

Le site: www.mp3trazaac.com

Merci pour ton aide !

nostromo2122
12/02/2016, 21h53
Bonjour ALain31000

Pour aider lya, pourrais tu communiquer ta version php, les regles de ton ovhconfig, et ton filer s'il te plait ?
Merci

nostromo2122
12/02/2016, 21h41
Bonjour Lya, et merci pour ton aide
depuis mon dernier post a 18h20, j'ai tout mis de coté et touché a rien.

Une petite precision, j'utilise mod_expires depuis longtemps, sur ce domaine et sur d'autres, et jamais je n'ai eu un probleme similaire, ni eu besoin de vider "geo cache" n'ayant jamais vu cette option.

Bref, la petite modification pour test faite sur le fichier CSS vers 17h30, n'est pour l'instant toujours pas prise en compte malgré le fait que tu ai flusher geocache... et le fichier sur le ftp est le bon.

Pour mettre a mal ton hypothese (dsl je n'ai rien contre toi ) , je viens de faire un autre test, sur la meme plateforme d'hebergement (multi domaine), mais sur un autre domaine, meme config mod_expires dans htaccess, en php 5.4 via htaccess : edition du fichier css sur le ftp, upload, et succes a la lecture sur le navigateur client, que j'avais bien pris soin d'ouvrir prealablement sur une page ou je pourrai voir la modification du CSS , puis annulation de l'edition css, re upload, F5 sur navigateur et tout est ok, comme ça l'a toujours été (ça fais 10 ans que je suis client chez vous sans veritable souci... meme si je peux faire des critiques sur l'evolution d'ovh ),

la seule difference c'est que le second domaine testé est normalement hebergé sur une ip anglaise (le 1er sur une francaise), ou alors autre piste possible: php via cgi pour le second (5.4 htaccess), et php frm sour le 1er (php7 ovhconfig)?
qu'en penses tu ?

ALain31000
12/02/2016, 20h51
Bonjour j'ai exactement le même pb: j'ai ouvert un ticket, j'ai rien compris à ce qu'a dit LYA, tout ce que je sais c'est que ça me gonfle au plus haut point.

C'est quand même dingue qu'on ne puisse pas faire une modif via le FTP classique sans rentrer dans l'interface OVH et se prendre la tête avec 36 considérations techniques pour savoir pourquoi si on uploade un fichier modifié, ce n'est pas pris en compte ! C'est quand même le mini que l'on puisse demander à un hébergeur non?

Cdt

L.YA
12/02/2016, 18h20
Bonjour nostromo2122,

J'ai une hypothèse qui pourrait partiellement expliquer une partie de ton problème. Même si tu n'as pas souscrit à l'offre CDN, on fournit de base un cache (appelé "GeoCache") comportant 3 POP. Comme tu utilises mod_expire, il va insérer les infos d'expiration du cache en header et geocache... il va s'en souvenir et les conserver en cache.
En conséquence, il faut demander à geoache de vider son cache (possible via le manager) si tu changes un fichier avant expiration.

Concernant l'upload FTP... je dois t'avouer que je n'avais pas encore rencontré ce cas là, si cela se reproduit, il pourrait être intéressant que l'on fasse tout les deux des tests pour le vérifier (comparer des hash et les stats du fichier après un upload).

PS : Si tu ne souhaite pas utiliser geocache (mais ça serait dommage de ne pas en profiter ), tu peux utiliser cette ip "37.187.184.17" à la place de "213.186.33.17" dans la zone DNS du domaine.

PS2 : Je viens de lancer un flush du cache geocache sur ton hébergement. Sa devrait prendre effet dans les minutes qui viennent. J'espère que ça permettra de confirmer mon hypothèse !

nostromo2122
12/02/2016, 18h20
Update: Petite evolution vers 17h30: le fichier sur le ftp (le bon) est soudainement pris en charge par le navigateur client... j'ai donc fais un nouveau test d'edition avec espoir, mais non, ce n'est pas pris en compte

nostromo2122
12/02/2016, 16h22
Bonjour à tous,

Je rencontre un problème curieux depuis mercredi soir: j'edite un fichier CSS, upload via FTP, je teste dans mon navigateur (cache desactivé par defaut) , mais pas de changement pris en compte, j'ouvre l'inspecteur d'elements, les nouvelles regles n'y figure pas, je recharge la page à grand coups de F5, mais nada...
Je recupere le CSS par FTP, et là je vois que les nouvelles regles n'y sont pas... re-édition, re-upload, re test ... aucun resultat; je desactive les regles mod_expires dans htaccess, ovhconfig en mode developpement, , teste sur 2 OS differents, sur smartphone, sur 4 navigateurs divers... et toujours rien... finalement, je change le nom du CSS et miracle ça marche, les nouvelles regles apparaissent au client... je remets l'ancien nom, et c'est l'ancien fichier qui est resservi... par contre il n'y aucun probleme de ce genre sur les autres fichiers (php ou jpeg ou autres)... WTF me dis-je
Petite evolution depuis hier soir, le fichier edité garde bien cette fois les nouvelles regles (c'est donc bien le nouveau CSS qui est sur le FTP), mais c'est toujours l'ancien qui est servi au client... J'en deduis que OVH a un syteme de cache qui part en cou..le quelque part ? (pas de cdn pour ma part)
Quelqu'un a t'il une solution ou Y a t'il un gentil monsieur de chez ovh pour jeter un oeil sur le filer 547 site: fetesdelalavande.fr en php 7 ?

Merci d'avance et bonne journée.