OVH Community, votre nouvel espace communautaire.

.htaccess plus pris en compte de façon soudaine (utilisé pour jeu Unity WebGL)


Dragonic
12/02/2016, 12h23
Bonjour,

Depuis cet après-midi j'ai remarqué que mon site web ne permettait plus démarrer mon jeu en WebGL, fait avec le moteur Unity3D.
L'adresse du site : http://zer0.io/webgl/

Cela semble venir d'un problème de lecture du htacess qui permet de gérer la compression gzip des fichiers du jeu

Code:
Options +FollowSymLinks
RewriteEngine on

RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}gz -f
RewriteRule ^(.*)\.js$ $1\.jsgz [L]

RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}gz -f
RewriteRule ^(.*)\.data$ $1\.datagz [L]

RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}gz -f
RewriteRule ^(.*)\.mem$ $1\.memgz [L]

RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}gz -f
RewriteRule ^(.*)\.unity3d$ $1\.unity3dgz [L]

AddEncoding gzip .jsgz
AddEncoding gzip .datagz
AddEncoding gzip .memgz
AddEncoding gzip .unity3dgz
(c'est un htaccess généré par le moteur Unity)

Je n'avais jamais eu de problème, jusqu'à donc cet après-midi où le jeu ne voulait tout simplement plus se lancer, alors que je n'avais fait aucune modification des fichiers du site.
Je remarque aussi que le transfert de certains fichiers via FTP prennent bizarrement beaucoup de temps à être appliqués sur le site. Pour la modification de l'index.html et son upload via FTP le résultat est direct, mais bizarrement quand j'upload mon css updaté cela prend bien 5 à 10 minutes avant de voir les effets, 1ère fois que ça me fait cela.

(pour information j'ai vérifié une copie de mon site sur un simple dropbox, et tout fonctionne bien)

Du coup vu ses comportements assez étrange depuis cet après-midi, je suppose qu'il y a quelques soucis sur le serveur gérant mon hébergement. Je reste à disposition si il y a besoin de plus d'informations.

Dragonic
11/02/2016, 21h47
Bonjour,

Depuis cet après-midi j'ai remarqué que mon site web ne permettait plus démarrer mon jeu en WebGL, fait avec le moteur Unity3D.
L'adresse du site : http://zer0.io/webgl/

Cela semble venir d'un problème de lecture du htacess qui permet de gérer la compression gzip des fichiers du jeu

Code:
Options +FollowSymLinks
RewriteEngine on

RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}gz -f
RewriteRule ^(.*)\.js$ $1\.jsgz [L]

RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}gz -f
RewriteRule ^(.*)\.data$ $1\.datagz [L]

RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}gz -f
RewriteRule ^(.*)\.mem$ $1\.memgz [L]

RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}gz -f
RewriteRule ^(.*)\.unity3d$ $1\.unity3dgz [L]

AddEncoding gzip .jsgz
AddEncoding gzip .datagz
AddEncoding gzip .memgz
AddEncoding gzip .unity3dgz
(c'est un htaccess généré par le moteur Unity)

Je n'avais jamais eu de problème, jusqu'à donc cet après-midi où le jeu ne voulait tout simplement plus se lancer, alors que je n'avais fait aucune modification des fichiers du site.
Je remarque aussi que le transfert de certains fichiers via FTP prennent bizarrement beaucoup de temps à être appliqués sur le site. Pour la modification de l'index.html et son upload via FTP le résultat est direct, mais bizarrement quand j'upload mon css updaté cela prend bien 5 à 10 minutes avant de voir les effets, 1ère fois que ça me fait cela.

(pour information j'ai vérifié une copie de mon site sur un simple dropbox, et tout fonctionne bien)

Du coup vu ses comportements assez étrange depuis cet après-midi, je suppose qu'il y a quelques soucis sur le serveur gérant mon hébergement. Je reste à disposition si il y a besoin de plus d'informations.