OVH Community, votre nouvel espace communautaire.

désactiver la compression gzip


sthibaud
08/02/2016, 14h41
Ok merci, je vous remercie pour vos réponse rapide.

Cordialement,

Thibaud

Ludo.H
08/02/2016, 13h12
Bonjour,

J'ai testé votre site avec FF et Chrome, j'ai pas vu de soucis.
Si les soucis vienne de navigateur spécifique, vous pouvez aussi utiliser les directives : BrowserMatch :

Code:
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
En adaptant la configuration à vos besoin.

d'autre doc (en anglais) parlant de la compression :

http://httpd.apache.org/docs/2.2/mod/mod_deflate.html
http://serverfault.com/questions/212...ll-in-htaccess
https://wordpress.org/support/topic/...ng-in-htaccess

Toutefois la compression reste un plus (accélération de la transmission des pages au navigateur), à voir si le problème n'est pas plutôt votre plugin.

Cdt,

sthibaud
08/02/2016, 12h27
le domaine c'est : http://blog.moncoach.com/ et tout le site est compressé. la compression de wp super cache est bien désactivée et la règle est bien dans le .htaccess.

Cordialement,

Thibaud

Ludo.H
08/02/2016, 09h50
Bonjour,

Pouvez vous fournir le nom de domaine et la page en erreur ?

Cdt,

sthibaud
08/02/2016, 09h44
Bonjour,

Merci pour vos réponses. J'ai bien inclus la ligne dans le htaccess mais ceci n'a pas désactivé la compression.

Cordialement,

Thibaud

Ludo.H
05/02/2016, 12h01
Bonjour,

Possible de désactiver via htaccess :

RewriteRule ^(.*)$ $1 [NS,E=no-gzip:1,E=dont-vary:1]

Cdt,

janus57
04/02/2016, 18h17
Bonjour,

vu que le serveur compresse tout seul, pourquoi ne pas désactiver cette option sur le plugin wordpress ?

Cordialement, janus57

sthibaud
04/02/2016, 13h45
Bonjour à tous,

Le site se trouve sur un serveur pro mutualisé. Depuis la mise à jour de wp super cache, il se trouve que j'ai un problème : Lorsque la compression gzip est activé dans le module WP Super Cache de manière aléatoire certaines pages plante sur certain navigateurs. Je me retrouve alors avec cette erreur : ERR_CONTENT_DECODING_FAILED.
J'ai testé la compression, le fichier index.php ne contenait alors que de l'html, il se trouve que la réponse était compressé donc je pense que le serveur compresse les pages. y a-t-il un moyen désactiver cette compression?

merci d'avance pour vos réponses