OVH Community, votre nouvel espace communautaire.

Problème de point de montage /home


janus57
04/02/2016, 17h27
Bonjour,

perso j'ai un owncloud depuis un peu plus d'1an installé via les package officiel et il est stable même avec les MAJ (après j'installe pas de plugin/addon dessus car j'en ai pas l'utilité).

Cordialement, janus57

bbr18
04/02/2016, 17h11
oui il est stable tant que tu ne fais pas les mises à jour, je n'en ai jamais eu une qui n'ait pas merdouillé

VarioFlux
04/02/2016, 16h54
Bon, après toutes ces réflexions (et état grippal inside) je vais réinstaller une debian jessie...
Juste ce qui me gonfle (et on en avait déjà causé un peu sur ton propre forum) c'est qu'avec cette version debian-owncloud c'est la première fois que j'avais un owncloud stable, c'est tout le reste qui branle !

Que le monde est injuste :-)
Merci

buddy
02/02/2016, 17h49
Tu en as besoin pourquoi exactement ?

Il reste la solution pas forcément idéale mais de créer un "lien symoblique" de /home vers /var/home

bbr18
02/02/2016, 17h24
si tu veux un serveur polyvalent ce serait mieux de repartir sur une Debian nue puis ajouter virtualmin et enfin owncloud, parce que l'install d'owncloud avec le manager partitionne ton serveur de façon particulière.

VarioFlux
02/02/2016, 16h40
Oki, je commence à comprendre...

Jusqu'à présent j'utilisais une debian standard sur laquelle je greffais owncloud, et là c'est la première fois que je teste leur version debian-owncloud...

C'est rattrapable la config ou c'est plus sûr que je remette un debian de base ?

Parce que j'y ajoute virtualmin et bientôt quelques sites

bbr18
02/02/2016, 15h57
normal que ce soit sur var puisque owncloud met les fichiers ici :
/var/www/owncloud/data/ton_user/files
tu ne dois pas aller mettre des fichiers manuellement dans home
(le reste de mon arborescence est un peu différente de la tienne car c'est sur une VM, mais le principe est le même)

VarioFlux
02/02/2016, 15h47
Merci, mais j'imagine que j'ai mal décrit mon soucis...

J'ai un transmission-daemon qui tourne sur mon serveur, et quand je lance le chargement au bout de 2 ou 3 fichiers (je mets souvent en ligne des images disque de Linux) celui ci m'indique qu'il n'a plus d'espace disponible (il travaille bien sur /home lui), et j'ai bien 465 Go de libre mais sur /var, pas sur /home...

- - - Mise à jour - - -

Code:
root@welcometoparadize:/# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        20G  4.9G   14G  27% /
devtmpfs        987M     0  987M   0% /dev
tmpfs           988M     0  988M   0% /dev/shm
tmpfs           988M   35M  953M   4% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           988M     0  988M   0% /sys/fs/cgroup
/dev/sda2       439G  901M  416G   1% /var
tmpfs           198M     0  198M   0% /run/user/0

bbr18
02/02/2016, 15h28
j'ai la même chose
Code:
df -h
Filesystem      Size  Used Avail Use% Mounted on
simfs           500G   55G  446G  11% /
none            1.0G  4.0K  1.0G   1% /dev
none            205M  1.2M  204M   1% /run
none            5.0M     0  5.0M   0% /run/lock
none            512M     0  512M   0% /run/shm
none            100M     0  100M   0% /run/user
fais donc ceci et tu verras ton home
Code:
 ls -l /
total 68
drwxr-xr-x   2 root root 4096 May 29  2015 bin
drwxr-xr-x   2 root root 4096 Jan  8  2015 boot
drwxr-xr-x   5 root root 1340 Jan 23 12:39 dev
drwxr-xr-x 113 root root 4096 Jan 29 09:25 etc
drwxr-xr-x   2 root root 4096 Jan  8  2015 home
drwxr-xr-x  14 root root 4096 Feb  8  2015 lib
drwxr-xr-x   2 root root 4096 Feb 23  2015 lib64
drwx------   2 root root 4096 Jan  8  2015 lost+found
drwxr-xr-x   2 root root 4096 Jan  8  2015 media
drwxr-xr-x   2 root root 4096 Jan  8  2015 mnt
drwxr-xr-x   2 root root 4096 Jan  8  2015 opt
dr-xr-xr-x  71 root root    0 Jan 23 12:39 proc
drwx------   4 root root 4096 Oct 25 14:05 root
drwxr-xr-x  21 root root  720 Jan 23 12:40 run
drwxr-xr-x   2 root root 4096 Jan 17 17:21 sbin
drwxr-xr-x   2 root root 4096 Jan  8  2015 selinux
drwxr-xr-x   2 root root 4096 Jan  8  2015 srv
drwxr-xr-x   7 root root    0 Jan 23 12:39 sys
drwxrwxrwt   4 root root 4096 Feb  2 16:23 tmp
drwxr-xr-x  10 root root 4096 Jan  8  2015 usr
drwxr-xr-x  12 root root 4096 Jan  8  2015 var
pas de panique, tout va bien sur ton serveur

VarioFlux
02/02/2016, 15h02
Hello

Je ne suis pas pro de serveur, mais ça fait bien une dizaine d'années que je m'en sort sans trop de soucis.

Après avoir réinstallé mon serveur avec la debian owncloud je decouvre le problème suivant
Code:
root@welcometoparadize:/home# df
Filesystem     1K-blocks    Used Available Use% Mounted on
/dev/root       20026236 5068700  13917204  27% /
devtmpfs         1010572       0   1010572   0% /dev
tmpfs            1011100       0   1011100   0% /dev/shm
tmpfs            1011100   35284    975816   4% /run
tmpfs               5120       4      5116   1% /run/lock
tmpfs            1011100       0   1011100   0% /sys/fs/cgroup
/dev/sda2      459913320  921500 435606528   1% /var
tmpfs             202224       0    202224   0% /run/user/0
Je ne sais pas depuis combien de temps mon /home a disparu, mais pas de partout puisque winscp m'y donne accès sans soucis...

Je soupçonne le montage de /var a remplacé le /home (excusez-moi de simplifier) mais incapable de dire depuis combien de temps.
Je suis bien tenté de repartir à zéro mais bon, si je fais ça j'apprends jamais, et si ça se trouve c'est un petit détail dans la config...

Quelqu'un pour m'éclairer ?