OVH Community, votre nouvel espace communautaire.

Mise a jours et upgrade impossible sur Kimsufi avec Debian jessie.


Labure
31/01/2016, 12h34
Citation Envoyé par janus57
Bonjour,

dans un premier temps je vous conseil de clean votre source.list et de n'avoir que les sources officiel et surtout que les sources jessie.

Ensuite visiblement vous avez un script/service nommé "firewall" qui fait une boucle et plante vos MAJ.


je sais pas si avant vous avez fait des script ou autre qui se lance au démarrage, mais je rappel que sous jessie c'est systemd le nouveau système donc si vous avez des résidus de script init dans systemd je crois pas que l'os va apprécier.

Cordialement, janus57
Merci

c'était bien monit qui était le coupable , pour le supprimer j'ai du :

dpkg --purge remove monit
rm /etc/init.d/monit
systemctl disable monit

ensuite un reboot

et miracle tout ce met a jours sans soucie maintenant !!

janus57
31/01/2016, 11h55
Bonjour,

dans un premier temps je vous conseil de clean votre source.list et de n'avoir que les sources officiel et surtout que les sources jessie.

Ensuite visiblement vous avez un script/service nommé "firewall" qui fait une boucle et plante vos MAJ.

insserv: warning: script 'firewall' missing LSB tags and overrides
insserv: There is a loop between service monit and firewall if stopped
insserv: loop involving service firewall at depth 2
insserv: loop involving service monit at depth 1
insserv: Stopping firewall depends on monit and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement du paquet pptpd (--configure)*:
je sais pas si avant vous avez fait des script ou autre qui se lance au démarrage, mais je rappel que sous jessie c'est systemd le nouveau système donc si vous avez des résidus de script init dans systemd je crois pas que l'os va apprécier.

Cordialement, janus57

Labure
31/01/2016, 11h39
Bonjour

Depuis quelque temps mes mise a jours par apt ou aptitude echoue .

Les paquets suivants seront mis à jour*:
apache2 apache2-bin apache2-data apache2-utils apt-utils ca-certificates curl dbconfig-common file libapache2-mod-php5 libapt-inst1.5
libcurl3 libcurl3-gnutls libcurl4-openssl-dev libdns-export100 libfuse2 libirs-export91 libisc-export95 libisccfg-export90
libldap-2.4-2 libmagic1 libmysqlclient-dev libmysqlclient18 libmysqld-dev libpcre3 libpcre3-dev libpcrecpp0 libpng12-0 libsystemd0
locales mdadm multiarch-support mysql-client-5.5 mysql-common mysql-server-5.5 mysql-server-core-5.5 openjdk-7-jre-headless
openssh-client openssh-server openssh-sftp-server passwd php5-cli php5-common php5-gd php5-mcrypt php5-mysql php5-readline rsyslog
systemd systemd-sysv
Les paquets partiellement installés suivants seront configurés*:
bind9 openvpn pptpd samba udev
Les paquets suivants sont RECOMMANDÉS mais ne seront pas installés*:
libpam-systemd xauth
50 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 58,5 Mo/78,9 Mo d'archives. Après dépaquetage, 6 299 ko seront utilisés.
Voulez-vous continuer*? [Y/n/?] y
Prendre*: 1 http://security.debian.org/ jessie/updates/main libcurl4-openssl-dev amd64 7.38.0-4+deb8u3 [336 kB]
Prendre*: 2 http://security.debian.org/ jessie/updates/main curl amd64 7.38.0-4+deb8u3 [200 kB]
Prendre*: 3 http://security.debian.org/ jessie/updates/main libcurl3 amd64 7.38.0-4+deb8u3 [259 kB]
Prendre*: 4 http://security.debian.org/ jessie/updates/main libcurl3-gnutls amd64 7.38.0-4+deb8u3 [251 kB]
Prendre*: 5 http://security.debian.org/ jessie/updates/main mysql-common all 5.5.47-0+deb8u1 [82,6 kB]
Prendre*: 6 http://security.debian.org/ jessie/updates/main mysql-client-5.5 amd64 5.5.47-0+deb8u1 [1 678 kB]
Prendre*: 7 http://security.debian.org/ jessie/updates/main mysql-server-core-5.5 amd64 5.5.47-0+deb8u1 [3 353 kB]
Prendre*: 8 http://security.debian.org/ jessie/updates/main mysql-server-5.5 amd64 5.5.47-0+deb8u1 [2 022 kB]
Prendre*: 9 http://security.debian.org/ jessie/updates/main libmysqlclient-dev amd64 5.5.47-0+deb8u1 [957 kB]
Prendre*: 10 http://security.debian.org/ jessie/updates/main libmysqlclient18 amd64 5.5.47-0+deb8u1 [675 kB]
Prendre*: 11 http://security.debian.org/ jessie/updates/main openjdk-7-jre-headless amd64 7u95-2.6.4-1~deb8u1 [45,4 MB]
Prendre*: 12 http://security.debian.org/ jessie/updates/main libmysqld-dev amd64 5.5.47-0+deb8u1 [3 271 kB]
58,5 Mo téléchargés en 6s (8 832 ko/s)
Extraction des modèles depuis les paquets*: 100%
Préconfiguration des paquets...
Paramétrage de udev (215-17+deb8u3) ...
insserv: warning: script 'firewall' missing LSB tags and overrides
insserv: There is a loop between service monit and firewall if stopped
insserv: loop involving service firewall at depth 2
insserv: loop involving service monit at depth 1
insserv: Stopping firewall depends on monit and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement du paquet udev (--configure)*:
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution*:
udev
E: Sub-process /usr/bin/dpkg returned an error code (1)
Failed to perform requested operation on package. Trying to recover:
Paramétrage de pptpd (1.4.0-5) ...
insserv: warning: script 'firewall' missing LSB tags and overrides
insserv: There is a loop between service monit and firewall if stopped
insserv: loop involving service firewall at depth 2
insserv: loop involving service monit at depth 1
insserv: Stopping firewall depends on monit and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement du paquet pptpd (--configure)*:
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de bind9 (1:9.9.5.dfsg-9+deb8u5) ...
insserv: warning: script 'firewall' missing LSB tags and overrides
insserv: There is a loop between service monit and firewall if stopped
insserv: loop involving service firewall at depth 2
insserv: loop involving service monit at depth 1
insserv: Stopping firewall depends on monit and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement du paquet bind9 (--configure)*:
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de openvpn (2.3.4-5+deb8u1) ...
[ ok ] Restarting virtual private network daemon.:.
insserv: warning: script 'firewall' missing LSB tags and overrides
insserv: There is a loop between service monit and firewall if stopped
insserv: loop involving service firewall at depth 2
insserv: loop involving service monit at depth 1
insserv: Stopping firewall depends on monit and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement du paquet openvpn (--configure)*:
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de udev (215-17+deb8u3) ...
insserv: warning: script 'firewall' missing LSB tags and overrides
insserv: There is a loop between service monit and firewall if stopped
insserv: loop involving service firewall at depth 2
insserv: loop involving service monit at depth 1
insserv: Stopping firewall depends on monit and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement du paquet udev (--configure)*:
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de samba (2:4.1.17+dfsg-2+deb8u1) ...
insserv: warning: script 'firewall' missing LSB tags and overrides
insserv: There is a loop between service monit and firewall if stopped
insserv: loop involving service firewall at depth 2
insserv: loop involving service monit at depth 1
insserv: Stopping firewall depends on monit and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement du paquet samba (--configure)*:
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution*:
pptpd
bind9
openvpn
udev
samba
j'ai de plus en plus de mise a jour qui echoue avec une erreur de sortie 1 (pptpd bind9 openvpn udev samba)

du coup ca me bloque tout les autres maj en plus ce sont des paquet très important .

Mon source list :

#deb http://debian.mirrors.ovh.net/debian/ jessie main
#deb-src http://debian.mirrors.ovh.net/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://debian.mirrors.ovh.net/debian/ jessie-updates main
deb-src http://debian.mirrors.ovh.net/debian/ jessie-updates main

# jessie-backports, previously on backports.debian.org
deb http://debian.mirrors.ovh.net/debian/ jessie-backports main
deb-src http://debian.mirrors.ovh.net/debian/ jessie-backports main

deb http://debian.mirrors.ovh.net/debian/ jessie main contrib non-free
deb-src http://debian.mirrors.ovh.net/debian/ jessie main contrib non-free

deb http://download.webmin.com/download/repository sarge contrib
deb http://webmin.mirror.somersettechsol....uk/repository sarge contrib
Je sais plus comment faire pour avoir plus de details sur ces erreurs, si quelqu'un a une idée ?