OVH Community, votre nouvel espace communautaire.

Bind vs OVH


Ramucho1
29/12/2015, 20h21
oui j'ai tiré cet exemple avec les IP de google d'une doc internet, mais il faut remplacer par les IP des DNS d'ovh.
J'ai vu en lisant dans le train que par défaut, bind se comporte comme un cache, or il se trouve qu'à part créer des master zones, je n'ai touché à rien de sa config : je peux donc restaurer facilement son état initial en supprimant les master zones créées)

Nowwhat
29/12/2015, 15h53
Citation Envoyé par Ramucho1
En gros, si je comprends bien, il s'agit juste de mettre :
Code:
forwarders {
                8.8.8.8;
                8.8.4.4;
        };
        forward only;
avec les ip des dns d'ovh ?
Comme janus57, la meilleur solution est de réinstaller bind 'comme neuf' (donc remove, purge puis install dans le langage 'Debian).
Sans aucune retouche de votre part, bind sera le cache DNS 'parfait'.

PS: Faire passer toutes vos requêtes à Google, c'est bien, comme ça il (Google) va vraiment savoir ce qu'il fait votre serveur Pense à leur demander une %, car Google VA vendre ces données (anonyme, hein, bien sur ^^)

janus57
29/12/2015, 15h18
Bonjour,

mieux encore lui dire d'aller cherchez les infos sur les DNS racine (pas de DNS menteur ni de tracking).

Cordialement, janus57

Ramucho1
29/12/2015, 14h34
En gros, si je comprends bien, il s'agit juste de mettre :
Code:
forwarders {
                8.8.8.8;
                8.8.4.4;
        };
        forward only;
avec les ip des dns d'ovh ?

janus57
29/12/2015, 14h15
Bonjour,

perso je conseil de basculer bind9 en résolveur local vous verrez c'est utile.

Cordialement, janus57

Ramucho1
29/12/2015, 13h37
effectivement, en arrêtant carrément le service Bind, le sous domaine est bien résolu ... c'est encore plus simple !
Merci Janus.

janus57
29/12/2015, 13h29
Bonjour,

si vous utilisez les DNS de OVH les zones bind9 de votre serveur ne sont plus utilisé et donc inutile, je ne sais pas ce que vous essayer de faire (pas tout lu, je me suis arrêté à "j'utilise les DNS OVH").

Donc si vous utilisez les DNS de OVH faut laisser tomber bind9, vous pouvez même le passer en serveur DNS de cache local.

EDIT :
pour avoir de l'aide concrète avec les DNS faut donner le vrai NDD qui est impacté et pas jouer aux devinettes.
C'est plus simple de faire des test directement avec votre NDD.

Cordialement, janus57

Ramucho1
29/12/2015, 13h19
Bonjour,

une petite question sur un paramètre que je pense avoir loupé, mais sait-on jamais ...

"autrefois" j'avais un kimsufi et pour chaque NDD, le primaire était le ksXXXXX.kimsufi.com et le secondaire sur ns.kimsufi.com
j'avais dans mon ancien Bind des "master zones" pour chaque NDD avec les sous domaines, etc. tout fonctionnait.

"maintenant", (j'ai arrêté le kimsufi) j'ai décidé de tout passer sur les DNS d'ovh, avec juste un champ "A" à changer en cas de changement de serveur. et ça marche !

MAIS : je me suis rendu compte d'une chose : mon dédié ne "sait pas" lire le DNS d'ovh...


Exemple concret : domaine1.fr
MX = hosted exchange
A = 111.111.111.111
NS = ns11.ovh.net

Je crée une master zone sur Bind et je rentre le minimum vital, à savoir le NS. Lorsque mon site envoie un mail à contact@domaine1.fr dans les logs de postfix je vois "mail delayed - bounce to myself".

Correctif : dans Bind, j'ai créé un champ MX qui pointe aussi sur le hosted exchange, et les mails partent bien.


Mais ça veut dire que mon dédié n'a pas su trouver l'info dans les DNS d'ovh ...

Autre test : je crée sur OVH une entrée "ramucho1.domaine1.fr" type A, adresse 222.222.222.222
lorsque je ping "ramucho1.domaine1.fr" depuis mon pc perso, j'ai bien 222.222.222.222 (ça lit depuis OVH = ok)
lorsque je ping "ramucho1.domaine1.fr" depuis mon dédié, il ne sait pas le résoudre... sauf si je lui déclare l'adresse 222.222.222.222 pour une entrée "ramucho1".

Voici la config en question :
/etc/bind/named.conf.options
Code:
options {
	directory "/var/cache/bind";

	// If there is a firewall between you and nameservers you want
	// to talk to, you may need to fix the firewall to allow multiple
	// ports to talk.  See http://www.kb.cert.org/vuls/id/800113

	// If your ISP provided one or more IP addresses for stable 
	// nameservers, you probably want to use them as forwarders.  
	// Uncomment the following block, and insert the addresses replacing 
	// the all-0's placeholder.

	// forwarders {
	// 	0.0.0.0;
	// };

	//========================================================================
	// If BIND logs error messages about the root key being expired,
	// you will need to update your keys.  See https://www.isc.org/bind-keys
	//========================================================================
	dnssec-validation auto;

	auth-nxdomain no;    # conform to RFC1035
	listen-on-v6 { ::1; };
	listen-on { 127.0.0.1; 213.251.128.130; 213.251.188.130; 213.251.128.150; 213.251.188.150; };
	allow-recursion { 127.0.0.1; ::1; };
	allow-query-cache { 127.0.0.1; ::1; };
};
pour le listen-on, j'ai tenté tout d'abord avec l'ip publique de domaine1.fr : listen-on { 127.0.0.1; 111.111.111.111; }; mais voyant que ça ne donnait rien, j'ai mis les dns d'OVH. et ça ne donne rien de plus.

et voici un exemple de config de domaine1.fr vu sur Bind :
Code:
$ttl 1200
domaine1.fr.	IN	SOA	nsXXXXXXXX. trucmuche.yahoo.fr. (
			1450359801
			10800
			3600
			604800
			1200 )
domaine1.fr.		IN		A	111.111.111.111
www.domaine1.fr.	IN		A	111.111.111.111
domaine1.fr.		IN		NS	dns11.ovh.net.
domaine1.fr.		IN		NS	ns11.ovh.net.
domaine1.fr.		IN		MX	1 ex.mail.ovh.net.
où est-ce que j'ai loupé un truc ? Merci pour toute réponse. Ce n'est pas bloquant puisque je peux manuellement recréer les adresses (et j'ajoute pas une entrée DNS tous les jours ...) mais j'aimerais comprendre et corriger.

EDIT : j'ai consulté qq autres liens sur le forum, mais ça ne correspond pas à ma demande p.ex. https://forum.ovh.com/showthread.php...D-%28debian%29

Je suis sous Debian 8.2 et Bind 9.9.5.