OVH Community, votre nouvel espace communautaire.

Mise à jour de php foireuse


Darki666
14/01/2016, 19h08
Et si j'ai déjà installé webmin je dois le désinstaller ?

- - - Updated - - -

j'ai vu ce tuto :
http://www.how-to.ovh/viewtopic.php?t=12
mais il faut que j'installe software.virtualmin.com/gpl/scripts/install.sh et le fichier pour Debian 8 http://www.how-to.ovh/script_install...min-debian8.sh ou juste celui pour Debian 8 ?

janus57
14/01/2016, 18h56
Bonjour,

il suffit juste d'installer virtualmin, il s'occupe d'installer webmin et tout ce qui tourne autour.

Pour des tutos y en a ici : http://www.how-to.ovh/

Cordialement, janus57

Darki666
14/01/2016, 18h35
Merci de toute tes infos, j'aurais juste une dernière question, du coup là j'ai prit un serveur avec une debian 8 et du coup j'ai installé Webmin, connais-tu un module webmin qui pourrait me créé les domaines aussi facilement que dans la R3 (création automatique de BDD, des dossiers www du domaine,...) ? Faut-il installez Virtualmin ? et si oui as-tu un bon tuto (récent) pour cela s'il-te-plaît ?

Merci.

janus57
27/12/2015, 12h52
Citation Envoyé par Gaston_Phone
As-tu essayé de repasser en PHP 5.3 ?

Utilises-tu :
  • Des commandes mysql_xxx ?
  • Des commandes ereg ?
Bonjour,

ça marche pas comme ça sur un VPS en R3

Bonjour,
du coup là j'ai copié, les vhosts, la database et les fichiers web pour ensuite réinstaller le serveur, je n'ai rien d'autre à sauvegarder d'après toi ?
pour la BDD c'est bien un dump et pas un copier/coller sauvage des BDD MySQL sur le disque, si oui alors OK.

Si c'est pour réinstaller sur une R3 cela devrait suffire (si vous n'utilisez pas de boites mails).

Si c'est pour réinstaller sur du virtualmin les fichiers + les BDD des sites suffit vu qu'il fait refaire la configuration sous virtualmin (l'histoire de quelques minutes).

Cordialement, janus57

Gaston_Phone
26/12/2015, 19h03
As-tu essayé de repasser en PHP 5.3 ?

Utilises-tu :
  • Des commandes mysql_xxx ?
  • Des commandes ereg ?

Darki666
26/12/2015, 17h42
Bonjour,
du coup là j'ai copié, les vhosts, la database et les fichiers web pour ensuite réinstaller le serveur, je n'ai rien d'autre à sauvegarder d'après toi ?

Nowwhat
24/12/2015, 09h34
Citation Envoyé par Darki666
... n'y aurait-il pas une autre solution moins radical ? N'y a-t-il pas des logs quelque part qui pourrait m'aider d'avantage à trouver le problème ? Une commande qui testerai la config ?
Comme il n’existe pas ds experts "R3" qui communique leur expériences .... Non.
Même Google reste muet sur le sujet (et ça, ça fait allumer la gyrophare rouge - utiliser un système non-documenté, ça te fait pas flipper à toi ?? )

Des logs ? A toi de me dire. Mais trouver des logs qui peuvent t'aider pour réparer ? Je ne pense pas.
La ré-installation n'est pas une si mauvaise idée : ça va valider ton processus de sauvegarde (aussi hyper important) et tu va apprendre comment remettre tes sites en place dès qu'un catastrophe arrive (et ça arrive - va voir ce forum, faut mieux être préparé).

Citation Envoyé par Darki666
C'est ce que je pensais faire mais en dernière dernière dernière solution ...
Hélas, je me moque pas de toi, mais choisir un R3 implique carrément : dès que ça foire, tu ré - installe.
Il n'y qu'une solution pour t'en sortir de cette façon de travailler : installer autre choses (disons : utilise ce que utilise la reste de la planète terre) : un OS normal.
Au moins, tu va apprendre ce que nous avions tous appris, t'auras la même chose - et t'auras les mêmes questions, les même solutions (docn cette fois si facile à trouver).
Ça n'existe pas, la solution : je installe le R3 puis je m'occupe plus (de l'administration d'un serveur). C'est de la tromperie, cet idée ...

Darki666
24/12/2015, 09h20
C'est ce que je pensais faire mais en dernière dernière dernière solution ^^, n'y aurait-il pas une autre solution moins radical ? N'y a-t-il pas des logs quelque part qui pourrait m'aider d'avantage à trouver le problème ? Une commande qui testerai la config ?

Nowwhat
24/12/2015, 07h59
Bonjour,

T'as cassé le règle d'or: t'as un R3 donc faut pas faire ce genre de choses.
Seule les experts peuvent s'en sortir .... mais les experts n'ont pas un 'R3' (car trop chiant, contraignent, doc pas existant, logiciels trop vieux, etc etc)

Sur ce forum tu trouveras des milliers de messages qui te dissent tous la même chose : t'as un OS de la série Rx, donc, uniquement les mise à jours d'OVH de ton OS (depuis R3 - et encore sous réserve) et OVH devront être appliqués.

Solution: exporte tes bases (avec ligne de commande, sachant que PHP est cuit donc pas de phpmyadmin)
Sauvegarde tes "hébergement sites".

Puis réinstalle.
Et pense à te donner toi-même le cadeau de noël: choisi cette fois si un OS 'normal'
Exemple: Debian utilise par défaut PHP 5.6.14 en ce moment.

Darki666
24/12/2015, 07h31
bonjour tout le monde,
J'ai voulu mettre à jour PHP de mon VPS qui tourne sur la Release3 de OVH et donc sur l'OS CentOS 6.7. De base c'est un PHP 5.3, que j'ai désinstallé via la commande "yum remove php php-cli php-common" et ensuite j'ai installé la 5.6 via les instruction du site https://webtatic.com/packages/php56/.
Mais depuis mes sites sont inaccessible ... j'ai une erreur 500 Internal Server Error... alors j'ai désinstallé plusieurs fois, testé d'autres méthodes comme celle là http://www.it-connect.fr/mettre-a-jo...-debiancentos/ mais en modifiant pour php 5.6. Mais toujours pareil. Je ne trouve même plus de repo qui fournissent encore de php 5.3 pour tester au cas ou Centos 6.7 n'accepte pas plus que php 5.3.

Je pense que j'ai du oublier une config quelque part, au début j'avais un problème avec suphp, dans les logs de ce dernier j'avais "File "/home/xxxx/www/page.php" is not in document root of Vhost "/var/www/xxxx/www"", mais j'ai modifier le fichier de conf /etc/suphp.conf et ça à l'air d'être bon je n'ai plus rien dans les logs de suphp.
Si je regarde dans les logs du vhost que je visite il me dit juste "[error] [client XX.XX.XXX.XX] Premature end of script headers: index.php" mais de ce que j'en ai lu cela peut venir de plein de choses...

Est ce que quelqu'un aurais une piste à me proposer svp ? Merci d'avance.

Edit : Petite précision, les fichiers html marchent très bien mais pas les fichiers php