OVH Community, votre nouvel espace communautaire.

aide sur une redirection


janus57
25/12/2015, 04h20
Bonjour,

normalement pas besoin de redirection, faut juste bien déclarer le multi-domaine, puis bien paramétrer wordpress et c'est tout.

Cordialement, janus57

brunoche
25/12/2015, 03h39
Comment faire une redirection claire ? est ce chez OVH, ou dans les réglages de wordpress ? sans que ça ne me foute pas le b......l partout

Cordialement
Bruno

janus57
25/12/2015, 03h11
Bonjour,

en gros "http://www.martial-lamouette.mu/" inclus des pages venant de "http://www.lafrangipane.net/martial/" dans un cadre interne, ce qui pénalise le référencement et affiche toujours des liens en "http://www.lafrangipane.net/martial/".

Vous avez juste crée une fausse redirection via la manager OVH.

Cordialement, janus57

brunoche
25/12/2015, 02h22
Merci de votre réponse.

Mais c'est franchement du chinois pour moi ce que vous m'avez envoyé.

Pour rappel, j’héberge un petit site dans le "www " de mon nom de domaine.

Bonne fêtes de fin d'année
Bruno

janus57
24/12/2015, 17h04
Bonjour,

heu pas vraiment en faite :
Code:
root@janus57-beta:~# curl http://www.martial-lamouette.mu/

    
        
            Martial la mouette
            
            
            
            
            
        
        
            
            
            
                <body><a href="http://www.lafrangipane.net/martial">Click here</a><hr></body>
            
        
    
C'est juste une iframe qui va pourrir votre référencement et surtout garder vos anciens liens :
Code:
root@janus57-beta:~# curl -I http://www.lafrangipane.net/martial
HTTP/1.1 301 Moved Permanently
Set-Cookie: 90planBAK=R698931959; path=/; expires=Thu, 24-Dec-2015 17:06:55 GMT
Content-Type: text/html; charset=iso-8859-1
Set-Cookie: 90plan=R1530978702; path=/; expires=Thu, 24-Dec-2015 17:23:15 GMT
Server: Apache
Location: http://www.lafrangipane.net/martial/
Vary: Accept-Encoding
Date: Thu, 24 Dec 2015 16:04:10 GMT
Connection: keep-alive
X-Geo: varn22.rbx5
X-Geo-Port: 1002
X-Cacheable: Not cacheable: no cache headers from backend
Cordialement, janus57

brunoche
24/12/2015, 16h37
Bonsoir.

J'ai enfin trouvé la solution. j'ai tout simplement réinstallé wordpress dans un autre dossier, modifié la redirection chez OHV et ça fonctionne comme je le souhaitais.

Merci à ceux qui m'ont répondu.
Cordialement
Bruno

janus57
22/12/2015, 14h01
Bonjour,

si l'installation de base est correcte il n'y a normalement rien à changer au niveau du .htaccess

Cordialement, janus57

brunoche
22/12/2015, 13h45
Citation Envoyé par janus57
Bonjour,

trouver l'origine du problème et le corriger en gros.

Le problème que vous décrivez est souvent un problème de configuration de wordpress au niveau de la config voir .htaccess.

Chose qui serait "simple" à faire c'est installer un wordpress nue puis importer le thème + articles et voilà finit.

Cordialement, janus57
C'est ce que je suis entrain de faire tranquillement. Après m'attaquer au htaccess. mais la encore je ne sais pas quoi changer.

Cordialement
Bruno

janus57
22/12/2015, 13h37
Bonjour,

trouver l'origine du problème et le corriger en gros.

Le problème que vous décrivez est souvent un problème de configuration de wordpress au niveau de la config voir .htaccess.

Chose qui serait "simple" à faire c'est installer un wordpress nue puis importer le thème + articles et voilà finit.

Cordialement, janus57

brunoche
22/12/2015, 13h28
Debuger ??? Un tout petit détail en plus, je suis une brelle en anglais

Cordialement
Bruno

janus57
22/12/2015, 13h23
Bonjour,

dans ce genre de cas plutôt que de recommencer il est plus simple de débuger, cela va plus vite, surtout que wordpress a un relativement bon wiki pour ça.

Cordialement, janus57

brunoche
22/12/2015, 12h17
Bonjour.

je me suis retrouvé avec le site sans aucune mise en page, tout à la suite comme si le "style.css" n'existait plus.

Je n'arrivais plus a entrer dans l'admin. Enfin le grand bazar.

Pas grave, l'ancien fonctionne encore et je recommence depuis le début.

Cordialement
Bruno

janus57
22/12/2015, 12h03
Bonjour,

comment ça ?

Cordialement, janus57

brunoche
22/12/2015, 05h27
Bonjour

Merci d'avoir prit le temps de me répondre.

Le résultat n'est pas celui que j'attendais, comment dire, ça a tout merdouillé. heureusement le site est assez léger pour le reconstruire assez vite.

Cordialement
Bruno

janus57
22/12/2015, 02h51
Bonjour,

je pense que votre problème est que vous devez dire à wordpress d'utiliser "martial-lamouette.mu" plutôt que "lafrangipane.net" hors cela se passe dans l'administration de wordpress, et normalement cela devrais aussi modifier le .htaccess si c'est bien configuré côté OVH le multidomaine.

Cordialement, janus57

brunoche
22/12/2015, 02h46
Bonjour Loic.

J'ai regardé le htaccess, mais la c'est franchement du chinois pour moi. je ne sais pas ce que je doit y changer. j'ai tenté plusieurs truc qui n'ont pas fonctionné dans la ligne " RewriteRule . /Martial/index.php [L] "

a l'heure actuelle j'ai ça

# BEGIN WordPress

RewriteEngine On
RewriteBase /Martial/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /Martial/index.php [L]


# END WordPress

Merci de votre aide
Bruno

L.YA
20/12/2015, 13h10
Dans l'espace de ton hébergement (sur l'espace client), tu peux configurer ça dans l'onglet "Domaines associés" . Dans cet onglet, tu devrais voir "martial-lamouette.mu" et peut-être même "www.martial-lamouette.mu". Pour chacun d'eux, le bouton d'edition te permettra de modifier le dossier racine. Tu peux ainsi mettre www/Martial ou tout autre repertoire selon ton besoin.

brunoche
20/12/2015, 05h13
Merci de votre rapidité de répondre.

A la suite d'une mauvaise manip, j'ai tout supprimé et je réinstalle.

Ensuite j'essaie d'appliquer vos pistes. Je souhaiterai que le nom de "martial-lamouette.mu" ne soit pas précédé de lafrangipane.

Merci encore
Bruno

L.YA
20/12/2015, 04h43
Bonsoir brunoche,

Si tu passes par là : http://www.lafrangipane.net/Martial/index.php (en mettant index.php directement), on a quelque chose (incomplet mais quelque chose).

Cela me semble être dû au fichier .htaccess qui ne contient pas les éléments de "base" au fonctionnement des url rewriting utilisé par wordpress.

Voir ici : https://codex.wordpress.org/htaccess

Tu peux récupérer celui que tu as en local (en adaptant le chemin RewriteBase / probablement) soit te baser sur la documentation WordPress.

Par ailleurs, je te recommande de modifier et faire pointer le domaine "martial-lamouette.mu" vers www/Martial , a l'heure actuel, il pointe vers un répertoire inexistant !

brunoche
20/12/2015, 04h18
Bonjour

Petit problème à résoudre pour vous, gros pour moi.
Je vais tenter d’être le plus clair possible. Je suis hébergé chez OVH, mon site est construit avec wordpress

1) J’ai mon nom de domaine (lafrangipane.net)
2) Dans le dossier « www » mon site est localisé dans un dossier « site »
3) J’ai un deuxième petit site (martial-lamouette.mu) dans le dossier « www » sous le nom « martial »
4) Il s’ouvre avec « accueil.html » jusqu’à la tout va bien

En local je l’ai refaitavec wordpress et transféré avec l’extension Duplicator.
Le site s’ouvre sur une page que je n’ai pas créé, avec cette inscription « Aucun résultat trouvé
La page que vous avez demandé n'a pas été trouvé. Essayez d'affiner votre recherche, ou utiliser la navigation ci-dessus pour retrouver l'article. »

Je ne sais pas du tout à quel niveau je dois intervenir pour que le site s’ouvre directement sur la page d’accueil du deuxième site.

Merci pour votre aide.
Cordialement
Bruno