OVH Community, votre nouvel espace communautaire.

Problème avec mon serveur dédié???


Avignon
14/12/2015, 08h27
d'abord je voudrais bien signaler que mon problème est réglé. La solution ou la cause était une mauvaise attribution des ID_order_statut dans la BDD.

Simplement l'examen de mon fichier m'a permit de constater certains erreurs ou/et des fichiers sur le serveur qui n'y avaient pas à être.

Merci quand même pour votre aide!

bbr18
13/12/2015, 12h10
/var/log/httpd/
oui c'est normal si tu es sous Centos, où est le problème ??
regarde ce qu'il y a dans error_log
Code:
cat  /var/log/httpd/error_log
ou s'il est très volumineux
Code:
tail -n 50  /var/log/httpd/error_log
ou 50 correspond à afficher les 50 dernières lignes

Avignon
13/12/2015, 12h06
Ni le /var/log/apache2/ existe ni le /home/log/httpd/.

J'ai simplement un folder /var/log/httpd/ avec ces fichiers:

suexec_log
error_log
error_log20151213
access_log
suexec_log-20151213
access_log-20151213
error_log-20151206
suexec_log-20151206
access_log-20151206
access_log-20151130
error_log-20151129
suexec_log-20151129
error_log-20151122
suexec_log-20151122
access_log-20151122
ssl_error_log
ssl_error_log-20150531
ssl_request_log
ssl_acces_log

C'est tout!

bbr18
13/12/2015, 11h46
Le folder /var/log/apache/ n'existe même pas.
/var/log/apache2 ou /home/log/httpd selon ta distribution

Avignon
13/12/2015, 11h43
Suite à un hack en mai 2015, j'ai dû réinstaller mon serveur. Les sauvegardes de mes domaines m'ont permit de les recopier. Un forum MYBB était installé tout neuf et j'ai pu importer la BDD. Il marche sans le moindre problème.

Sur un autre domaine, j'ai perdu ma boutique PrestaShop totalement. Donc, j'ai installé la dernière version de PrestaShop et j'ai recrée tous les articles etc. donc une BDD toute neuve.

Malheureusement j'ai un grave problème avec les modules de paiement. La cause doit se trouver sur le serveur. Quand la dernière étape de validation d'un commande avec le choix du moyen de paiement doit m'afficher la page /shop/module/cheque/validation, j'obtiens un message d'erreur '500 server error).

Sur le forum PrestaShop, on m'a pisté de vérifier quelques fichiers error_log dans /var/log/httpd/ et dans /var/log/apache/.

Voici le fichier /var/log/httpd/error_log:
[Sun Dec 13 03:39:20 2015] [notice] Digest: generating secret for digest authentication ...
[Sun Dec 13 03:39:20 2015] [notice] Digest: done
[Sun Dec 13 03:39:20 2015] [notice] mod_bw : Memory Allocated 0 bytes (each conf takes 48 bytes)
[Sun Dec 13 03:39:20 2015] [notice] mod_bw : Version 0.92 - Initialized [0 Confs]
[Sun Dec 13 03:39:20 2015] [error] python_init: Python version mismatch, expected '2.6.5', found '2.6.6'.
[Sun Dec 13 03:39:20 2015] [error] python_init: Python executable found '/usr/bin/python'.
[Sun Dec 13 03:39:20 2015] [error] python_init: Python path being used '/usr/lib64/python26.zip:/usr/lib64/python2.6/:/usr/lib64/python2.6/plat-linux2:/usr/lib64/python2.6/lib-tk:/usr/lib64/python2.6/lib-old:/usr/lib64/python2.6/lib-dynload'.
[Sun Dec 13 03:39:20 2015] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Sun Dec 13 03:39:20 2015] [notice] mod_python: using mutex_directory /tmp
[Sun Dec 13 03:39:20 2015] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Sun Dec 13 03:39:20 2015] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Sun Dec 13 03:39:20 2015] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Sun Dec 13 03:39:20 2015] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Sun Dec 13 03:39:20 2015] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Sun Dec 13 03:39:20 2015] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Sun Dec 13 03:39:20 2015] [notice] Apache/2.2.15 (Unix) DAV/2 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.6.6 mod_ssl/2.2.15 OpenSSL/1.0.1e-fips mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations


Le folder /var/log/apache/ n'existe même pas.

Comme info, je me suis lancé dans l’apprentissage d'administration d'un serveur dédié mais vu la complexité du sujet, je vais avoir besoin de pas mal de temps. Je serais alors très reconnaissante pour tout aide à mon problème urgent.