OVH Community, votre nouvel espace communautaire.

Postfix / Auth SMTP / Multi IP / multi domaines


Ramucho1
28/12/2015, 14h12
je viens de finaliser mon serveur.
Hormis un bug avec le manager OVH qui me tronque les options dkim (quand je coche la case DKIMv1 par exemple, le champ d'aperçu en bas menvionne bien v=DKIM1 mais losque je valide au final, ça a disparu ... Je suis obligé de rentrer en mode textuel), tout a l'air bon.
dans tous les tests que tu me présentais plus haut, il n'y a rien d'alarmant (qq warnings sur la SOA par exemple qui a un temps de refresh pas dans les limites, bizarre car c'est le template par défaut mais bon...).

En tout cas, GRAND MERCI nowwhat et GRAND MERCI à ktp qui est aussi intervenu !
je vous souhaite d'excellentes fêtes de fin d'année à tous les 2.

Ramucho1
15/12/2015, 16h07
il manquait l'IP v6 dans mon SPF car google mail me le demandait, et avec, j'ai un beau SPF: passed

il ne me reste plus qu'à résoudre le warning dans les logs :

warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
je m'y attèle, mais ceci ne semble pas avoir d'incidence sur mail-tester.

EDIT : rajouter la ligne alias_maps = hash:/etc/aliases dans le main.cf + postfix reload semble suffisant pour résoudre le souci.

Ramucho1
15/12/2015, 14h35
Voilà, 10/10 à mail tester :-) youpiii !

Merci pour vos aides respectives!

Ramucho1
14/12/2015, 16h04
Code:
root@MonServ:~# netstat -napt | grep 'master'
tcp        0      0 222.222.222.222:25       0.0.0.0:*               LISTEN      1571/master
tcp        0      0 111.111.111.111:25       0.0.0.0:*               LISTEN      1571/master
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      1571/master
Edit : la commande SSH fonctionne désormais, j'ai 7/10 sur mail-tester.
par contre, comment lui indiquer de passer par une adresse IP failover plutôt que par l'ip générique du serveur ?
car forcément il ne reconnait pas mon reverse...

EDIT : même en me connectant en SSH via l'IP failover 111.111.111.111 j'ai tout de même [SPF] MonServeurIP n'autorise pas votre serveur AAA.BBB.CCC.DDD à utiliser root@MonServeur.

EDIT 2 : avec un script PHP (phpmailer) j'ai pu faire un essai directement sur le site web correspondant. Vu que c'est un site de test, il n'y a pas encore tous les SPF etc. J'ai 7/10 dans mail tester, c'est déjà beaucoup mieux :-)
je vais mettre un SPF sur ce domaine et un dmarc voire dkim pour tester au fur et à mesure.

Nowwhat
14/12/2015, 15h55
Citation Envoyé par Ramucho1
Quant à Mail-tester :
mais sur mon SYS, la commande "mail" est introuvable. C'est juste parce que j'ai commenté la ligne "smtp" dans le master.cf ... PAr quelle syntaxe puis-je la remplacer ?
Pas de "mail" ?
Normal.
Pareil pour ton KS, t'as du l'installer ....
Faut faire la même chose sur ton SYS.
Code:
apt-get update
apt-get install mailutils
Et t'as 'mail' (et quelques autres outils)

Citation Envoyé par Ramucho1
Code:
Dec 14 16:18:34 MONSERV postfix-mail.domaine1.com/smtp[9915]: B9E2BC0609: to=, relay=mail-tester.com[94.23.206.89]:25, delay=1028, delays=1028/0.01/0.3/0.13, dsn=4.7.1, status=deferred (host mail-tester.com[94.23.206.89] said: 451 4.7.1 Service unavailable - try again later (in reply to end of DATA command))
...'est juste parce que j'ai commenté la ligne "smtp" dans le master.cf ... PAr quelle syntaxe puis-je la remplacer ?
Oula ........ T'es sur la ??
Donne nous
Code:
netstat -napt | grep 'master'

Nowwhat
14/12/2015, 15h23
Citation Envoyé par Ramucho1
....
je ne comprends pas, comment le tester pour être sûr que ce réglage fonctionne ?
je suis en train de me pencher sur SPF, puis Dkim, etc.
postfix + debug && Google => http://postfix.traduc.org/index.php/DEBUG_README.html

Ouvre deux fenêtres SSH.
lance dans une:
tail -f /var/log/mail.log

Dans l'autre, modifié master.cf (/etc/postfix/master.cf
Cherche
rewrite unix - - - - - trivial-rewrite
et change le pour rewrite unix - - - - - trivial-rewrite -v

Puis cherche
cleanup unix n - - - 0 cleanup
et change le pour
cleanup unix n - - - 0 cleanup -v

puis sauvegarde.
Puis relance postfix:
service postfix reload

Utilise un webmail (ou mail client) pour envoyer un mail à, parti d'undomaine sur ton serveur.

Admire le résultat dans la fenetre SSH "tail -f /var/log/mail.log"
Difficile de demander plus de détails encore (quoi que possible, change le"-v" pour "-v -v" plus haut et assume


Dans mes logs, je trouve dans ce cas, entre autre la conversion de "sender_dependent_default_transport_maps"
Dec 14 15:47:51 ns311465 postfix/trivial-rewrite[30543]: maps_find: sender_dependent_default_transport_maps: mysql:/etc/postfix/mysql-sdd_transport_maps.cf(0,lock|no_regsub|fold_fix): monmail@mondomaine.fr = mondomaine_fr:

ce mondomaine_fr est justement mappé dans mon master.cf:
Code:
mondomaine_fr  unix -       -       n       -       -       smtp
   -o smtp_bind_address=a.b.c.d
   -o smtp_bind_address6=2001:41D0:y:xx::11
   ......
Petit détail: pour gérer tout ça plus facilement, j'utilse pas un fichier 'hash' (ton /etc/postfix/sender_transport) mais une tabe / base MySQL.
Le tout fonctionne de la même façon.

Qui faire ?
https://www.mail-tester.com/ teste tout ça (et plus)
D’ailleurs :
Pour le DNS : http://www.dnsinspect.com/
Les certificats : https://www.ssllabs.com/ssltest/ (le https)
Le TLS : https://starttls.info/
Et tant que on y est : https://www.checktls.com/

Ramucho1
14/12/2015, 15h20
Quant à Mail-tester :
Code:
Dec 14 16:18:34 MONSERV postfix-mail.domaine1.com/smtp[9915]: B9E2BC0609: to=, relay=mail-tester.com[94.23.206.89]:25, delay=1028, delays=1028/0.01/0.3/0.13, dsn=4.7.1, status=deferred (host mail-tester.com[94.23.206.89] said: 451 4.7.1 Service unavailable - try again later (in reply to end of DATA command))
je réessaierai plus tard.

EDIT : sur mon ancien kimsufi, la commande SSH fonctionne :
Code:
echo  "salut quelle note pour cet envoi de mail ?" | mail -s "tester mon envoi de mail" web-vgWjBs@mail-tester.com
mais sur mon SYS, la commande "mail" est introuvable. C'est juste parce que j'ai commenté la ligne "smtp" dans le master.cf ... PAr quelle syntaxe puis-je la remplacer ?

Ramucho1
14/12/2015, 14h33
postmap -q @domaine.com hash:/etc/postfix/sender_transport
et
postmap -q @domaine2.fr hash:/etc/postfix/sender_transport
Merci, je viens de passer 20 min à revérifier mes configs, mais ce que tu énonces marche bien, ouf

Place aussi ceci dans ton /etc/postfix/main.cf
masquerade_domains = domaine.com domaine2.fr
pour que postfix va simplifier tes domaines d'émission comme "mail.domaine.com"
je ne comprends pas, comment le tester pour être sûr que ce réglage fonctionne ?
je suis en train de me pencher sur SPF, puis Dkim, etc.

ils ne donnent pas exactement les mêmes résultats, mais se complètent :
http://www.spfwizard.net/
http://www.microsoft.com/mscorp/safe...d/default.aspx

Nowwhat
14/12/2015, 13h40
Citation Envoyé par Ramucho1
....
- le fichier /etc/postfix/sender_transport contient
Code:
@domaine.com               domaine1com-out:
@domaine2.fr                  domaine2fr-out:
- j'ai bien généré le hash avec la commande postmap hash:/etc/postfix/sender_transport + reload postfix
Le test est donc le suivant:
postmap -q @domaine.com hash:/etc/postfix/sender_transport
et
postmap -q @domaine2.fr hash:/etc/postfix/sender_transport

Place aussi ceci dans ton /etc/postfix/main.cf
masquerade_domains = domaine.com domaine2.fr
pour que postfix va simplifier tes domaines d'émission comme "mail.domaine.com" (@mail.domaine.com ne fait pas travailler "sender_transport) vers "domaine.com".

Ramucho1
14/12/2015, 12h52
Hello
merci pour ces précisions. Je ne sais pas si j'en sortirai un jour ...

c'est précisément un des liens que j'ai suivis pour le multi banner.

postmap -q mail.domaine1.com hash:/etc/postfix/sender_transport
devrait répondre:
domaine1-out
pourtant, ça ne répond rien ...
or :

- la ligne
sender_dependent_default_transport_maps = hash:/etc/postfix/sender_transport est bien dans mon main.cf

- le fichier /etc/postfix/sender_transport contient
Code:
@domaine1.com               domaine1com-out:
@domaine2.fr                  domaine2fr-out:
- j'ai bien généré le hash avec la commande postmap hash:/etc/postfix/sender_transport + reload postfix

Nowwhat
11/12/2015, 18h11
Citation Envoyé par Ramucho1
Mais ça n'explique pas pourquoi c'est l'@IP administrative du serveur qui ressort. je reviendrai poster sur ce fil de discussion.
postfix est sensé d'utiliser le bon IP (un IPFO sur ton serveur, lié à un domaine sur ton serveur) avec ceci:
sender_dependent_default_transport_maps = hash:/etc/postfix/sender_transport
et ceci:
Code:
domaine1-out  unix -       -       n       -       -       smtp
   -o smtp_bind_address=111.111.111.111
   ........
domaine2-out  unix -       -       n       -       -       smtp
   -o smtp_bind_address=222.222.222.222
   ......
Il faut donc tester cette partie.
Par exemple : http://serverfault.com/questions/650...ip-smtp-banner
et ceci:
postmap -q mail.domaine1.com hash:/etc/postfix/sender_transport
devrait répondre:
domaine1-out

EVITE d'utiliser un domaine (qui est géré par ton serveur) AVANT d'avoir TOUT testé avec, entre autre http://www.mail-tester.com/
Des milliers d'autres sites "test mon serveur mail coté émission" existe sur le net.

Sans ce tests, à réaliser avant la mise en service, tu donne immédiatement aux serveurs mails (outlook, msn, gmail, yahoo, etc etc) une raison de ne plus aimer ton serveur (domaine) pour un bout de temps.
outlook.com te le dit clairement dans son message d'erreur.

Ne envoie aucun mail avant que SPF, DKIM, DMARC, reverse DNS de ton IP sont ok. Il te faut le 10/10 sur http://www.mail-tester.com/ ....

Ramucho1
11/12/2015, 15h59
Salut,
oui c'est ma "next step" pour ce WE.
Mais ça n'explique pas pourquoi c'est l'@IP administrative du serveur qui ressort. je reviendrai poster sur ce fil de discussion.
Merci pour vos réponses.

bbr18
11/12/2015, 14h38
vas sur ce site et fais le test, tu auras tout ce qui cloche dans ton envoi de mail et des conseils pour y remédier http://www.mail-tester.com/

Ramucho1
11/12/2015, 13h51
hello,
bon, ya du mieux, mais ce n'est pas encore fini : l'auth fonctionne (c'est un bon point) mais les mails ne partent pas.
par exemple, quand je tente un email vers une @outlook.com j'ai ces lignes en retour :

Code:
Dec 11 12:10:33 mail.domaine1.com/smtpd[2697]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Dec 11 12:10:33 SERVmail.domaine1.com/smtpd[2697]: connect from LCaen-***.abo.wanadoo.fr[80.***.***.***]
Dec 11 12:11:06 SERVmail.domaine1.com/smtpd[2697]: D91D9C0DCC: client=LCaen-***.abo.wanadoo.fr[80.***.***.***], sasl_method=PLAIN, sasl_username={monUserPostfix}@mailmail.domaine1.com
Dec 11 12:11:11 SERVmail.domaine1.com/smtpd[2697]: warning: non-SMTP command from LCaen-***.abo.wanadoo.fr[80.***.***.***]: Subject: test
Dec 11 12:11:11 SERVmail.domaine1.com/smtpd[2697]: disconnect from LCaen-***.abo.wanadoo.fr[80.***.***.***]
Dec 11 12:11:34 SERVmail.domaine1.com/smtpd[2697]: connect from LCaen-***.abo.wanadoo.fr[80.***.***.***]
Dec 11 12:12:18 SERVmail.domaine1.com/smtpd[2697]: BD7B3C0DCC: client=LCaen-***.abo.wanadoo.fr[80.***.***.***], sasl_method=PLAIN, sasl_username={monUserPostfix}@mailmail.domaine1.com
Dec 11 12:12:31 SERV postfix/cleanup[2794]: BD7B3C0DCC: message-id=<>
Dec 11 12:12:31 SERV postfix/qmgr[1594]: BD7B3C0DCC: from=, size=299, nrcpt=1 (queue active)
Dec 11 12:12:32 SERV postfix/smtp[2889]: BD7B3C0DCC: to=, relay=mx2.hotmail.com[65.55.37.120]:25, delay=26, delays=24/0/1.1/0.16, dsn=5.0.0, status=bounced (host mx2.hotmail.com[65.55.37.120] said: 550 SC-001 (COL004-MC4F2) Unfortunately, messages from ***.***.***.*** weren't sent. Please contact your Internet service provider since part of their network is on our block list. You can also refer your provider to http://mail.live.com/mail/troubleshooting.aspx#errors. (in reply to MAIL FROM command))
Dec 11 12:12:32 SERV postfix/smtp[2889]: BD7B3C0DCC: lost connection with mx2.hotmail.com[65.55.37.120] while sending RCPT TO
Dec 11 12:12:32 SERV postfix/cleanup[2794]: 58CC5C0DD4: message-id=<20151211111232.58CC5C0DD4@SERV.ip-**.eu>
Dec 11 12:12:32 SERV postfix/bounce[2890]: BD7B3C0DCC: sender non-delivery notification: 58CC5C0DD4
Dec 11 12:12:32 SERV postfix/qmgr[1594]: 58CC5C0DD4: from=<>, size=2816, nrcpt=1 (queue active)
Dec 11 12:12:32 SERV postfix/qmgr[1594]: BD7B3C0DCC: removed
et d'ailleurs hotmail m'affiche l'@IP administrative de mon serveur ce qui n'est plus la bonne adresse. Je vais revérifier mes scripts.

Ramucho1
10/12/2015, 14h53
Salut,
ayant été en déplacement hier, je n'ai pas pu te répondre.

J'ai fait un test rapide mardi soir, ça a eu l'air de marcher. Je reteste et reviens dire si c'est bon pour moi. J'ai l'impression que c'est juste le $myhostname qui manquait ... Merci beaucoup pour cette réponse qui m'a permis d'avancer. A très vite, je réinstalle mon serveur from scratch et je reteste.

ktp
08/12/2015, 08h00
Référence :
Cyrus SASL configuration for the Postfix SMTP server
http://www.linuxtopia.org/online_boo...EADME_008.html

Le plus simple serait d'utiliser les mots de passe de la base Cyrus SASL:

smtpd.conf:
pwcheck_method: auxprop
auxprop_plugin: sasldb
mech_list: PLAIN LOGIN CRAM-MD5 DIGEST-MD5

Puis utiliser les commandes :
saslpasswd2
sasldblistusers2

Ramucho1
03/12/2015, 16h18
Bonjour,

j'ai un serveur dédié sous Debian 8.1/jessie, avec postfix 2.11.3
ce serveur a plusieurs IP, et plusieurs domaines de tests dessus (il est actuellement en test encore).

Pour ce sujet, je donne arbitrairement cet environnement :
domaine1.com [ip 111.111.111.111]
domaine2.fr [ip 222.222.222.222]
Environnement logiciel : Apache, MySQL, PHP. Rien de bien extra.

Pour chaque domaine, j'ai configuré le reverse dans le manager de façon que mail.domaine1.com => 111.111.111.111 et idem pour mail.domaine2.fr sur son IP.

la config multi IP fonctionne.

le telnet en port 25 affiche bien la bonne bannière (trouvé un tuto qui explique comment faire).


Ce que je souhaite faire : configurer une authentification SMTP pour les domaines.

Concrètement, après des pages de liens violets sous google, je n'arrive toujours pas à faire fonctionner cette authentification. Dans un premier temps, je la fais sans TLS.
j'ai teté :
- postfix + mysql
- postfix + cyrus (mais sur un tuto fedora, je ne suis pas allé loin)
- postfix + dovecot

je ne veux pas d'imap ni de pop3 : mon serveur n'héberge aucun mail pour domaine1.com ni domaine 2.fr (les MX pointent vers un exchange online).

Verdict : lorsque je tente :
- AUTH LOGIN + base64 d'un login/mdp, j'ai l'erreur "535 5.7.8 Error: authentication failed: generic failure"
- testsaslauthd -u user -p monpass, j'ai l'erreur "connect() no such file or directory"


Mes récentes sources :
http*//michauko.org/docs/debian_testing/install_debian.pdf
http*//gogs.info/books/debian-mail/chunked/postfix.sasl.html
http*//www.nervous.it/txt/Postfix-SMTP-AUTH-4-DUMMIES.html

Mes fichiers de conf :


main.cf
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no
sender_dependent_default_transport_maps = hash:/etc/postfix/sender_transport

smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sender_restrictions = permit_sasl_authenticated




début du master.cf
Code:
#
# Postfix master process configuration file.  For details on the format
# of the file, see the master(5) manual page (command: "man 5 master" or
# on-line: http://www.postfix.org/master.5.html).
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
#smtp      inet  n       -       -       -       -       smtpd
127.0.0.1:smtp inet  n     -       n       -       -       smtpd
      -o syslog_name=postfix-localhost
      -o smtp_helo_name=localhost
      -o smtp_bind_address=127.0.0.1
      -o myhostname=localhost
111.111.111.111:smtp inet  n     -       n       -       -       smtpd
      -o syslog_name=postfix-mail.domaine1.com
      -o smtp_helo_name=mail.domaine1.com
      -o smtp_bind_address=111.111.111.111
      -o myhostname=mail.domaine1.com

222.222.222.222:smtp inet  n     -       n       -       -       smtpd
      -o syslog_name=postfix-mail.domaine2.fr
      -o smtp_helo_name=mail.domaine2.fr
      -o smtp_bind_address=222.222.222.222
      -o myhostname=mail.domaine2.fr

domaine1com-out  unix -       -       n       -       -       smtp
   -o smtp_bind_address=111.111.111.111
   -o smtp_helo_name=mail.domaine1.com
   -o syslog_name=postfix-mail.domaine1.com

domaine2fr-out  unix -       -       n       -       -       smtp
   -o smtp_bind_address=222.222.222.222
   -o smtp_helo_name=mail.domaine2.fr
   -o syslog_name=postfix-mail.domaine2.fr

#smtp      inet  n       -       -       -       1       postscreen
#smtpd     pass  -       -       -       -       -       smtpd
#dnsblog   unix  -       -       -       -       0       dnsblog
#tlsproxy  unix  -       -       -       -       0       tlsproxy
#submission inet n       -       -       -       -       smtpd
#  -o syslog_name=postfix/submission
#  -o smtpd_tls_security_level=encrypt
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_reject_unlisted_recipient=no
#  -o smtpd_client_restrictions=$mua_client_restrictions
#  -o smtpd_helo_restrictions=$mua_helo_restrictions
#  -o smtpd_sender_restrictions=$mua_sender_restrictions
#  -o smtpd_recipient_restrictions=
#  -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
#smtps     inet  n       -       -       -       -       smtpd


/var/log/mail.info
Code:
Dec  3 15:33:07 MONSERVEUR postfix-mail.domaine1.com/smtpd[13657]: connect from *****.abo.wanadoo.fr[***]
Dec  3 15:33:43 MONSERVEUR postfix-mail.domaine1.com/smtpd[13657]: warning: *****.abo.wanadoo.fr[***]: SASL LOGIN authentication failed: bad protocol / cancel
Dec  3 15:33:49 MONSERVEUR postfix-mail.domaine1.com/smtpd[13657]: disconnect from *****.abo.wanadoo.fr[***]
Dec  3 15:34:09 MONSERVEUR postfix-mail.domaine1.com/smtpd[13657]: connect from *****.abo.wanadoo.fr[***]
Dec  3 15:34:14 MONSERVEUR postfix-mail.domaine1.com/smtpd[13657]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Dec  3 15:34:14 MONSERVEUR postfix-mail.domaine1.com/smtpd[13657]: warning: SASL authentication failure: Password verification failed
Dec  3 15:34:14 MONSERVEUR postfix-mail.domaine1.com/smtpd[13657]: warning: *****.abo.wanadoo.fr[***]: SASL PLAIN authentication failed: generic failure
Dec  3 15:39:15 MONSERVEUR postfix-mail.domaine1.com/smtpd[13657]: timeout after AUTH from *****.abo.wanadoo.fr[***]
Dec  3 15:39:15 MONSERVEUR postfix-mail.domaine1.com/smtpd[13657]: disconnect from *****.abo.wanadoo.fr[***]
/etc/postfix/sasl/smtp.conf
Code:
pwcheck_method: saslauthd 
#mech_list: digest-md5 cram-md5 plain login 
mech_list: plain login
log_level: 5

/etc/default/saslauthd
Code:
#
# Settings for saslauthd daemon
# Please read /usr/share/doc/sasl2-bin/README.Debian for details.
#

# Should saslauthd run automatically on startup? (default: no)
START=yes

# Description of this saslauthd instance. Recommended.
# (suggestion: SASL Authentication Daemon)
DESC="SASL Authentication Daemon"

# Short name of this saslauthd instance. Strongly recommended.
# (suggestion: saslauthd)
NAME="saslauthd"

# Which authentication mechanisms should saslauthd use? (default: pam)
#
# Available options in this Debian package:
# getpwent  -- use the getpwent() library function
# kerberos5 -- use Kerberos 5
# pam       -- use PAM
# rimap     -- use a remote IMAP server
# shadow    -- use the local shadow password file
# sasldb    -- use the local sasldb database file
# ldap      -- use LDAP (configuration is in /etc/saslauthd.conf)
#
# Only one option may be used at a time. See the saslauthd man page
# for more information.
#
# Example: MECHANISMS="pam"
MECHANISMS="pam"

# Additional options for this mechanism. (default: none)
# See the saslauthd man page for information about mech-specific options.
MECH_OPTIONS=""

# How many saslauthd processes should we run? (default: 5)
# A value of 0 will fork a new process for each connection.
THREADS=5

PARAMS="-r -m /var/spool/postfix/var/run/saslauthd"
OPTIONS="-r -c -m /var/spool/postfix/var/run/saslauthd"
mes questions...
1) les logs suggèrent clairemnt que le couple login/mdp est faux. OK. (j'ai bien démarré le saslauth évidemment).
D'où vient ce login/mdp ? j'ai créé un compte via webmin avec /bin/false mais visiblement ça ne suffit pas.

2) vu que je ne veux pas de webmail ni imap ni pop3, suis-je vraiment obligé de passer par dovecot ? Je suis en train de ne faire que du postfix/saslauth, sans mysql, sans dovecot. ça me parait plus simple.

Merci beaucoup par avance pour toute aide ...

Ramucho