OVH Community, votre nouvel espace communautaire.

php non interpreté apr le serveur (telecharge au lieu de l'executer)


arn0
04/11/2015, 09h08
je viens de modifier et restart apache. Sa me DL toujours le fichier au lieu de m'ouvrir l'interface :s

Les "Files regexp" c'est des fichiers par defaut. je ne les ai pas rajouter. Donc toujours bloquer! Mais pourquoi l'interface phpmyadmin fonctionne et pas l'autre interface ? Car si c'etait le php sa devrait me faire la me^me chose pour phpmyadmin non ? Est-ce la protection par le htaccess qui fait deconner le php ?

bbr18
03/11/2015, 16h40
Files regexp \.phps$
me semble bizarre, ce ne serait pas plutôt
Files regexp \.php$

arn0
03/11/2015, 15h02
Bonjour,

Je n'ai toujours pas trouvé mon problème suite aux infos données ci-dessus. j'ai beau modifier/chercher des paramètres en SSH ou via virtualmin mais je ne trouve pas pourquoi le php n'est pas interprété...

arn0
02/11/2015, 13h13
Citation Envoyé par bbr18
usr/share/mantis
virtualmin configure par défaut dans /home/ton_user/public_html/
tu as modifié la configuration à la main ?
Non je n'ai pas toucher à la configuration. Les sites que j'avais rajouté pour test sont bien dans /home (lors de la création du serveur virtuel via virtualmin)

Concernant mantis j'ai dl le paquet et dans virtualmin sa c'est mis tout seul dans "serveur par defaut" puis le chemin en question (dans Webmin=>serveur web apache)

Peut etre faut-il que je rajoute un serveur virtuel qui pointe vers usr/share/mantis ou modifié le fichier apache propre à mantis (dans etc/mantis) ??

Voici une capture d'ecran de ce que j'ai sur "Serveur par defaut" :



Code HTML:
Chemin d'accès    	Type   
Directory /usr/share/apache2/icons 	Répertoire
Directory /usr/share/doc/apache2-doc/manual/ 	Répertoire
Directory /usr/share/javascript/ 	Répertoire
Directory /usr/share/mantis/www 	Répertoire
Directory /usr/share/mantis/www/admin 	Répertoire
Files regexp ^\.ht 	Fichiers
Files regexp \.ph(p3?|tml)$ 	Regexp sur les fichiers
Files regexp \.phps$ 	Regexp sur les fichiers
Location /server-status 	Emplacement

bbr18
02/11/2015, 11h44
usr/share/mantis
virtualmin configure par défaut dans /home/ton_user/public_html/
tu as modifié la configuration à la main ?

arn0
02/11/2015, 08h22
Bonjour,

j'ai toujours mon problème de page php qui télécharge au lieu d’ouvrir l'interface!

mais ce qui me parait étrange, c'est que l'interface phpmyadmin fonctionne. et cette interface fait bien appelle à des pages php...(et en plus dans le même repertoire /urs/share que le logicel qui fonctionne pas)

Sur webmin, le repertoire du programme qui ne s'ouvre pas est dans "Serveur par defaut" usr/share/mantis et dans les chemins d'accès (autres que Directory") j'ai 3 trucs en plus liés à php :

Code HTML:
Files regexp ^\.ht
Files regexp \.ph(p3?|tml)$
Files regexp \.phps$

arn0
30/10/2015, 16h12
je viens de regarder dans /etc/mime.types et la ligen que tu dis n'est pas commenter :s

Dans les appli seul celle-ci est commenté = #application/vnd.ms-pki.stl stl

bbr18
30/10/2015, 16h01
regarde le fichier /etc/mime.types
la ligne est commentée par défaut par virtualmin, il faut la décommenter
Code:
application/x-httpd-php                 phtml pht php
puis relancer apache

arn0
30/10/2015, 15h54
Citation Envoyé par bbr18
sur Debian 8, il faut mettre tes lignes php avec : si tu ne mets que cela ne fonctionne pas, c'est peut-être pareil pour ubuntu dernière version ?
c'est un ubuntu 12.04.5 LTS. Et c'est un paquet depuis une source que j'ai installé au niveau du logiciel donc quand je tape Adresse_ip_serveur_web/mantis/admin/install.php je suis censé tombé sur l'interface de configuration mais a priori le php n'est pas interprété sur le serveur et je ne sais pas ou chercher d'autre ?

Est-ce lié à cela dans la conf apache du logiciel :

Code HTML:

		php_flag magic_quotes_gpc Off
		php_flag track_vars On
		php_value include_path .:/usr/share/php:/usr/share
	
Ou a un autre fichier de conf php a regarder ?

bbr18
30/10/2015, 15h45
sur Debian 8, il faut mettre tes lignes php avec : si tu ne mets que cela ne fonctionne pas, c'est peut-être pareil pour ubuntu dernière version ?

arn0
30/10/2015, 15h34
j'ai decommenter les 2 lignes et redemarré Apache et toujours pareil le fichier est téléchargé au lieu d'afficher son contenu :s

Est-ce parceque le repertoire est protégé par un htaccess ou une autre modif a faire dans le php ?

- - - Mise à jour - - -

Dans le apache.conf du logiciel en question (/ect/mantis/apache.conf)

j'ai sa :

Code HTML:
Alias /mantis /usr/share/mantis/www



	#
	# Disable these options (as needed) to improve PHP configuration
	#
	#php_admin_flag display_errors Off
	#php_admin_flag log_errors On
	#php_admin_flag html_errors Off
	#php_admin_flag allow_url_fopen Off
	#php_admin_flag safe_mode On
	#php_admin_value upload_tmp_dir "/tmp"
	#php_admin_value open_basedir "/usr/share/mantis/www/:/etc/mantis/:/usr/share/php/libphp-phpmailer/:/usr/share/php/adodb/:/tmp/"
	#php_admin_value disable_functions "exec,passthru,popen,proc_open,shell_exec,system,socket_create,fsockopen,pfsockopen"

	Options +FollowSymLinks
	AllowOverride None
	Order allow,deny
	Allow from all

	AddType application/x-httpd-php .php .phtml

	
		php_flag magic_quotes_gpc Off
		php_flag track_vars On
		php_value include_path .:/usr/share/php:/usr/share
	

	DirectoryIndex index.php



# The Administrative directory should not be publicly accessible,
# since the tools herein allow for access to the database without
# authentications.

        AuthType Basic
        AuthName "Restricted Admin mantis"
        AuthUserFile /etc/mantis/htaccess.dat
        Require valid-user

ktp
30/10/2015, 15h26
Il faudrait décommenter l'autre ligne aussi oui (l'expression régulière semble englober php, php3, phptml ?). N'oublies pas de recharger Apache.

arn0
30/10/2015, 15h23
Bonjour et merci de ton aide,

C'est le fichier par defaut je ne l'avais pas modifié. la je viens de dé commenter SetHandler application/x-httpd-php-source mais apparement c'est toujours pareil :s

Faut-il decommenter également cela : SetHandler application/x-httpd-php ?

Et il y a t il d'autres choses à vérifier ?

PS : il y a également un webmin/virtualmin d'installer sur ce serveur
PS2 : le repertoire est protégé par un simple htaccess.dat

ktp
30/10/2015, 15h09
Code:

#	SetHandler application/x-httpd-php-source
Pourquoi le '#' (commentaire) sur cette ligne si importante ?

arn0
30/10/2015, 14h59
Bonjour,

Après avoir fait une bonne MAJ des packets d'un serveur sous Ubuntu, j'ai installé un logiciel (mantis) et pour finir la configuration, il faut que j'ouvre l'interface dans un navigateur Adresse_ip_serveur_web/mantis/admin/install.php

mais le problème c'est que le php n'est pas interpreté par le serveur ! j'ai essayé pas mal de test mais toujours pareil sa me télécharge le fichier .php au lieu de me donner l'interface!

Avez-vous une idée ? Un fichier de conf à modifier ?

Voici mon fichier php5.conf

Code HTML:

    
#	SetHandler application/x-httpd-php
    
    
#	SetHandler application/x-httpd-php-source
    
    # To re-enable php in user directories comment the following lines
    # (from  to .) Do NOT set it to On as it
    # prevents .htaccess files from disabling it.
    
        
#            php_admin_value engine Off