OVH Community, votre nouvel espace communautaire.

Serveurs hosting 2016 et kernel original incompatbibles????


Kioob
28/10/2015, 07h47
Citation Envoyé par Nowwhat
Il y a des raisons pourquoi OVH livre ces kernel sans l'option 'module'.
L'expert-utilisateur qui est conscient des risques saura changer le noyau, et assumer ces conséquences.
Le débutant vivra sans option modules, donc plus de sécurité.
Les modules noyau sont signés depuis un moment maintenant, donc l'argument de sécurité me semble fortement obsolète.
Ça reste un choix historique et surtout pratique de la part d'OVH.

fredbriand
27/10/2015, 20h20
Bon alors en fait ca boot, mais y a pas de reseau.
apres avoir installe IPMI (doc ovh pas a jour) et avoir charger les bons modules, finalement ca ping.

fredbriand
27/10/2015, 18h10
Error - audit support not in kernel

super: pas de selinux, pas de auditd...

fredbriand
27/10/2015, 14h44
C'est justement pour la nouvelle gamme. Pas pour des serveurs qui tournent depuis des annees.
J'ai plusieurs serveurs hard, vps cloud, openstack qui tournent avec le kernel original. J'ai jamais eu de probleme remplacer celui d'OVH.

Nowwhat
27/10/2015, 14h29
Citation Envoyé par fredbriand
quelqu'on a reussi a installer l'original?
L'original ?
Lui www.kernel.org ?

Sinon, je ne connais pas 'Centos 7' (j'utilise moi même l'OS 'normal' : Debian 8.2 ) mais je présume que, dès que le serveur est livré, l'install de ton OS a déjà vieilli, donc le moindre 'mise à jour' va aussi assurer la mise en place d'un nouveau noyau (kernel).
Sinon, chez 'Centos', ils expliquerons surement comment il faut faire.

Il y a des raisons pourquoi OVH livre ces kernel sans l'option 'module'.
L'expert-utilisateur qui est conscient des risques saura changer le noyau, et assumer ces conséquences.
Le débutant vivra sans option modules, donc plus de sécurité.

Pense à choper le bon fichier de config chez OVH - (ici: http://guide.ovh.com/KernelInstall) puis utilise la source (kernel.org) et ton serveur sera à jour coté noyau. Je fait tourner mon 'Debian' depuis des années comme ça.

édit: kernel original incompatbibles???? - ton serveur marche pas ???? incompatible avec quoi ? Centos 7 d'OVH est incompatible avec ton serveur ?? Incompatible avec toi ?

fredbriand
27/10/2015, 14h09
Salut,

Alors j'ai pris 2 serveurs hosting 32L, et le premier a ete livre.
MAIS, on moment de l'installation, on ne peut pas choisir le kernel original de la distribution.... je veux une centos 7 et je ne peux pas utiliser leur kernel.... donc pas de selinux, pas de modules kernel...
J'ai force l'installation et modifier grub, mais le serveur boot plus...

perso je trouve pas ca tres pro et pas tres malin. D'autant que ca n'a pas l'air d'etre precise.

quelqu'on a reussi a installer l'original?

----
fred