OVH Community, votre nouvel espace communautaire.

version php 5.3 release 3 ... à quand une mise à jour ?


lxwfr
20/02/2016, 15h33
sert à rien de poster tous mois pour le R3, elles font peut-être des tâches bien plus importante qu'une interface R3

pkoipas
16/02/2016, 12h31
buddy, on est sur 5.3.3
bbr18, je ne vais pas déranger le big boss, du moins pour le moment ;-)

bbr18
16/02/2016, 08h06
et si tu veux absolument avoir une réponse : @olesovhcom sur twitter

buddy
16/02/2016, 07h16
il y a 2 ans, le support avait clairement répondu que c'était à l'utilisateur de se débrouiller

https://forum.ovh.com/archive/index.php/t-97895.html message du 21/05/2014, 11h57
En sachant que si tu la modifies toi même il y a de fortes chances pour qu'à la prochaine mise à jour plus rien ne marche ...

Au fait, tu as quelle version de php 5.3 actuellement sous la R3 ? la dernière étant la 5.3.29 Aout 2014 : http://php.net/ChangeLog-5.php#5.3.29

OVH release était bien à l'époque car c'était un tout en un, mais maintenant une débian ou centos +virtualmin (qui a une grosse communauté) marche clairement mieux ... et tu n'es pas dépendant d'OVH

Virtualmin supporte depuis le 5 janvier PHP 7 qui est sorti début décembre (soit 1 mois avant) ...
Je dis çà, je dis rien ..
Je vous conseille de migrer là dessus.

pkoipas
15/02/2016, 21h37
C'est dingue de ne pas avoir une réponse ! positive ou négative mais une réponse quoi... Si c'est abandonné qu'on nous le dise pour qu'on passe à autre chose !

buddy
15/02/2016, 20h54
çà fait déjà plusieurs mois qu'une version supérieure est attendue .... Si tu n'as pas de réponse précise sur la ML, il faut se faire à l'évidence .

Le mieux la prochaine fois sera de passer sur debian + virtualmin par exemple :
https://www.how-to.ovh/viewforum.php?f=2
https://www.virtualmin.com/

pkoipas
15/02/2016, 18h42
Oui pareil, j'ai eu aucune réponse sur le ML Release

Ce n'est pas normal, on nous dit qu'il faut passer de R2 (qui ne sera plus supportée) à R3 et après on reçoit des emails de OVH qui dit que php 5.3 est dangereux et qu'il faut passer à supérieur

Ce n'est vraiment pas normal ! J'ai trop de site pour migrer sur une autre distribution...

C'est quoi le problème au juste ? C'est trop dur ? Ce n'est pas possible ? ça va venir d'ici un mois ?

UNE REPONSE SVP

ZwaZo
15/02/2016, 18h07
Même sur la ML Release 3 OVH brille par son absence. zéro communication depuis plusieurs mois ! Alors sur le forum...

pkoipas
14/02/2016, 20h24
Une réponse serait trop demandée ou quoi ? La team d'OVH ne parcourt jamais les forums ?

pkoipas
10/01/2016, 21h35
Et toujours aucune communication de OVH sur l'avenir de la R3

ZwaZo
08/01/2016, 23h56
la R3 est une vaste fumisterie de la part d'OVH : Elle est passée de bêta à obsolète avec zero communication de la part d'OVH quant au suivi.

La raison en est simple : elle couvre un secteur de marché qui ne les intéressent juste pas.

pkoipas
07/12/2015, 17h28
Citation Envoyé par bbr18
pose la question sur la ML dédiée aux Releases
Pareil qu'ici, aucune réponse de la team

pkoipas
03/12/2015, 13h24
Et ce dossier crée en octobre et toujours vide ????
ftp://ftp.ovh.net/made-in-ovh/release3/

janus57
03/12/2015, 12h44
Bonjour,

ouais enfin on peu peut être mettre du PHP7 sur la R3 mais c'est pas pour autant que y a beaucoup de patch R3 :
update_3.35-3.36.tgz
9616 KB 29/07/2015 12:31:00
Cf : ftp://ftp.ovh.net/made-in-ovh/release/update_3.35-3.36/

Et aussi est-ce que effectivement cela casse les prochain patch ?

Cordialement, janus57

pkoipas
03/12/2015, 12h03
Citation Envoyé par bbr18
quand la R3 est passée en prod, la version de php était DEJA obsolète
ça fait combien d'heures que tu passes à chercher comment avoir des versions récentes ? Pose-toi la question : ne gagnerai-je pas beaucoup de temps à migrer vers une distribution/panel qui soit simple d'emploi et surtout qui utilise les versions récentes de tous les paquets ? Par exemple pour installer/configurer Debian/Virtualmin il faut disons 1h, puis migrer tes domaines sera plus ou moins long mais moins que de passer de R2 à R3 car l'arborescence des sites est semblable et après tu seras tranquille.
Oui je sais, tu as raison... moi ce qui me soûle c'est de recommencer à nouveau car j'ai deux serveurs dédiés où j'ai beaucoup beaucoup de domaines, donc s'il mettent pas à jour, je trouverais bien un moyen de le mettre à jour et de sortir de la release

Raptor, tu as mis à jour comment ? et lors d'une mise à jour tu sors de la release, non ?

Raptor00
03/12/2015, 10h17
Perso j'ai pris un vps pour faire des test, et j'ai installé php7 sans problème

https://vps222872.ovh.net/1.php


CentOS release 6.7 (Final)
Linux vps222872.ovh.net 2.6.32-573.8.1.el6.x86_64 #1 SMP Tue Nov 10 18:01:38 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

server : vps
release : 3.36
hostname : vps222872.ovh.net
eth0 IPv4 : 51.255.33.219

[root@vps222872 ~]# php -v
PHP 7.0.0RC7 (cli) (built: Nov 13 2015 23:46:17) ( NTS )
Copyright (c) 1997-2015 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2015 Zend Technologies
with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies

bbr18
03/12/2015, 09h02
quand la R3 est passée en prod, la version de php était DEJA obsolète
ça fait combien d'heures que tu passes à chercher comment avoir des versions récentes ? Pose-toi la question : ne gagnerai-je pas beaucoup de temps à migrer vers une distribution/panel qui soit simple d'emploi et surtout qui utilise les versions récentes de tous les paquets ? Par exemple pour installer/configurer Debian/Virtualmin il faut disons 1h, puis migrer tes domaines sera plus ou moins long mais moins que de passer de R2 à R3 car l'arborescence des sites est semblable et après tu seras tranquille.

pkoipas
03/12/2015, 08h46
Merci pour ces explications, si la release 3 n'est plus maintenue, que quelqu'un de OVH nous le dise, dans le cas contraire, merci de le maintenir à jour...
J'étais sur une R2 et OVH m'a dit que ce n'était pas maintenu et qu'il fallait que je migre sur la R3 et là ça fait même pas un an que j'ai migré que je dois laisser la R3 !
Ah si j'avais su !!!!

Ma question est toute simple, la R3 est à l'abandon ou pas ?

janus57
03/12/2015, 06h35
Citation Envoyé par pkoipas
Ah merci bbr18 ;-)

Sinon, suis-je le seul à être sur la R3 ou quoi ? ça dérange personne d'avoir un php obsolète avec des failles de sécurité ?
Bonjour,

en générale les personne passe vite leur chemin pour migrer sur autre chose, c'est pareil sur le forum KS.

La R3 est a éviter pour 2 raisons :
1 - Les composants interne ne sont pas maintenu suffisamment à jour (même Debian Wheezy fait mieux).
2 - si vous voulez de l'aide y a 95% de chance de l'avoir mais uniquement sur la ML de la R3, google ne vous aidera que dans 5-10% des cas, alors que Debian ou autre ce sera l'inverse 95% de réponse google et 5% ou il faut demander de l'aide.

Enfin la R3 est juste un webmin avec un module OVH (OVHm), donc passer sur du virtualmin (en gros webmin + usermin mais pas que) c'est presque pareil qu'une R3, le PHP et d'autre choses à jour, le fait que l'on peu installer pratiquement ce qu'on veux sans tout casser et surtout le support qui va avec la distribution en dessous (Debian/CentOS/Ubutnu etc…).

Cordialement, janus57

pkoipas
02/12/2015, 21h11
Ah merci bbr18 ;-)

Sinon, suis-je le seul à être sur la R3 ou quoi ? ça dérange personne d'avoir un php obsolète avec des failles de sécurité ?

bbr18
02/12/2015, 20h34
mais si : release-subscribe@ml.ovh.net

pkoipas
02/12/2015, 20h13
Mais il n'y a pas de mailing dédié aux releases

bbr18
02/12/2015, 18h51
pose la question sur la ML dédiée aux Releases

pkoipas
02/12/2015, 18h25
UP !
Personne de la Team OVH pour répondre ?
Merci

pkoipas
01/12/2015, 19h01
Oui c'est à jour mais à quoi bon si c'est pour avoir une version obsolète de php, comme le dit OVH dans un mailing à l'attention des clients sous mutualisé

Toujours personne de OVH pour répondre aux nombreux topics ouvert sur ce sujet ????????????

janus57
01/12/2015, 17h41
Bonjour,

le jour où la R3 arrivera au même stade que la R2 il sera sans doute trop tard.

D4ailleurs est-ce que votre R3 est à jour ? =)

Cordialement, janus57

pkoipas
01/12/2015, 08h57
Oui mais j'ai pas envie de migrer à nouveau comme j'ai pas pu le faire de R2 à R3 !
Ah si j'avais su que cette R3 allait être abandonnée.. Arf

Personne de OVH pour nous dire s'il va avoir une mise à jour ou pas ???????????????????????????
Merci d'avance

janus57
30/11/2015, 22h02
Bonjour,

à l'heure actuelle le plus simple reste la migration sur une solution de type Debian + Virtualmin ce qui donne accès à PHP5.6 + MariaDB ou MySQL, le tout avec le support de la communauté Virtualmin en cas de problème (donc google est très bavard).

Cordialement, janus57

pkoipas
30/11/2015, 20h48
A quand une version récente de php sur R3 ?????????
Merci

garavan
29/09/2015, 19h55
Bonjour,

j'ai suivi plusieurs tuto pour mettre à jour la version de php sur une release 3, pris contact avec la mailing list . Chacun y va de sa solution mais force est de constater qu'aucune d'entres elles ne s'avère parfaitement fonctionnelle on finit toujours soit pas casser la release, soit par perdre une config d'un élément composant la release.

J'ai bien conscience qu'on prend une release 3 pour justement ne pas avoir à mettre les mains dedans , mais quand même proposer sur une distrib trés grand public, avec une version de php qui est dépréciée depuis plusieurs mois c'est un peu limite .

d'où ma question à quand une mise à jour de la release 3 vers php 5.5 ou php 5.6 ? ou une solution venant d'un sage qui ne casserait pas tout ..

Ceci mis à part cette release est trés décriée sur le forum mais il faut savoir que mis à part ce point noir je la trouve tout à fait convenable , c'est pas du debian mais ...elle fait le job , est stable et sécurisée. c'est que du bonheur. bravo au techos qui l'ont pondu.