OVH Community, votre nouvel espace communautaire.

migration php 5.4 et probleme mysql_fetch_array


Gaston_Phone
27/09/2015, 16h48
Avec PHP Version 5.5.22 et MuSQL 5, c'est OK chez moi.

- - - Mise à jour - - -

Citation Envoyé par oliv_zd
J'ai trouve la réponse à mon problème ;-)
Et alors ... c'était ... ? ? ?

oliv_zd
27/09/2015, 16h46
J'ai trouve la réponse à mon problème ;-)



Citation Envoyé par oliv_zd
Bonjour,

Je m'occupe d'un site qui est encore en php 4.4 et je teste la migration vers 5.4.

Je rencontre un problème que je ne comprends pas.

Dans une partie du code il y a un appel à mysql_fetch_array, en 4.X ça fonctionne parfaitement et en 5.4 il me renvoi FALSE.

J'ai vérifier la config de php 5.4 est la même que pour la v4.4. Le connect et la query se font correctement.

JE coince, des idées ?

Merci d'avance ;-)
Olivier

oliv_zd
27/09/2015, 16h04
Bonjour,

Je m'occupe d'un site qui est encore en php 4.4 et je teste la migration vers 5.4.

Je rencontre un problème que je ne comprends pas.

Dans une partie du code il y a un appel à mysql_fetch_array, en 4.X ça fonctionne parfaitement et en 5.4 il me renvoi FALSE.

J'ai vérifier la config de php 5.4 est la même que pour la v4.4. Le connect et la query se font correctement.

JE coince, des idées ?

Merci d'avance ;-)
Olivier