OVH Community, votre nouvel espace communautaire.

Serveur dédié, ip failover, openvz, comment faire fonctionner mon serveur virtuel?


semor
29/09/2015, 17h39
c'est bon en fait j'ai trouvé!
j'ai fait un
apt-get install language-pack-fr language-pack-fr-base manpages
puis j'ai modifié le fichier /etc/default/locale avec les infos suivantes:
LANG="fr_FR.UTF-8"
LANGUAGE="fr_FR"
comme ça j'en ai profité pour passer ubuntu en français ^^

semor
29/09/2015, 16h25
je rencontre un petit soucis avec une CT sur laquelle j'ai installé un ubuntu. Je n'arrive pas à configurer le serveur en UTF-8. j'ai essayé dpkg-reconfigure locales mais ça ne me sort aucune liste. Sans cela je ne peux pas installer airtime dessus.
Si quelqu'un a une idée je suis preneur.

semor
28/09/2015, 15h46
C'est bon j'ai trouvé la solution, en fait il fallait que je confirgure le reverse de mon @ IPFO comme "Adresse-IP-Fail-Over.ovh.net" et donc d'utiliser ensuite ces infos comme serveur DNS principal de mon domaine et dans ispconfig !

semor
28/09/2015, 12h31
je viens de transferer mon premier site sur un CT construit sur une debian 8 sur laquelle j'ai installé un ispconfig
après quelques modif de fichier de config pour les lien avec bd ça fonctionne en pointant manuellement l'url vers l'@ ip du serveur virtuel
par contre je ne suis pas sur de la nouvelle configuration pour mes dns j'aurais besoin d'un peu d'aide à ce sujet
pour mon nom de domaine mon serveur dns est ns301xxxx.ovh.net ou le nom du serveur virtuel soit serveurb.ip-xxx-xxx-xxx.eu ?
ns301xxxx.ovh.net pointe vers l'adresse ip du serveur dédié, ce qui est normal, par contre serveurb.ip-xxx-xxx-xxx.eu pointe sur une adresse qui ne correspond à aucune adresse de mon serveur.

semor
26/09/2015, 15h03
Je rencontre un petit problème avec un CT sous ubuntu, je n'arrive pas à changer la langue de l'os en UTF-8 ce qui me pose problème pour installer airtime qui plante, j'ai essayé la commande dkpg-reconfigure locales mais j'ai rien qui s'affiche, pas de retour de message d'erreurs mais simplement quedal.
Du coup je suis coincé je ne peux pas installer ma radio airtime. J'ai essayé avec 2 versions d'ubuntu et j'ai le même problème sur les deux distrib.
Une petite idée comment faire?

semor
26/09/2015, 09h59
merci mais j'ai trouvé mon bonheur à priori avec la commande scp

bbr18
26/09/2015, 09h06
rsync ?

semor
26/09/2015, 08h38
C'est bon en fait j'ai supprimé l'@ mac virtuelle et ça fonctionne! en fait j'avais lu sur un tuto qu'il fallait créer une adresse mac virtuelle pour pouvoir faire fonctionner une CT avec openvz, comme proxmox fonctionnait avec openvz je pensais que c'était le même tarif, du coup c'est bon j'ai réussi à créer 2 CT avec mes 2 IPFO

Bon maintenant il faut que je rapatrie tout de mes deux autres serveurs...
Si vous avez une solution rapide pour le transfert de données entre les différents serveurs je suis preneur!

bbr18
26/09/2015, 07h50
J'ai recommencé avec la même adresse IPFO ça ne fonctionne toujours pas, du coup j'ai essayé avec une nouvelle IPFO et là la magie opère tout fonctionne.
Contacte le support pour ton IP qui ne ping pas

bbr18
25/09/2015, 19h20
tu peux regarder ce que tu utilisais sur l'ancien serveur, puis tu peux affiner selon les résultats, c'est facile avec Proxmox puisque tu peux le faire à chaud, si tu vois que la mémoire allouée est juste, tu en rajoutes, dans le tuto j'ai expliqué un peu les calculs

semor
25/09/2015, 14h26
Citation Envoyé par bbr18
détruis le ct, puis recrée-le, en suivant le tuto sans rien faire d'autre histoire de repartir à zéro
(tu n'as pas modifié la config de l'hôte à la main ? )
J'ai recommencé avec la même adresse IPFO ça ne fonctionne toujours pas, du coup j'ai essayé avec une nouvelle IPFO et là la magie opère tout fonctionne.

Maintenant j'aurais besoin de quelques conseils:

Voici les détails de mon serveur dédié:

CPU: Intel(R) Xeon(R) CPU E5-1630 v3 @ 3.70GHz
Coeurs : 8
Cache : 10240KB
RAM: 4x 16384Mo
Disques: 2 x 2000 Go
Carte Mère: X10SRi-F

Je souhaiterai savoir comment équilibrer tout ça. J'ai besoin de deux serveurs virtuels avec un airtime dessus, un serveur virtuel avec une petite dizaine de sites marchands, un autre éventuellement pour y mettre une autre dizaines de sites vitrines avec blog, forums... le but ayant d'avoir un serveur en secours si l'un merde côté soft pour pouvoir héberger et transférer rapidement les sites d'un serveur à l'autre. J'ai également besoin d'installer un serveur teamspeak, mais de souvenir cela s'installe très bien sur une debian.
Je pensais donc installer 2 ubuntu 12.04 pour mes radios, et 2 debian pour mes sites.
Comment répartir les charges du serveur? à savoir que je pense attribuer 250Go par radio comme il y a bcp de fichiers. Pour les sites aujourd'hui j'utilise 111Go sur mon serveur actuel, donc avec un serveur de 300 Go ça suffit largement.
Par contre au niveau puissance, mémoire attribuée, nombre de CPU, cpu units... etc... vous en pensez quoi?

semor
24/09/2015, 17h51
Citation Envoyé par bbr18
détruis le ct, puis recrée-le, en suivant le tuto sans rien faire d'autre histoire de repartir à zéro
(tu n'as pas modifié la config de l'hôte à la main ? )
je réessaierai ce soir, sinon non je n'ai rien modifié en installant la distrib proxmox.

bbr18
24/09/2015, 17h45
détruis le ct, puis recrée-le, en suivant le tuto sans rien faire d'autre histoire de repartir à zéro
(tu n'as pas modifié la config de l'hôte à la main ? )

semor
24/09/2015, 17h35
non ce n'est pas l'adresse du serveur dédié

Rizz
24/09/2015, 17h32
si 37.187.231.86 est ton serveur c'est que tu as probablement mal crée ton CT ou oublié de modifier vz.conf

semor
24/09/2015, 17h05
Effectivement le ping ne fonctionne pas.

Code:
C:\Users\***>tracert 51.***.***.***

Détermination de l'itinéraire vers ip255.ip-51-***-***.eu [51.***.***.***]
avec un maximum de 30 sauts*:

  1    <1 ms    <1 ms    <1 ms  FREEBOX [192.168.0.254]
  2    54 ms    50 ms    41 ms  82.228.170.254
  3   103 ms   119 ms   112 ms  reims-6k-1-a5.routers.proxad.net [213.228.13.254]
  4    57 ms    85 ms   149 ms  conde-6k-1-po3.intf.routers.proxad.net [212.27.50.166]
  5    95 ms    99 ms   107 ms  th2-crs16-1-be1103.intf.routers.proxad.net [212.27.50.121]
  6   119 ms   107 ms    86 ms  p11-crs16-1-be1004.intf.routers.proxad.net [78.254.249.129]
  7    45 ms    38 ms    52 ms  cbv-crs8-1.intf.routers.proxad.net [78.254.249.102]
  8    42 ms    52 ms    47 ms  gsw-1-a9.fr.eu [213.186.32.169]
  9    48 ms    75 ms    58 ms  gra-g1-a9.fr.eu [94.23.122.84]
 10    61 ms    78 ms    40 ms  gra-3a-a9.fr.eu [37.187.231.86]
 11     *        *        *     Délai d'attente de la demande dépassé.
 12     *        *        *     Délai d'attente de la demande dépassé.
 13     *        *        *     Délai d'attente de la demande dépassé.
 14     *        *        *     Délai d'attente de la demande dépassé.
 15     *        *        *     Délai d'attente de la demande dépassé.
 16     *        *        *     Délai d'attente de la demande dépassé.
 17     *        *        *     Délai d'attente de la demande dépassé.
 18     *        *        *     Délai d'attente de la demande dépassé.
Je dois louper un truc au passage... je viens de recommander une seconde ip, même résultat,

Rizz
24/09/2015, 17h02
Tu dois etre capable de savoir si ca ping ou pas. De la tu peux faire un trace route sans doute . Et de la tu peux revoir toute la partie firewall peut etre si tu estimes que l'ip ne pose pas pb coté ovh.

Perso j'ai suivie ce tuto ( merci bbr ) pour un SYS et .. pas eu de soucis.

semor
24/09/2015, 16h58
Citation Envoyé par bbr18
tu peux entrer en ssh simplement en mettant l'ip du CT et root/pass (ou clé selon ta config)
cela ne fonctionne pas

bbr18
24/09/2015, 16h22
tu peux entrer en ssh simplement en mettant l'ip du CT et root/pass (ou clé selon ta config)
pas besopin de tripatouiller les mac, tu renseignes juste l'IP que tu attribues au CT au moment de la création et tout le reste se fait seul
Depuis le ssh de l'hote (donc ton dédié) tu devrais avoir accès à ton CT avec vzctl enter 100 si c'est bien ce numéro que tu lui a attribué lors de sa création ^^

semor
24/09/2015, 15h45
merci pour toutes ces infos, je viens de suivre ton tuto pour créer un CT a priori c'est bon pour l'installation par contre je n'ai pas d'accès à l'extérieur depuis ma CT.
Je me suis connecté en SSH dessus depuis ma session sur le serveur dédié avec la commande vzctl enter 100.
J'ai pourtant bien entré mon IPFO qui a bien une adresse mac virtuelle et qui est liée au bon serveur.
Une petite idée?

bbr18
24/09/2015, 12h15
Promox est très simple d'utilisation, regarde mes tutos, http://www.how-to.ovh/viewforum.php?f=3 cela devrait te permettre de démarrer rapidement
Tu prends 2 IP FO, sur une tu te sers du template Debian 8 et sur l'autre de celui de Ubuntu
Proxmox configure lui-même les IP
Tu remplaces le lien du wget du tuto par ceux qui t'intéressent (à faire avant de créer tes vm/containers)
Edit : sur un SP64, je ne vois pas l'utilité d'utiliser l'IP de l'hôte, se servir des IP FO est bien mieux.

semor
24/09/2015, 11h05
Ok je vais tester tout ça par contre je suis un peu perdu, il faut télécharger des gabarits je suppose?

mantex
24/09/2015, 08h46
Citation Envoyé par janus57
Bonjour,

non proxmox est gratuit mais il est possible de payer pour avoir des "bonus" et/ou un support.


Cordialement, janus57

Tu as déjà testé le support ? , j' ai un CT d' un client qui ne redémarre plus, il y a rien dans les logs. Difficile de trouver une piste de départ...

janus57
23/09/2015, 17h18
Bonjour,

non proxmox est gratuit mais il est possible de payer pour avoir des "bonus" et/ou un support.

De plus une IP pour la VM suffit, proxmox peu utiliser l'ip du serveur.

Je conseil de faire une VM en KVM/Qemu qui virtualise le noyau, OpenVZ étant pas top.

Cordialement, janus57

semor
23/09/2015, 16h38
You do not have a valid subscription for this server. Please visit www.proxmox.com to get a list of available options.

Si je comprends bien il faut prendre un abonnement supplémentaire pour pouvoir utiliser promox ?

semor
23/09/2015, 16h14
du coup je vais installer une promox 3.4 pour voir comment ça se gère.
par contre du coup il me faut 2 ip fail-over?
une pour un serveur virtuel debian 8 + ispconfig et une autre autre pour mon serveur virtuel sous ubuntu?

semor
23/09/2015, 16h07
Citation Envoyé par hogsim
Bonjour,
pourquoi n’êtes vous pas plutôt partit sur une installation de proxmox qui est basé sur debian mais ou tout est déja configuré pour y faire de la virtualisation?

https://fr.wikipedia.org/wiki/Proxmox_VE
Tout simplement parce que je ne connais pas
Après je suis assez attaché à ispconfig et je veux être sûr de pouvoir le mettre en place sans accros. j'ai vu aussi en regardant qu'il y avait la distrib Vmware 6, est-ce mieux que proxmox? ou non?

hogsim
23/09/2015, 15h38
Bonjour,
pourquoi n’êtes vous pas plutôt partit sur une installation de proxmox qui est basé sur debian mais ou tout est déja configuré pour y faire de la virtualisation?

https://fr.wikipedia.org/wiki/Proxmox_VE

semor
23/09/2015, 15h12
Bonjour,

Je suis en train de m'arracher les cheveux un à un

Aujourd’hui j'utilise 2 serveurs dédiés, un sur une distrib debian 6 avec ispconfig et un second sous ubuntu 12.04 pour faire tourner une radio en ligne airtime.
Je viens d'acquérir un nouveau serveur dédié (SP-64) pour tout centraliser et me mettre à jour.
J'ai tout d'abord installé une distrib debian 7 64bits avec ispconfig sur laquelle j'ai réussi à installer openvz en suivant un tuto sans trop de soucis, j'arrive à créer un serveur virtuel avec le web panel d'openvz installé également ou bien en ligne de commande, jusque là tout va bien.
Seulement je n'arrive pas accéder depuis l'extérieur à ma machine virtuelle. depuis la machine en ssh avec la commande
Code:
vzctl enter 101
je n'arrive pas à me connecter à l'extérieur, pas d'update possible, bref la liaison ne se fait pas.
J'ai bien sûr commandé une ip failover sur laquelle j'ai une @ mac virtuelle. en ssh j'ai également modifié le fichier /etc/network/interfaces en utilisant le guide ovh (http://guide.ovh.com/BridgeClient) mais rien y fait ça ne veut pas.

Alors soit ispconfig m'empêche de faire fonctionner mon serveur virtuel soit je m'y prends comme un manche. ça fait 2 jours que je cherche sur les forums à droite à gauche sans vraiment trouver mon bonheur.
Auriez-vous une petite idée d'où peut venir mon problème?
Faut-il que je m'oriente sur une autre distrib? j'avoue que je me perds un peu et qu'un peu d'aide me ferait le plus grand bien