OVH Community, votre nouvel espace communautaire.

.. votre système n'est pas prêt à utiliser Virtualmin


seb2047
20/09/2015, 20h39
Yes grand merci Janus

ça a bien marché, j'ai juste eu un second soucis me disant que mailman n'était pas démarrer... une fois démarré j'ai enfin pu avoir le message
.. votre système est prêt à utiliser Virtualmin.
encore merci

janus57
20/09/2015, 19h46
Bonjour,

ok donc c'est juste le message qui vous fait peur.

Donc voici la solution qui normalement devrait fonctionner :
modifier /etc/resolv.conf comme ceci
Code:
domain local
search local
nameserver 127.0.0.1
nameserver 213.186.33.99
puis
Code:
apt-get install resolvconf
Cela devrait "figer" le fichier /etc/resolv.conf si jamais un programme essaye de le modifier, mais cela n'empêche pas de l’éditer (voir : man resolvconf).

Après suffit de dire à Virtualmin de revérifier la configuration et cela devrait passer sans problème.

Cordialement, janus57

seb2047
20/09/2015, 19h18
Lors de la post-intallation (à la première connexion à webmin) j'ai indiqué comme dans le tuto le nom de mon vps "vps******.ovh.net" et le dns secondaire "sdns2.ovh.net".

En fin de compte mon problème c'est juste ce message qui me dit que mon système n'est pas prêt à utiliser virtualmin. Si il dit qu'il est pas prêt moi ça m'inquiète lol




Quel infos puis-je donner ?
Comme dit au début c'est un VPS 2016 SSD 1 avec une installation Debian 8 nu ou j'ai ajouté virtualmin en suivant le tuto cité plus haut.

/etc/network/interfaces (pas touché car pas d'ip fail over)
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The normal eth0
auto eth0
iface eth0 inet dhcp

# Maybe the VM has 2 NICs?
allow-hotplug eth1
iface eth1 inet dhcp

# Maybe the VM has 3 NICs?
allow-hotplug eth2
iface eth2 inet dhcp

/etc/resolv.conf (je ne l'ai pas modifié non plus)
Code:
domain local
search local
nameserver 213.186.33.99

janus57
20/09/2015, 18h17
Bonjour,

vous devez remplir comme dans le tuto, donc d'abord le nom du VPS puis l'ip du DNS secondaire (qui n'est pas 213.186.33.99 d'ailleurs).

Après je vois pas votre problème pour le coup.

D'après le message dans le post #1 vous avez config virtualmin pour ne pas l'utiliser en tant que serveur DNS (ce qui est tout à fait possible).

J'ai pas de VPS sous la main donc je peu pas faire de test et vous ne donnez pas d'infos pour vérifier, donc dans l'absolu vu que vous avez accès à virtualmin votre installation est bien passé et là il vous dit juste que pour une raison X vous ne pouvez pas utiliser le VPS comme serveur maitre (ce qui est pas grave vu qu'on peu s'en passer).

Cordialement, janus57

seb2047
20/09/2015, 18h07
Le 127.0.0.1 ne s'enregistre pas donc pas besoin de remplacé ^^



Petite erreur de ma part en faite l'ip affiché correspond au dns secondaire (sdns2.ovh.net)
j'ai essayé de mettre l'ip de mon vps à la place, puis de la mettre en premier et le dns secondaire en dessous, c'est toujours pareil aucunes modifications n'est prise en compte.

janus57
20/09/2015, 17h38
Bonjour,

déjà avez-vous remplacé le 127.0.0.1 dans les DNS ?

Possible d'avoir votre config au complet (screen ou message) ?

Cordialement, janus57

seb2047
20/09/2015, 16h25
Oui pas de soucis j'ai bien utilisé le script officiel pour installé virtualmin.
est-ce qu'il faut que je tente l'autre option proposé : désactivé Domaine DNS BIND des modules ?

janus57
20/09/2015, 15h08
Bonjour,

vous avez installé virtualmin comment très exactement ?

Perso je vous conseil d'utiliser seulement et uniquement le script officiel (software.virtualmin.com/gpl/scripts/install.sh).

EDIT :
et non dans le DNS faut pas mettre "127.0.0.1" c'est soit l'IP du VPS soit son nom, mais surtout pas 127.0.0.1

Cordialement, janus57

seb2047
20/09/2015, 15h01
Bonjour,

J'ai récemment pris un VPS 2016 SSD avec Debian 8 et installer Virtualmin (en suivant ce tuto: http://www.how-to.ovh/viewtopic.php?f=2&t=12 )
Mon problème est que j'ai un message d'erreur Virtualmin qui me dit qu'il n'est pas prêt :

Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add 127.0.0.1 to the list of DNS servers, or turn off the BIND feature on the module config page. It appears that DHCP is being used to dynamically configure your network interfaces, which can cause the DNS servers to be set based on settings provided by the DHCP server. Using a static IP address is strongly recommended with Virtualmin.

.. votre système n'est pas prêt à utiliser Virualmin.
"list of DNS servers" et "module config" sont également des liens. Dans le premier comme DNS je n'ai que l'IP du VPS donc je rajoute 127.0.0.1 clique sur "sauvegarder" puis "appliquer la configuration" tout semble marché mais si j'y retourne je me rend compte qu'il n'a rien enregistré j'ai tenter je ne mettre que 127.0.0.1 mais c'est la même chose il ne sauvegarde pas !

Si quelqu'un pouvait me dire qu'est ce que je peu faire pour ne plus avoir ce message d'erreur ce serais sympa à vous