OVH Community, votre nouvel espace communautaire.

ovh release 3 avec php >5.3


buddy
20/09/2016, 12h18
Il vaut mieux réinstaller et partir sur quelque chose de plus récent.
Centos 7 ou debian 8 avec virtualmin si tu veux un panel similaire.

Derek
20/09/2016, 11h09
Concrètement, quand on a des services qui tournent sur une R3 et qu'on a besoin d'un paquet qui ne date pas de la préhistoire on fait comment ? Réinstallation obligatoire vers une autre distribution ? Ou est-ce qu'on peut transformer sa R3 en CentOS ?
Un peu d'accompagnement d'OVH pour ceux qui se retrouvent bloqués ne serait pas du luxe.

AlexR
23/05/2016, 12h53
Bonjour,

La release 3 sera dépréciée et ne sera pas mise-à-jour. (Excepté pour les failles de sécurité).

Si vous avez besoin de paquets récents alors la release n'est pas l'OS adapté à vos besoins.

Il convient uniquement pour une minorité de clients qui ne nécessitent pas de migrer vers les dernières version des différents paquets.

Pour le moment la release 3 est toujours maintenu et elle restera donc la liste des OS disponibles.

Comme indiqué plus haut, je vous conseille l'utilisation d'un panel open-source comme Virtualmin ou bien ISPConfig pour gérer vos différents services sur une Debian fraîche par exemple.

Sinon, côté propriétaire vous avez par exemple Plesk qui convient également pour nombre de nos clients.

L’inconvénient c'est qu'avec un tel système vous êtes tributaire de l'ensemble du Panel...

Cordialement, Alexandre R.
Technicien Support IT Cloud

salouma
18/05/2016, 16h38
Citation Envoyé par janus57
Bonjour,

avec debian je connais 2 panels :
- Virtualmin
- ISPConfig

Pour virtualmin tu as le site (https://www.how-to.ovh/) de @BBR avec pas mal de tuto et cela ressemble un peu à une R3.

Perso je suis pas fan des panel propriétaire car parfois c'est très dur d'y intervenir en ligne de commande (car on veux faire quelque chose de non prévu par le panel mais qui nous intéresse) sans tout "casser".

Cordialement, janus57
Super merci.

Si un admin d'OVH passe par la ca serait bien de nous dire ce que va devenir la release 3 ou de la virer des distribution si elle est abandonée !

janus57
13/05/2016, 23h41
Bonjour,

avec debian je connais 2 panels :
- Virtualmin
- ISPConfig

Pour virtualmin tu as le site (https://www.how-to.ovh/) de @BBR avec pas mal de tuto et cela ressemble un peu à une R3.

Perso je suis pas fan des panel propriétaire car parfois c'est très dur d'y intervenir en ligne de commande (car on veux faire quelque chose de non prévu par le panel mais qui nous intéresse) sans tout "casser".

Cordialement, janus57

salouma
13/05/2016, 08h49
Ok merci de ta réponse,

Dernière question,

Idéalement je serai intéréssé par un distribution bien maintenue, gratuite et si possible sur Debian. Ca serait plutot virtualmin plutot ?
Ou plutot Plesk 12 ubuntu ? (gratuit pour mon VPS cloud)

Merci !

janus57
13/05/2016, 08h42
Bonjour,

C'est possible sans reinstaller tout le serveur (uploader tous les fichiers, les bases de données, refaire les connexions site/bdd) ?
non

Il y a un tutoriel pour passer OVH V3 vers cpanel ?
non plus et après le support sera côté cPanel (vu que c'est un panel propriétaire le meilleur support sera chez eux), sans oublier le fait que les licence sont payante (mais du coup y a normalement le support qui va avec mais pas pour tout et n'importe quoi normalement).

Cordialement, janus57

salouma
13/05/2016, 08h39
Citation Envoyé par janus57
Bonjour,


simple suffit de passer sur une autre solution qui est maintenu depuis longtemps et le sera encore longtemps (virtualmin/ispconfig/plesk/cpanel etc…).

Cordialement, janus57
C'est possible sans reinstaller tout le serveur (uploader tous les fichiers, les bases de données, refaire les connexions site/bdd) ?

Il y a un tutoriel pour passer OVH V3 vers cpanel ?

merci

janus57
10/05/2016, 18h15
Bonjour,

Je ne compte pas passer ma vie a reinstaller mon serveur car OVH ne veut plus maintenir ses produits.
simple suffit de passer sur une autre solution qui est maintenu depuis longtemps et le sera encore longtemps (virtualmin/ispconfig/plesk/cpanel etc…).

Cordialement, janus57

salouma
10/05/2016, 10h53
On dirait en effet,

Mais la OVH se fiche de nous, j'ai passé toute ma journée d'hier a changer de serveur et j'ai tout installé sur OVH release 3.

A aucun moment j'ai eu de message me disant que la distribution n'était plus mise à jour.

Je ne compte pas passer ma vie a reinstaller mon serveur car OVH ne veut plus maintenir ses produits.



Citation Envoyé par fritz2cat
OUVREZ LES YEUX !

La release 3 est un produit à l'abandon.
OVH devrait ne plus la proposer et annoncer à tous ses clients qui ont installé la R3 qu'il sont en danger.

fritz2cat
10/05/2016, 10h19
OUVREZ LES YEUX !

La release 3 est un produit à l'abandon.
OVH devrait ne plus la proposer et annoncer à tous ses clients qui ont installé la R3 qu'il sont en danger.

salouma
10/05/2016, 09h48
UP !!!!

PHP n'est toujours pas à jour sur OVH release 3, je trouve vraiment ca pas serieux de ne pas mettre à jour un composant aussi essentiel sur une distribution serveur.
Voici la réponse que j'ai recu du service :

Bonjour,

Nous n'avons pas de délai sur la mise à jour de la version de PHP sur la release3.

S vous souhaitez une version plus à jour de PHP, vous pouvez soit partir sur une distribution nue et installer les paquets dans les versions de votre choix, ou alors, si vous préférez un panel d'administration, les distribution Plesk et cPanel, proposent des versions à jour.

Je reste à votre disposition pour toute demande complémentaire.


Ce post est ouvert depuis septembre 2015, plus de 9 mois...

Une reaction d'OVH serait la bienvenu pour qu'on nous dise si OVH release 3 est juste à jeter à la poubelle ?!??

janus57
18/09/2015, 19h02
Citation Envoyé par Decko
Je n'ai plus besoin du VPS, donc de mon point de vue, ça ne change plus rien
cdlt
Bonjour,

VPS ou Dédié une R3 non à jour c'est mal, très mal et mauvaise exemple pour eux qui vont suivre votre méthode et être bloqué car il ne connaissent rien en administration système.

Cordialement, janus57

Decko
18/09/2015, 12h47
Je n'ai plus besoin du VPS, donc de mon point de vue, ça ne change plus rien
cdlt

janus57
17/09/2015, 19h45
Citation Envoyé par Decko
quand je clique mettre à jour ça me donne
Operation realisee avec succes
found OVH-Release 3
Your OVH-Release is up to date

pour les paquets, ça m'a mis les paquets php56w et autres à jour également
Bonjour,

visiblement votreR3 était déjà à jour donc non validé de mon point de vue, si à la prochaine tentative de MAJ R3 le patch OVH ne passe pas/plus ne cherchez pas c'est que vous avez modifié la R3 alors que vous n'auriez pas dû.

Cordialement, janus57

Decko
17/09/2015, 08h37
quand je clique mettre à jour ça me donne
Operation realisee avec succes
found OVH-Release 3
Your OVH-Release is up to date

pour les paquets, ça m'a mis les paquets php56w et autres à jour également

janus57
15/09/2015, 20h33
Citation Envoyé par Decko
Pour information, j'ai pu faire une mis à jour sans casser la release ovh, semble-t-il en faisant un yum replace : https://webtatic.com/packages/php56/
Bonjour,

vérifier par le fait que vous arrivez encore à faire les MAJs ?

Cordialement, janus57

Decko
15/09/2015, 10h01
Pour information, j'ai pu faire une mis à jour sans casser la release ovh, semble-t-il en faisant un yum replace : https://webtatic.com/packages/php56/

libris86
04/09/2015, 15h32
Citation Envoyé par Decko
Bonjour,

est-il possible de faire une mis à jour de php vers 5.4 ou supérieur sans tout ou trop cassé la ovh release 3 ?

j'ai des scripts qui refuse de tourner sous 5.3, qui commence à devenir obsolète...
merci d'avance.
Malheureusement, la réponse est NON. Cela casse "sauvagement la Release 3"... Tu peux faire une mise a jour de PHP vers 5.4, 5.5 ou 5.6, mais tu perd toute compatibilité Release 3. Ce serait souhaitable que OVH se penche SÉRIEUSEMENT sur une MAJ de la Release 3 devenu vraiment obsolète !

Decko
04/09/2015, 03h38
Bonjour,

est-il possible de faire une mis à jour de php vers 5.4 ou supérieur sans tout ou trop cassé la ovh release 3 ?

j'ai des scripts qui refuse de tourner sous 5.3, qui commence à devenir obsolète...
merci d'avance.