OVH Community, votre nouvel espace communautaire.

ouverture de ports ?


captainadmin
03/09/2015, 10h10
Hello

En ssh sur ta machine il faut que tu regardes sur quelle ip le port est ouvert
netstat -laputen | grep "port" ou pour ton cas
netstat -laputen | grep 10000

tu verras qui écoute sur ce port et l'ip associée sans doute juste le localhost actuellement

Si ca écoute sur l'ip publique, il faut voir les différents blocages ou si qui passe sur ton inerface
Pour savoir ya les logs webmin ou apache et sinon plus brute tu as le tcpdump
tcpdump -ni any port 10000
avec cette commande sur le serveur tu test un acces via ton navigateur et tu pourras voir si les flux fonctionne bien

Bon courage
http://www.captainadmin.com

drolilol
03/09/2015, 09h23
Complément d'info, je me suis monté un tunnel SSH et j'arrive à accéder à webmin depuis mon PC via ce tunnel mais bon, ça ne me permet pas pour autant de pouvoir mettre à disposition des services comme apache ou mysql sur l'interface wan...

Bref...à l'aide !

drolilol
03/09/2015, 08h50
Bonjour,

J'ai lancé une instance hier et je voulais utiliser webmin. L'install s'est bien passée (j'ai testé sur une debian 8 et une centos7). Si je fais un wget sur 127.0.0.1:10000, j'ai bien webmin.
En revanche, impossible d'accéder à webmin depuis le net via l'IP de l'instance.
Il n'y a que SSH sur le port 22 qui soit OK et fonctionnel depuis le net.

Pourtant, j'ai réinitialisé toutes les config iptables (le plus permissif possible, juste pour un POC), vérifié que firewalld soit coupé sur la centos (il était même pas installé)...bref, je comprends pas pourquoi je suis incapable d'émettre un service sur le net...J'ai essayé avec apache aussi => même problème, via mon navigateur, je timeout lorsque j'essaye d'accéder à l'IP.
Du coup, par désespoir, j'ai fait un tour sur horizon et j'ai modifié les règles du groupe de sécurité "default" (celui associé à mon instance) pour autoriser le trafic en entrée sur l'IPV4 tcp & udp sur le port 10000...mais non, toujours un timeout.

Qu'ai-je oublié de faire ? Il reste un vilain pare-feu sur les templates OVH qui bloque mon trafic ?

Merci pour votre aide