OVH Community, votre nouvel espace communautaire.

Problèmes de droits de répertoire pour les mails


durrm001
29/09/2006, 20h12
Bonsoir à tous,

J'ai résolu mon problème en retirant le droit d'exécution des fichiers .qmail-default

il fallait le trouver celui-là quand même ...

En tout cas, merci beaucoup à Tibre44 qui m'a bien dépanné

durrm001
29/09/2006, 11h47
Citation Envoyé par Tibre44
Si tous les droits fichiers et owner.group ont bien été respectés, je ne vois pas la raison. Essaye de voir si tu n'as pas plus d'information dans ton log.

Sur quel distrib es-tu ? Tout ce que je t'ai envoyé concerne une gentoo 2006.
Je suis avec un serveur Pentium dual ++, avec une Redhat 7.2.

Tibre44
29/09/2006, 11h17
Si tous les droits fichiers et owner.group ont bien été respectés, je ne vois pas la raison. Essaye de voir si tu n'as pas plus d'information dans ton log.

Sur quel distrib es-tu ? Tout ce que je t'ai envoyé concerne une gentoo 2006.

durrm001
29/09/2006, 11h10
Tibre44, j'ai appliqué les droits sur tous les répertoires et fichiers, comme ce que tu m'as envoyé par mail.

Maintenant, quand je lance Thunderbird, j'ai un message d'erreur que je n'avais pas avant : "Echec de l'envoi du mot de passe. Le serveur de courrier pop3.XXXXXX.com a répondu : authorization failed" (j'ai remplacé le nom de domaine par XX)

Qu'est-ce que je fais maintenant ?

durrm001
29/09/2006, 10h08
Citation Envoyé par Tibre44
Ils doivent être en 755 et ne pas oublier de redonner aussi les bons propriétaires dans les sous-dossiers.
Merci beaucoup. Ca remarche pour l'accès à sqwebmail et à qmailadmin.

Cependant, je ne reçois toujours aucun mail. J'ai refais des tests, et rien dans la boîte de réception...
Il doit y avoir autre chose qui cloche (snif !)

Tibre44
29/09/2006, 10h01
Ils doivent être en 755 et ne pas oublier de redonner aussi les bons propriétaires dans les sous-dossiers.

durrm001
29/09/2006, 09h55
Tibre44, je viens d'essayer avec tes paramètres, mais cela ne change rien.
Sais-tu s'il y a un autre répertoire contenu dans "home" qui gère les mails ?

Pour les 2 répertoires que je t'avais demandé, ils sont en chmod 777. Est-ce que cela joue d'avoir trop de droits??

Si quelqu'un a une autre suggestion pour que je puisse à nouveau recevoir des mails, je suis toute ouïe...

Tibre44
29/09/2006, 09h48
Bonjour,

Voilà ce que j'ai chez moi sur une Gentoo 2006.

Code:
ls -ld /home/vpopmail/ /home/ovh/cgi-bin/
drwxr-xr-x 2 vpopmail vchkpw 4096 Jun 14 15:23 /home/ovh/cgi-bin/
drwxr-xr-x 7 vpopmail root   4096 Jun  7 11:05 /home/vpopmail/
Tibre

durrm001
29/09/2006, 09h28
Bonjour,

Depuis 2 jours, je ne reçois plus aucun mail, mais je peux en envoyer.

J'ai contacté le service technique OVH qui m'a dit que c'était un problème de droits de répertoire.

En effet, les droits d'accès au répertoire /home/vpopmail/ ont été écrasés avec l'utilisateur "root" et le groupe "root". Idem pour /home/ovh/cgi-bin/ pour accéder à qmailadmin et sqwebmail. Je précise que je suis en serveur dédié.

Le service technique OVH m'a dit qu'il fallait remettre les anciens droits, cependant je n'ai aucune idée de ce que c'était !

Est-ce que l'un d'entre vous aurais la gentillesse de me dire quels droits il faut mettre pour /home/vpopmail/ et /home/ovh/cgi-bin/ ???

Je tiens à préciser que je ne peux plus accéder à la gestion des comptes pop et à la lecture des mails depuis l'interface. Voici le message d'erreur :
--------------------------------------------------------------------------------
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, tech@ovh.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
--------------------------------------------------------------------------------

Merci de votre aide !