OVH Community, votre nouvel espace communautaire.

502 Bad Gateway - nginx / Welcome to nginx!


captainadmin
07/08/2015, 15h30
Est-ce que tu as simplement vérifié que le mysql tournait

Sinon un peu de supervision devrait t'aider pour ton problème, si besoin n'hésite pas

Bon weekend

neomino
07/08/2015, 14h10
Dans auth.log, j'ai la première erreur de connection aux databases le 28 juillet à 23h33 et 51'' :
Code:
Jul 28 23:33:51 sshd[30611]: Unable to connect to Plesk Database: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)
Ce qui correspond assez bien avec le problème "ERROR: Zend_Db_Adapter_Exception: SQLSTATE[HY000] [2002] No such file or directory (Abstract.php:144)", semblerait-il.

Dans systlog, au même instant j'ai un 'Call Trace' indiquant un crash kernel.
Code:
Jul 28 23:33:50 ks200730 kernel: Call Trace:
...
Jul 28 23:33:50 ks200730 kernel: Out of memory: Kill process 16638 (mysqld) score 97 or sacrifice child
Jul 28 23:33:50 ks200730 kernel: Killed process 16638 (mysqld) total-vm:1344640kB, anon-rss:161036kB, file-rss:0kB

neomino
03/08/2015, 11h32
Merci Captainadmin.

J'ai solutionné l'erreur 502 en suivant les instructions de la page http://kb.odin.com/fr/118757.

Je n'ai plus l'erreur "502 Bad Gateway - nginx" en accédant au serveur. Par contre j'ai l'erreur "ERROR: Zend_Db_Adapter_Exception: SQLSTATE[HY000] [2002] No such file or directory (Abstract.php:144)" maintenant.

Le nouveau message d'erreur semble provenir des databases, comme indiqué ici. Malheureusement je ne trouve pas mysql.sock , ni /etc/my.cnf.
Pourquoi je ne vois pas my.cnf, cela reste un mystère.

Je fais un back-up complet pour pouvoir chercher via l'explorateur Windows ensuite.

captainadmin
02/08/2015, 22h19
Hello,

Ton erreur est beaucoup trop vague pour que l'on puisse t'aider.
Il faut voir si les process tournent correctement commen nginx, php ou mysql
Ensuite une chose essentielle, c'est la vérification des logs dans /var/log

Une fois que tu as fais ca, il faut savoir si ton serveur est en train de se faire attaquer ou simplement mal configuré

Bon courage
http://www.captainadmin.com

neomino
01/08/2015, 10h51
Selon ce que j'ai trouvé sur cette page http://www.keole.net/plesk-11-5-ngin...y/#comment-246, cela ressemble à une mise à jour intempestive de Plesk.
Le problème c'est que je n'ai pas accès au serveur via l'administration de Plesk habituel, l'erreur 502 apparait aussitôt que je tente de me connecter.
En ajoutant dans etc/nginx/nginx.conf :
proxy_buffer_size 128k;
proxy_buffers 4 256k;
proxy_busy_buffers_size 256k;
Ca ne change rien pour moi.

Des idées ?

neomino
01/08/2015, 10h11
Est-ce que cela peut correspondre à une attaque sur le serveur ?

neomino
31/07/2015, 12h18
Citation Envoyé par Leeloo
Bonjour,

que donne en ssh un :

Code:
ps fauwx | grep nginx
et les log (/var/log/nginx... ) ?

Quelle est la distribution ?
Merci de ta réponse.
J'obtiens :
root 17111 0.0 0.0 8104 932 pts/0 S+ 18:58 0:00 | \_ grep --color=auto nginx
root 5465 0.0 0.0 76836 1284 ? Ss 12:34 0:00 nginx: master process /usr/sbin/nginx
www-data 5466 0.0 0.1 77192 2228 ? S 12:34 0:00 \_ nginx: worker process
www-data 5467 0.0 0.1 77192 2216 ? S 12:34 0:00 \_ nginx: worker process
www-data 5468 0.0 0.1 77192 2216 ? S 12:34 0:00 \_ nginx: worker process
www-data 5470 0.0 0.1 77192 2228 ? S 12:34 0:01 \_ nginx: worker process

Ma distribution: Linux Plesk 11.0.9 Ubuntu 12.04 110120608.16

Leeloo
31/07/2015, 11h44
Bonjour,

que donne en ssh un :

Code:
ps fauwx | grep nginx
et les log (/var/log/nginx... ) ?

Quelle est la distribution ?

neomino
31/07/2015, 11h22
Bonjour,

J'ai cette erreur quand je tente de me connecter à mon serveur depuis hier. Mes sites sur le dédié ne fonctionnant pas, j'ai bien essayé d'aller sur Plesk pour voir pourquoi, mais impossible d'y accéder. Pareil en FTP. J'ai pu accéder seulement via le SSH.
Je n'ai pas de geocache comme j'ai pu lire sur le forum pour les mutualisés.

Lorsque je tente d'accéder à un site du serveur, j'ai le message "Welcome to nginx!". Etrange,surtout que je n'ai rien fait sur le serveur ces derniers jours. J'ai mis à jour mon Plesk il y a 4 semaines. Depuis plus rien.
C'est la cata, tous les sites sont inaccessibles !!!!

Quelqu'un a une idée sur cette erreur 502 Bad Gateway - nginx. ?