OVH Community, votre nouvel espace communautaire.

Formulaire ne fonctionne plus


lxwfr
18/08/2015, 23h23
c'est peut-être du à la mise à jours de php, regarder plus prêt. ou quelque code erreur à testé en local d'abord.

MarinaS
23/07/2015, 14h29
Bonjour,

Je viens de remarquer récemment que mon formulaire de contact (codé en php, pas de widget ni de CMS) ne fonctionne plus: au moment de l'envoi du formulaire, je ne suis pas redirigée vers la page souhaitée et je ne reçois aucun mail. http://www.marinaschnoerringer.fr/contact
Je ne comprends pas quel est le problème, car le formulaire fonctionnait parfaitement pendant plusieurs mois et je n'ai fait aucune modification depuis.

J'ai tenté de résoudre le problème en remplaçant mon script par un script de formulaire basique. J'ai réussi à envoyer le mail, mais celui-ci était complètement vide, comme s'il n'était pas possible de récupérer les données du formulaire.

J'ai également essayé de changer le nom des fichiers et les noms des variables, rien n'y fait. De plus, quand j'essaie de changer le nom des fichiers (contact.html devient contact_essai.html et formulaire.php devient formulaire_essai.php), en veillant bien à remplacer le nom du fichier dans
, au moment de l'envoi du formulaire je suis toujours encore redirigée vers formulaire.php alors que j'ai changé le nom du fichier...

J'ai tenté de remplacer la méthode POST par la méthode GET et j'ai remarqué que PHP n'interprète pas la méthode POST, même un simple echo $_POST['nom']. Par contre, la méthode GET fonctionne très bien.

Je cherche une solution sans succès depuis plusieurs jours. Je ne comprends pas ce qui a pu changer étant donné que je n'ai pas modifié mes fichiers depuis plusieurs mois et que ça fonctionnait parfaitement avant.
Ce problème pourrait-il être lié à un éventuel piratage de mon site? Auriez-vous des conseils à me donner?

Je suis à bout d'idées et le support OVH tarde à répondre...

Merci pour votre aide !