OVH Community, votre nouvel espace communautaire.

Proxmox : configuration cartes réseau


RichardM
02/07/2015, 02h00
Re,

en fait je n'ai pas trop saisi les différences entre routed et bridge.
J'ai surtout cru comprendre que (donc peut-être erronée comme info ...) :
Routed = nombre de ports liés à l'IP du serveur : donc un seul port 80 par exemple
Bridge = nombre de ports liés à l'IP failover : donc autant de ports que d'IP (si 4 IP : port 80 x 4)

C'est ça ?

J'ai cru lire que le routed était plus rapide que le bridge, c'est exact ?

captainadmin
01/07/2015, 22h48
merci,

pour info tu peux aussi configurer en routed mode ton container et gérer l'ip directement via proxmox.
visiblement tu as choisi le bridge ca marche aussi mais il faut faire l'interface à la main dans le container.

Bon courage

RichardM
01/07/2015, 21h55
Bon ! J'ai retrouvé le tuto qui m'a sauvé la vie !

http://documentation.online.net/fr/s...n-proxmox-ve-3

En fait, il fallait simplement que je corrige mon "adress" en "address" ( ^^' ) puis que j'exécute la commande suivante : ifup eth0

Je supprime le CT et je recommence, si je ne reposte pas ici c'est que tout fonctionne.
Si vous avez des questions sur la méthode que j'ai suivi, répondez au topic je verrai la notif mail, sinon je vais tâcher de rattraper le retard que j'ai dans mon planning.

CaptaineAdmin, j'ai adoré le background de ton site, vraiment bien trouvé et ficelé !

RichardM
01/07/2015, 21h45
Bonjour,

donc : un CT pardon.

Hier soir j'ai réussi à créer un CT qui a accès à internet : seulement impossible de me rappeler comment j'ai fait ... j'ai reproduis le fichier /etc/network/interfaces (pas de interfaces.head ou autre interfaces.X) et configuré une nouvelle CT de la même façon : impossible de réitérer l'exploit.

Je précise que, je stop le CT qui a accès à internet et que je lance ensuite un CT qui me semble avoir la même configuration (adaptée au nouveau CT) : pourtant le nouveau CT n'a pas internet. :/
(J'ai pensé au reboot)

Est-ce que ça vient de l'adresse mac de l'hôte, dans Proxmox ? Car à chaque CT j'en ai une nouvelle : me semblait que l'adresse mac c'était celle de mon serveur dédié, donc théoriquement il ne devrait y avoir qu'une adresse mac "hôte", non ?

J'y comprends vraiment rien ...

captainadmin
01/07/2015, 15h51
Hello

Il faut savoir ce que tu veux faire avec cette ipfailover, la connecter sur ton proxmox puis gérer pour toutes tes vm ou l'allouer pour une vm spécifique avec un routage dédié.
Dans tous les cas ca se fait simplement avec une vmbr0 plugguer sur la bonne interface.

Bon courage
http://www.captainadmin.com

arowan
30/06/2015, 20h35
Tu n'as RIEN à toucher à la config hôte sauf si tu veux faire de la redirection de port

lorsque tu créé une vm cad ct ou vm? dans le cas d'une vm tu bridges avec vmbr0 tu y renseignes la mac que tu as créés via le manager et tu lances l'install de la vm ensuite tu changes la config réseau dans la vm et tu y mets les infos de ton ip FO.

Tu as toute la marche à suivre sur le lien ci-dessous

http://guides.ovh.com/Proxmox


bon c'est un ancien tuto mais le principal reste le même

RichardM
30/06/2015, 18h33
Bonjour,

j'essaie, en vain, de configurer Promox. :/

Je n'arrive pas à trouver de bons tutos, J'ai écumé le web sans résultats probants. :S

Quelqu'un peut-il m'aider ?

J'ai réinstallé Proxmox car la VM où je faisais mes tests a "bugué" (impossible de la supprimer ...) du coup me revoilà sur une install toute fraîche !

Ce que j'ai sur la config de l'hôte, dans "Réseau" :
vmbr0 / Linux Bridge / eth0 / IP : 188.165.209.89 / Masque : 255.255.255.0 / Passerelle : 188.165.209.254

Je sais qu'il faut utiliser une IP failover et une adresse mac dédiée, donc j'ai acheté une adresse IP FO sur laquelle j'ai une adresse mac.
Néanmoins, j'ai beau suivre les tutos pour configurer cela, impossible de bien faire fonctionner le bouzin. :S

Peut-être que j'ai mal configuré l'hôte ? :/