OVH Community, votre nouvel espace communautaire.

VPS Release 3 OVH | PHP 5.3.3 > PHP 5.4-PHP 5.x | Joomla! 2.5 > Joomla! 3.x


Eclipse68
18/06/2016, 01h26
Vivant, je suis vivant, mais, que de galères.

J'ai tout laissé tombé pour la migration. Format c:/ rm delete remove destroy.
Le template, et, rien ne marchait, quand je copiais le site et tentais alors de mettre à jour.

J'ai récupéré la BDD J2.5 , j'ai installé un site neuf en J3.5 , j'ai lié la BDD, et, corrigé la BDD automatiquement avec Joomla!
Puis, tout réinstallé manuellement, et réparer quelques bogues, souvent bien identifiés déjà par les super Dev que vous êtes.
Quel bordel, mais, c'est enfin résolu.

Mission suivante, passer le site local sous une VM locale.
Je suis entrain de monter une VM sous Debian 8.4, j'ai installé webmin, et, voilou, j'espère que ce sera moins compliqué ainsi.

Eclipse68
10/03/2016, 22h29
Merci doc_denis.
Bon, ça me rassure, j'avais déjà lu tes liens, donc, c'est que je dois pas être si éloigné que cela.

Je vais recommencer car pour le moment, ça n'allait pas.
Déjà, j'ai bien repassé le mutu de destination, ( sur un hébergement pas encore exploité ) en php 5.5.3
Je suis entrain de copier manuellement les données venant du site précédent ( 5.3.3 )
Je vais installer manuellement la base de données.
Remettre le .htaccess d'origine, et, tenter de me connecter à l'administration, si je n'ai pas une page blanche, pour pas changer.
De la, j'espère pouvoir faire la mise à jour.

Si non, je vais donc appliquer le patch de mise à jour en 3.02 , brutalement, sur le FTP.
Mais, pour la base de données, je ne touche donc pas. Si j'ai bien compris, cela doit pouvoir se faire par la suite, depuis l'interface admin de Joomla.

Si, biensur, elle veut bien s'afficher.

doc_denis
10/03/2016, 18h15
Bonjour,

php et joomla :
http://www.joomla.fr/afuj/item/1468-...es-pour-joomla
https://www.akeebabackup.com/compatibility.html

Migration / mise a jour
http://aide.joomla.fr/telechargement...-3-0-2/details

dans le cas d'utilisation de e-commerce avec VM, je conseil l'utilisation de vm-migrator (payant, mais on gagne beaucoup de temps)
https://www.daycounts.com/vm-migrator

@+ denis

Eclipse68
08/03/2016, 19h32
Citation Envoyé par buddy
Pourquoi tu dis qu'il te faut pouvoir réinstaller ton site avant ?
Sauf erreur de ma part, en copiant sur ton nouveau serveur les fichiers de joomla 2.5 et en copiant la base de données tu peux lancer la migration vers joomla 3.x.

Nb joomla 2.5.x tourne sous php5. 4 juste 1 message d'erreur non bloquant
Je tente cela en //
Merci buddy.

Eclipse68
08/03/2016, 16h25
La j'ai monté une debian 8.3, et, une VM avec un serveur Debian 8.3 avec les paquets tous à jour, par défaut.

Mais, je ne sais pas comment upper Joomla! 2.5.28 sur cet environnement peut être déjà trop à jour ?

J'aimerais pouvoir installer PHP 5.3.3 sur le serveur debian 8.3 que j'ai en VM.

Puis, mettre à jour vers PHP 5.5 / PHP 5.6 en fonction des besoins de mes modules et plugins.

Pouvez vous m'aider a mieux appréhender ce que je dois faire ? Pour le moment je n'arrive pas a installer php 5.3.3 sur le serveur debian Jessie 8.3.

buddy
03/03/2016, 16h45
Pourquoi dans ce cas prendre une R3 OVH et la préférer à une débian ou Centos + Virtualmin ?

Raptor00
03/03/2016, 13h57
Perso j'ai php 7 sur ma R3 depuis 2 mois sans problèmes

mkdir /root/configphp
cp -Rf /etc/php* /root/configphp
sudo yum remove php php-cli php-common && yum clean all
sudo rpm -Uvh https://dl.fedoraproject.org/pub/epe...t-7.noarch.rpm
sudo rpm -Uvh https://mirror.webtatic.com/yum/el7/...ic-release.rpm
sudo yum install php70w php70w-opcache

Et voila avec ses commandes vous avez votre php a-jour

https://ns3024190.ip-149-202-88.eu/

buddy
03/03/2016, 10h03
Pourquoi tu dis qu'il te faut pouvoir réinstaller ton site avant ?
Sauf erreur de ma part, en copiant sur ton nouveau serveur les fichiers de joomla 2.5 et en copiant la base de données tu peux lancer la migration vers joomla 3.x.

Nb joomla 2.5.x tourne sous php5. 4 juste 1 message d'erreur non bloquant

janus57
02/03/2016, 05h57
Bonjour,

Comment faire pour installer proprement un ENV Apache pour Debian avec PHP 5.3.3 ?
impossible car dire d'installer un PHP5.3 "propre" revient à dire d'installer un Windows XP avec des patch ce qui est impossible depuis que windows à stopé le support tout comme PHP avec les version inférieur à PHP5.5.

Du coup jessie == PHP 5.6 et Wheezy== PHP5.4
Utiliser debian squeeze je pense que c'est mort aussi car le support est finit.

La prise en charge de la sécurité pour Debian 6 « Squeeze » arrive à son terme le 29-02-2016. La prochaine version LTS est pour Debian 7 « Wheezy » et sera pris en charge à partir du 26-04-2016 jusqu'au 31-05-2018.
Cordialement, janus57

Eclipse68
02/03/2016, 03h15
Coucou les amis.
Bon, il me semblait avoir compris ......


DEBIAN Jessie, pasque, Debian, c'est bien !
Puis virtual machin ... et .... STOOOP c'est déjà trop pour moi : https://www.how-to.ovh/viewtopic.php?t=12
Du coup, je me demande comment faire pour partir sur une Debian Maison, mais, il me faudra d'abord avoir PHP 5.3.3
En effet, il me faut pouvoir réinstaller mon site avant toute mise à jour.
Comment faire pour installer proprement un ENV Apache pour Debian avec PHP 5.3.3 ?


J'ai relevé ce message pour la RELEASE 3, vu précédemment je crois : http://www.dootech.fr/blog/ovh-relea...-3-vers-5-6-3/

seb2047
16/09/2015, 13h54
Merci pour le lien Janus
j'y reviendrai quand je me lancerai...

janus57
15/09/2015, 20h38
Citation Envoyé par seb2047
Oui plus le choix malheureusement
je vais partir une Debian avec webmin et virtualmin en espérant pas trop galérer pour l'installation et la configuration...
Bonjour,

très simple : http://www.how-to.ovh/viewtopic.php?t=12

Je conseil juste d'utiliser directement le script de Virtualmin.

P.S. Virtualmin installe automatiquement Webmin + usermin pour former Virtualmin pas besoin de se prendre la tête.

Cordialement, janus57

seb2047
15/09/2015, 16h39
Oui plus le choix malheureusement
je vais partir une Debian avec webmin et virtualmin en espérant pas trop galérer pour l'installation et la configuration...

janus57
14/09/2015, 21h00
Bonjour,

Ubuntu et Debian sont tout les 2bien documentés et Debian est un peu plus "stable" si on utilise les dépôts officiels.

Perso je dit qu'il faut fuir la R3 et utiliser Virtualmin sur un OS "nue".

Cordialement, janus57

seb2047
14/09/2015, 14h23
Salut,

j'ai un problème similaire je suis sous Wordpress et je ne peu plus faire les mises à jour depuis l'admin (extensions et futurs versions de wordpress) car il faut maintenant la version 5.4 de PHP !! (voir topic forum wordpress)

Merci OVH pour votre Release 3 obsolète !

Est-ce qu'il faut que les utilisateurs fassent une pétition pour que ça bouge un peu ??

Eclipse68
14/09/2015, 03h47
Ok, bon, effectivement, j'avais pris une Release 3 car mon ancien employeur avait la même chose. ( Quelle idée. )

Du coup, partir sur une Ubuntu, par exemple, est je crois mis en avant, comme une bonne solution, documentée.

janus57
13/09/2015, 15h23
Bonjour,

non ce que voulais dire @lxwfr c'est carrément d'abandonner la Release3 et de partir sur un OS avec par dessus Webmin/Virtualmin tout court c'est largement plus facile à maintenir vu que les MAJs des composants suivront les MAJs de l'OS de base.

Exemple :
Debian Jessie + Virtualmin (fonctionne comme une R3) == apache2.4 + php5.6 donc voilà la dernière version de PHP juste en changeant d'OS et en ayant toujours un panel pour aider à la gestion.

Cordialement, janus57

Eclipse68
13/09/2015, 15h06
Une Release 3 OVH, mise à jour maison, qui ne sera plus une Release 3 OVH, mais, une Release Bidouille. Est ce conseillé ? ...
J'ai pas spécialement envie de tester, vu mon niveau.
Avis conseils idées, sinon, ptite mousse ?

lxwfr
13/09/2015, 10h34
ou réinstaller avec les source d'origine de webmin (=non customiser par ovh) en plus à jours

Eclipse68
13/09/2015, 04h23
Un simple échange avec un technicien, rien pour le moment, ils y pensent ( de très loin du coup ? ).
Il m'a dit qu'il faut évoquer le besoin, et, faire la demande ... Je suppose qu'ils ne vont pas oublier de mettre quelque chose en place.

libris86
04/09/2015, 15h27
Citation Envoyé par Eclipse68
Ok, justement, à ce sujet, j'ai envoyé un mail aujourd hui, pour savoir comment ça va se dérouler, chez OVH, si ils ont une Release 4 au programme.
Merci de vos réponse. Je complèterais, une fois que le support m'aura répondu.
Toute suite sur une mise a jour prévue par OVH pour cette release 3 et un PHP > a 5.3 bienvenue...

Decko
04/09/2015, 03h48
Citation Envoyé par Eclipse68
Ok, justement, à ce sujet, j'ai envoyé un mail aujourd hui, pour savoir comment ça va se dérouler, chez OVH, si ils ont une Release 4 au programme.
Merci de vos réponse. Je complèterais, une fois que le support m'aura répondu.
Je suis curieux de la réponse...

Eclipse68
26/07/2015, 19h23
Ok, justement, à ce sujet, j'ai envoyé un mail aujourd hui, pour savoir comment ça va se dérouler, chez OVH, si ils ont une Release 4 au programme.
Merci de vos réponse. Je complèterais, une fois que le support m'aura répondu.

ABSOLUTE Web
06/07/2015, 19h16
Bonjour,

C'est à OVH de fournir une release qui mettra à jour PHP et MySQL. D'ici à ce qu'il abandonnent la Release 3 et plantent tous les clients...

Nicolas.

mailbox
01/07/2015, 07h45
Oui ça semble meme fou de laisser PHP 5.3 !

La réponse du Support a ce sujet est sympa... impossible de passer en PHP 5.6 sans sortir de la R3....

fritz2cat
29/06/2015, 11h38
Le mail automatique concerne le mutu et non les VPS.

A propos de la release 3, OVH ferait bien de faire une mise à niveau du PHP pour rester crédible.

Eclipse68
28/06/2015, 21h17
Bonjour, je voulais savoir comment ça allait se passer par la suite, pour les Release 3 OVH sous php 5.3.3


Que devons nous faire, suite au mail automatique, qui nous informe que certains site sont à mettre à jour car, fin de vie de PHP 5.3


Actuellement, j'ai un Joomla 2.5 -(oui je sais..) avec Akeeba Backup.
Toutes mes applications sont compatibles Joomla 3.x

Est ce que je lance la migration vers Joomla! 3.x depuis php 5.3.3, ou bien, est ce que je dois lancer une réinstallation, avec akeeba, depuis un serveur PHP 5.4 ?


Merci de vos conseils.