OVH Community, votre nouvel espace communautaire.

adresse IP dans URL


max182
25/06/2015, 16h08
Citation Envoyé par fritz2cat
wp-admin > General settings > WordPress Address (URL) > http://www.tutogeek.fr
Site Address (URL) > http://www.tutogeek.fr
Merci... c'était ça....
Merci à vous tous pour l'aide apportée, et désolé si j'ai eu du mal à comprendre certains choses, je débute complètement..

fritz2cat
24/06/2015, 15h30
wp-admin > General settings > WordPress Address (URL) > http://www.tutogeek.fr
Site Address (URL) > http://www.tutogeek.fr

janus57
24/06/2015, 10h20
Bonjour,

Perso quand je vois ceci :
Code:


Je pense très sincèrement que le WordPress a été installé via l'IP et non via le NDD, donc retour en arrière par rapport à ce que j'avais dit : On change cela dans WordPress/BDD.

EDIT :
au passage j'arrête pas de me répéter que c'est ça le problème, mais visiblement vous n'en tenez pas compte, donc à quoi ça sert que j'essaye de vous aider ??
Et oui perso je vois ce comportement sur votre site depuis que vous avez donné le NDD et juste avant que vous réinitialiser le tout.

Cordialement, janus57

buddy
24/06/2015, 10h13
A mon avis tu as installé ton wordpress via l'adresse ip dans l'URL. Du coup il faut suivre la procédure "changement de domaine" pour wordpress et mettre www.tutogeek.fr

Ex : http://quick-tutoriel.com/changer-no...n-30-secondes/ sinon faut chercher sur le site officiel ou sur google..

max182
24/06/2015, 00h13
Mais c'est toujours pareil, tutogeek amène bien maintenant sur l'IP, mais seulement sur la page d’accueil.
Quand on va sur la page articles par exemple, ce n'est plus tutogeek.fr/articles mais IP/article.

J'ai fais ce que tu m'as dis. Normalement ^^

fritz2cat
23/06/2015, 23h09
C'est déjà un CNAME et tu édites le CNAME
ou bien tu supprimes le CNAME et tu en crées un autre.

Simple.

- - - Mise à jour - - -

Citation Envoyé par max182
Je dois rajouter si j'ai bien compris,
domaine : tutogeek.synology.me type : CNAME cible : tutogeek.fr
non, le contraire
www type CNAME cible tutogeek.synology.me

max182
23/06/2015, 22h11
Ok merci bien
Mais dans la zone DNS sur OVH j'en ai plusieurs dont :

domaine : tutogeek.fr type : A cible : l'adresse IP du NAS
domaine www.tutogeek.fr type : CNAME cible : tutogeek.fr

Normalement c'est pas suffisant alors ça du coup ?
Je dois rajouter si j'ai bien compris,
domaine : tutogeek.synology.me type : CNAME cible : tutogeek.fr

fritz2cat
23/06/2015, 22h04
oui

max182
23/06/2015, 21h58
Oui j'avais déjà un autre domaine tutogeek.synology.me pour acceder a mon site.
J'ai pris DNS server pour les configuration sur le synology.

Mais configurer www.tutogeek comme un CNAME qui renvoie sur ça, je dois le faire sur OVH ?

fritz2cat
23/06/2015, 21h48
Tu configures un DDNS chez OVH pour que l'adresse www.tutogeek.fr renvoie sur l'IP de ton synology

ou bien

tu configures un autre nom de domaine par exemple syno.example.com qui renvoie sur l'IP de ton synology ; et tu configures www.tutogeek.fr comme étant un CNAME qui renvoie sur syno.example.com.

J'imagine qu'il y a un client DynDNS sur le SYNO.

max182
23/06/2015, 21h36
Citation Envoyé par buddy
1/ tu as choisi et paramétré quel sous domaine avec le ddns de synology ??
Voila j'ai tout remis à neuf. Mais avant d'avancer dans la construction du site, je préfère déjà faire la bonne redirection. On a accès à mon site avec l'adresse IP, et on a accès à la page www.tutogeek.fr avec la page " félicitation ! vous avez créé votre domaine chez OVH" ...

Que dois-je faire maintenant étape par étape svp ?

buddy
20/06/2015, 01h46
1/ tu as choisi et paramétré quel sous domaine avec le ddns de synology ??

max182
19/06/2015, 19h22
Bonjour, merci de l’intérêt que vous portez à mon problème.
Après plusieurs modifications, je suis arrivé à pire... dans l'url s'affichait mon adresse IP PLUS tutogeek.fr ... du coup rien ne marchait, jusqu'à ce que le wordpress ''plante'' je ne pouvais plus me connecter en admin ip/wp-admin ni rien...
Du coup j'ai décidé de recommencer tout de 0, j'ai donc tout désinstaller et réinstaller mais je n'arrive même plus à créer un nouveau wordpress... au moment de son installation j'ai une erreur error http 500. J'ai regardé sur internet et suivi des conseils mais je reste bloqué... Je commence a désespérer j'ai passé beaucoup de temps à essayer de comprendre tout ça.

Si quelqu'un aurait envi de passer du temps pour régler ça j'en serais très ravi... Via skype par exemple ou autre serveur vocal ou par écrit.
Contactez vous à cette adresse : play-basket@hotmail.fr pour prendre contacte.
Je sature :s lol ...
Merci à vous

janus57
19/06/2015, 12h32
Citation Envoyé par buddy
Non, l'ip de tutogeek.fr et www.tutogeek.fr pointe vers le mutualisé ovh. Donc il n'a pas appliqué ce que je lui ai conseillé et ce n'est pas WordPress qui redirige mais la redirection OVH...


Donc 1/ tu remets la zone dns à zéro
2/ tu configure OVH ddns sur le synology (dis nous avec quel sous domaine tu l'as fait)
3/ ca devrait marcher...
Bonjour,

au moment de mon test son domain envoyé sur "89.156.53.64" et non une IP de mutualisé OVH (comme montré plus haut).

Au vu du serial (2015061905), je pense qu'il c'est amusé à "jouer" avec les DNS cette nuit ou peu avant mon test.
Sachant que j'ai fait le test vers +/- 1H du matin et que le serial indique 5 modification de zone pour la journée du 19 je dirais qu'il a touché au DNS avnt ou après ce que j'ai dit.

De plus si dans mon fichier HOSTS (windows) je relie 89.156.53.64 avec tutogeek.fr ou même directement sur son IP je tombe maintenant sur l'index de son synology qui dit qu'il est pas config, ce qui semble prouver qu'il a modifier les choses entre temps.

Cordialement, janus57

buddy
19/06/2015, 04h16
Citation Envoyé par janus57
Bonjour,

c'est bien ce que j'ai dit (depuis le #4), visiblement vous avez installé le CMS vuia l'IP et maintenant il force l'IP.

Il suffit juste de lui dire d'utiliser "tutogeek.fr" plutôt que l'IP (y a la procédure dans le codex WordPress).



Cordialement, janus57
Non, l'ip de tutogeek.fr et www.tutogeek.fr pointe vers le mutualisé ovh. Donc il n'a pas appliqué ce que je lui ai conseillé et ce n'est pas WordPress qui redirige mais la redirection OVH...


Donc 1/ tu remets la zone dns à zéro
2/ tu configure OVH ddns sur le synology (dis nous avec quel sous domaine tu l'as fait)
3/ ca devrait marcher...

janus57
19/06/2015, 01h02
Citation Envoyé par max182
Ah d'accord merci, mais du coup ce réglage se fait directement sur wordpress alors ? et non sur le NAS ou le manager OHV.
Bonjour,

oui et toute les infos sont sur le site wordpress (vu que j'utilise pas vraiment wordpress et la dernière fois ou j'ai du faire le changement c'était à coup de modification de la BDD).

Cordialement, janus57

max182
19/06/2015, 00h54
Ah d'accord merci, mais du coup ce réglage se fait directement sur wordpress alors ? et non sur le NAS ou le manager OHV.

janus57
18/06/2015, 23h58
Bonjour,

c'est bien ce que j'ai dit (depuis le #4), visiblement vous avez installé le CMS vuia l'IP et maintenant il force l'IP.

Il suffit juste de lui dire d'utiliser "tutogeek.fr" plutôt que l'IP (y a la procédure dans le codex WordPress).

FollowRedirects=False; Server requested redirection
HTTP Headers for http://tutogeek.fr

HTTP/1.1 302 Moved Temporarily
Set-Cookie: rd=R3047009581; path=/; expires=Sun, 21-Jun-2015 11:06:38 GMT
Server: nginx
Date: Thu, 18 Jun 2015 22:56:39 GMT
Content-Type: text/html
Content-Length: 154
Connection: close
Location: http://89.156.53.64
Cordialement, janus57

max182
18/06/2015, 22h53
Si vous voulez, mais ne prêtez pas attention au contenu il est en construction
www.tutogeek.fr

janus57
18/06/2015, 22h46
Bonjour,

et donner le NDD en question cela ne serait pas plus simple ?

Cordialement, janus57

max182
18/06/2015, 22h38
Dans ma config sur le NAS j'ai :

NomDomaine.fr -- type A -- monIP
NomDomaine.fr -- type NS -- ns.NomDomaine.fr

Dans ma config OVH j'ai :

Sous-domaine : .NomDomaine.fr -- type visible -- cible http://monIP

Je sais pas si ça peut aider ...

max182
18/06/2015, 19h57
Merci pour ta réponse. La solution est peut être sous mes yeux mais je n'y arrive toujours pas... La démarche expliquée sur le lien à propos du syno je l'ai déjà faite. Tout est bien paramétré à ce sujet. Je ne sais absolument pas d'où vient le problème :s

buddy
18/06/2015, 12h59
Bonjour,

Si ton NAS synology est récent & à jour il intègre OVH dans la partie :
http://anima-ex-machina.fr/synology-...c-dynamic-dns/ §CONFIGURER LE SERVICE DDNS DEPUIS LE NAS
avec les infos d'ici : http://guide.ovh.com/DynDns

après la propagation DNS ca devrait marcher.

max182
18/06/2015, 08h13
Bonjour,

Vers ma page Web, hébergé par un NAS synology.
Du coup pour accéder à mon site, c'est tout simplement mon IP.
Mais j'aimerais que le nom de domaine s'affiche toujours dans l'URL et non pas l'IP.
Du coup je ne sais pas trop où se trouve le réglage à faire :s mon NAS, box, sur ovh ... ? :s
Je suis débutant et j'ai du mal à assimiler ces config DNS je crois bien.

buddy
17/06/2015, 23h17
tu veux que ton nom de domaine pointe vers quoi ?
un site sur un VPS ? un dédié ?

janus57
17/06/2015, 18h12
Bonjour,

en donnant le vrai NDD on pourrait peut être aidé plus vite.

Ici je sens bien le CMS qui a été installé avec l'ip et ton "domaine" qui basculera sur l'ip à chaque requête car il (le CMS) force le NDD (ici c'est une IP) utilisé lors de l'installation.

Cordialement, janus57

max182
17/06/2015, 16h42
Oui ça fait pas très pro, c'est pour cela que je veux changer.
Oui tu dis que je dois mettre mon nom de domaine et non pas l'IP, mais comment ? c'est ce que je cherche à faire.

Quand je tape www.nomdomaine.fr, ça envoie bien sur mon site, mais l'adresse disparaît et met l'IP à la place dans l'URL.

Merci pour l'intention porté à mon problème.

fritz2cat
17/06/2015, 16h09
La redirection invisible montrera toujours la home page du site à rediriger, et en plus quand tu utilises la touche "back" de ton navigateur ça revient beaucoup plus en arrière que ce que tu veux.
C'est généralement un mauvais choix. C'est un bricolage à base de frames et c'est une enroule qui ne fait pas professionnel du tout.

Quant à ton problème d'IP, tu n'as qu'à utiliser ne nom de ton domaine et non pas une IP ?? ou bien fais un sous-domaine video.tondomaine.com qui pointe vers l'IP que tu connais.

max182
17/06/2015, 12h10
Bonjour,

J'ai un petit problème que je n'arrive pas résoudre. Je suis débutant.
Quand je tape le nom de mon site, on arrive a y accéder mais c'est l'adresse IP qui s'affiche dans l'URL.
Pour y remédier, je suis aller dans la rubrique redirection web, et j'ai changé le type visible à invisible. Cependant, mon nom de site s'affiche bien dans l'URL, il n'y a plus l'adresse IP, mais ce nom est le même pour toutes mes pages... Je voudrais avoir XXX/video quand je vais sur la page vidéo par exemple.
Aidez-vous SVP a résoudre ce problème.
Merci à vous