OVH Community, votre nouvel espace communautaire.

Ubuntu Vivid + Ispconfig ; impossible upload > 100k via php ==>error 500? SOLUTION :)


enzo24
05/06/2015, 14h33
Bonjour a tous & toutes,

Tout d'abord vérifier votre php.ini (pour moi, je suis en fast CGI donc /etc/php5/fcgi/php.ini) et mettre des valeurs plus "gonflées" à upload_max_filesize , post_max_size et max_execution_time

Déjà le site va reconnaitre des valeurs d'upload plus grands. Mais.... (il y a toujours un mais) ... dans ma situation, il m'était toujours impossible d'uploader une image ou document > 100k depuis mes site joomla !

Fichtre ! Le bougre dit qu'il veut bien 200 M, mais j’atterris systématiquement sur Error 500 quand je veux uploader plus de 100k !!

Sachez donc que FastCGI (du moins dans Ubuntu 15) ne permet pas d'upload supérieur a 100k si on ne lui dis pas autrement !

Donc, il faut modifier /etc/apache2/mods-enabled/fcgid.conf pour qu'il ressemble a ceci :

Code:

  FcgidConnectTimeout 200
  FcgidMaxRequestLen 1073741824
....
Pour faire avaler les changements de configuration, j'ai fait
Code:
services apache2 restart
service php5-fpm restart
Et a partir de là, j'ai pu uploader des fichiers de grande taille selon mes reglages dans le php.ini

J'espère que ceci aidera quelqu'un qui s'est retrouvé bloqué comme moi devant ce probleme..