OVH Community, votre nouvel espace communautaire.

caractère '-' indésirable


janus57
01/06/2015, 11h01
Citation Envoyé par fritz2cat
Grammaticalement, Debian 8 marque un point.
Bonjour,

surtout que Debian 8 à mis à jour pas mal de logiciel avec des données récentes, donc @la_spi_man doit avoir lui aussi des données récentes sur sont locale alors que OVH et Debian 7 ont des données "périmé" pour le module php-intl.

Cordialement, janus57

fritz2cat
01/06/2015, 10h56
Citation Envoyé par janus57
Par contre j'ai pareil sous ma Debian 7 :
cinquante-deux-mille-quatre-cent-cinquante

Sous Debian 8 :
cinquante-deux mille quatre cent cinquante
Grammaticalement, Debian 8 marque un point.

janus57
31/05/2015, 02h34
Bonjour,

c'est lié à l'extension PHP "intl" qui utilise des données "ICU", faut pas me demande ce que c'est mais PHP utilise cela pour plusieurs choses, ici par exemple pour bine sortir les nombre.

OVH :
Code:
intl
Internationalization support	enabled
version 	1.1.0
ICU version 	4.4.1
ICU Data version 	4.4.0.1
Cf : http://fpm5.6-check.cluster015.ovh.net/phpinfo.php

Debian 7.8 :
Code:
intl
Internationalization support	enabled
version 	1.1.0
ICU version 	4.8.1.1
ICU Data version 	4.8.1
Debian 8 :
Code:
intl
Internationalization support	enabled
version 	1.1.0
ICU version 	52.1
ICU Data version 	52.1
Par contre j'ai pareil sous ma Debian 7 :
cinquante-deux-mille-quatre-cent-cinquante
Sous Debian 8 :
cinquante-deux mille quatre cent cinquante
Donc voici un code "barbare" pour que cela fonctionne chez OVH ou version de intl pas à jour : https://gist.github.com/janus57/1d5d5eb4a75237899bf1

Cordialement, janus57

Gaston_Phone
30/05/2015, 21h16
Là je sèche.

la_spi_man
30/05/2015, 20h58
Merci pour ta réponse.
Mais là aussi j'aurai un souci, car mon cinquante-deux devient cinquante deux.

En fait, je pensais qu'il y avais une method de NumberFormatter pour enlever le '-' ...

Gaston_Phone
30/05/2015, 20h46
Il te suffit de mettre le résultat dans une variable, ex. $Nombre_Lettres et d'appliquer la cpmmande :
$Nombre_Lettres = str_replace ("-", " ", $Nombre_Lettres);

la_spi_man
30/05/2015, 18h46
Bonjour,

J'ai un hébergement performance , php 5.6.6

Mon problème :
Transformer un nombre en lettre avec l'objet NumberFormatter

Code:
$fmt = new NumberFormatter( 'fr_FR', NumberFormatter::SPELLOUT );
echo $fmt->format(52450.00);
// sur OVH il m'affiche  cinquante-deux-mille-quatre-cent-cinquante
// en locale : cinquante-deux mille quatre cent cinquante
Il y a donc le caractère '-' de séparation qui sort de je ne sais où !!!
Quelqu'un a t'il rencontré ce problème et comment le résoudre ?