OVH Community, votre nouvel espace communautaire.

Contenu du dossier home/ vide


janus57
26/05/2015, 17h56
Bonjour,

sans trop dire de conneries on dirait que la partition home (/dev/md4) ne semble pas monté.

Sinon que donne l'état des HDD (raid soft visiblement).

Cordialement, janus57

mohamedkhelifi
26/05/2015, 15h13
Citation Envoyé par janus57
Bonjour,

déjà première erreur, reboot un serveur complet en hard sur une simple erreur software (casse garantie si on fait tout le temps comme ça).

Est-ce que le HDD va bien ?
c'est une R2 ?

Que renvois
Code:
df -h && df -i && du -ah /home | sort -n -r | head -n 10
Cordialement, janus57
Bonjour Merci pour votre réponse;
voici ce que ça donne votre commande:
Code:
Sys. de fich.         Tail. Occ. Disp. %Occ. Mont� sur
/dev/md/1              50G  6,3G   41G  14% /
udev                  1,9G  184K  1,9G   1% /dev
shm                   1,9G     0  1,9G   0% /dev/shm
Sys. de fich.         Inodes   IUtil.  ILib. %IUti. Mont� sur
/dev/md/1            6553600  900804 5652796   14% /
udev                  497592    5374  492218    2% /dev
shm                   497592       1  497591    1% /dev/shm
4,0K	/home
- - - Mise à jour - - -

Citation Envoyé par MaikoB
Bonjour,

Un bon début serait aussi de vérifier le contenu du fichier /etc/fstab pour vérifier que la /home est bien en montage automatique.

Aussi, il serait intéressant de vérifier les disques & RAID au cas où il s'agit d'une défaillance..

Par exemple, pour un RAID Software :

fdisk -l

smartctl -a /dev/sda
smartctl -a /dev/sdb

cat /proc/mdstat

Cordialement,
Bonjour; Merci pour votre réponse:
voici ce que ça donne le fichier fstab
Code:
/dev/md1        /       ext3    errors=remount-ro       0       1
/dev/md3        /dev/shm        ext3    defaults        1       2
/dev/md4        /home   ext3    defaults,usrquota       1       2
/dev/sda2       swap    swap    defaults        0       0
/dev/sdb2       swap    swap    defaults        0       0

# NOTE: The next line is critical for boot!
proc                    /proc           proc            defaults             0 0

sysfs                   /sys            sysfs           defaults             0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec  0 0

MaikoB
26/05/2015, 14h27
Bonjour,

Un bon début serait aussi de vérifier le contenu du fichier /etc/fstab pour vérifier que la /home est bien en montage automatique.

Aussi, il serait intéressant de vérifier les disques & RAID au cas où il s'agit d'une défaillance..

Par exemple, pour un RAID Software :

fdisk -l

smartctl -a /dev/sda
smartctl -a /dev/sdb

cat /proc/mdstat

Cordialement,

janus57
26/05/2015, 12h13
Bonjour,

déjà première erreur, reboot un serveur complet en hard sur une simple erreur software (casse garantie si on fait tout le temps comme ça).

Est-ce que le HDD va bien ?
c'est une R2 ?

Que renvois
Code:
df -h && df -i && du -ah /home | sort -n -r | head -n 10
Cordialement, janus57

mohamedkhelifi
26/05/2015, 11h07
Nous avions un problème avec apache soudainement il s'est arreté et il ne demarrait plus.
Du coups après avoir rebooté le serveur nous n'avions plus accès au dossier home/ le suport technique nous a bien dis que le dossier home est à 49% dont il contient forcement des fichiers.

Leeloo
26/05/2015, 11h00
Bonjour,

le redémarrage fait suite à quoi (maj, ...) ?

"Locate" se base sur un index, le contenu/résultat ne reflète pas obligatoirement la réalité.

Vous avez des sauvegardes ?

Si non, mettre le serveur en mode rescue et faire une image (dd,...) des disques/partitions avant toutes autres opérations.

mohamedkhelifi
26/05/2015, 10h37
Bonjour;
Suite à un redemarrage du serveur, je n'ai plus accès au contenu de mon dossier Home/
Lorsque je fais:
Code:
ls /home
le contenu est vide, pourtant la taille du dossier n'est pas vide et lorsque je fais une recherche sur un fichier que je connais la recherche me ramène ce fichier:
Code:
locate /home/ovh/www/mon_dossier/mon_fichier
J'ai bien le résultat qui s'affiche.

J'ai un accès root.

System:
Gentoo Base System version 1.6.14