OVH Community, votre nouvel espace communautaire.

Problème 500 Internal error


stefde3
21/05/2015, 12h18
Bon trouvé...

c'est le "." de mes headers qui étaient mal placés...

fallait que je les mettent juste avant le "=" et non juste après le "$headers"

J'ai pourtant activer l'affichage des errors mais rien ne s'affichait... curieux le système quand même...

janus57
21/05/2015, 12h18
Bonjour,

et les erreurs côté OVH y a quoi dans les logs ?

Sinon :
Parse error: syntax error, unexpected '=' in CODE on line 15
Errors parsing CODE
Cordialement, janus57

stefde3
21/05/2015, 11h50
Bonjour,

depuis que j'ai repris un domaine en mutualisé sur OVH quoi que je fasse j'ai sans arrêt des error 500 qui s'affichent lors de mes traitements php.

Je passe par du jQuery/Ajax aussi mais même en les désactivant j'ai toujours l'erreur 500 qui s'affiche et je ne comprends pas ce qu'il se passe.

Voici mon code :

Code PHP:

    
if(isset($_POST)){
        
        
$success 'error';
        
        if(!empty(
$_POST['mail']) && !empty($_POST['sujet']) && !empty($_POST['message'])){
        
            
$success 'agree';
            
            
$dest 'stefde3@yahoo.fr';
            
$sujet $_POST['sujet'];
            
$mess 'Message de : ' .$_POST['mail']. ''.$_POST['message'];
            
$headers 'From '.$_POST['mail'] . "\r\n";
            
$headers. = 'Reply-To: ' $_POST['mail'] . "\r\n";
            
$headers. = 'MIME-Version: 1.0' "\r\n";
            
$headers. = 'Content-type: text/html';
            
            
mail($dest$sujet$mess$headers);
            
            
$message 'Votre mail a bien été envoyé. Nous y répondrons sous peu.'
        }
        else
        
$message 'Vous devez remplir tous les champs';
    
    
//echo json_encode([
        //'message' => $message,
        //'success' => $success
    //]);
    
    
}
?>
Je ne vois pas où peut se trouver l'erreur si erreur il y a...

je suis bien en CHMOD 705 pour les transferts.

Merci d'avance