OVH Community, votre nouvel espace communautaire.

Problème de version de PHP en CLI


caBBAlainB
15/05/2015, 15h17
Bonjour,
J'utilise une API reposant sur GuzzleHttp, qui fonctionne très bien en webservice (sur le framework cakePHP3).
Sauf qu'en web, j'utilise php 5.5.28.

Maintenant, je veux utiliser cette même API en CLI. Hors, je n'ai pas trouvé autre chose que php.ORIG.5_4, qui donc, exécute mon script en PHP 5.4.37 avec un Segmentation Fault juste après instanciation de ma première classe et retour de l'instance!

Donc évidemment, comme les quelques premières lignes de code sont exactement les mêmes, la première idée serait de pouvoir utiliser php 5.5.28.

Est-ce possible?

Slts,
Alain