OVH Community, votre nouvel espace communautaire.

Debian 7 IP FailOver, comment configurer ?


MaikoB
19/05/2015, 13h34
Bonjour,

En complément de mon collègue et pour confirmer ce qui a été dit plus haut, voici un exemple de configuration :

Code:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 22.22.22.22
        netmask 255.255.255.0
        network 22.22.22.0
        broadcast 22.22.22.255
        gateway 22.22.22.254
        post-up /sbin/ifconfig eth0:0 33.33.33.14 netmask 255.255.255.255 broadcast 33.33.33.14
        pre-down /sbin/ifconfig eth0:0 down
        post-up /sbin/ifconfig eth0:1 33.33.33.15 netmask 255.255.255.255 broadcast 33.33.33.15
        pre-down /sbin/ifconfig eth0:1 down

iface eth0 inet6 static
        address 2001:43C0:d:7ae::
        netmask 64
        post-up /sbin/ip -family inet6 route add 2001:43C0:d:7ff:ff:ff:ff:ff dev eth0
        post-up /sbin/ip -family inet6 route add default via 2001:43C0:d:7ff:ff:ff:ff:ff
        pre-down /sbin/ip -family inet6 route del default via 2001:43C0:d:7ff:ff:ff:ff:ff
        pre-down /sbin/ip -family inet6 route del 2001:43c0:d:7ff:ff:ff:ff:ff dev eth0
Cordialement,

MatthieuP
18/05/2015, 16h43
Bonjour,

Concernant une seconde interface réseau, celle-ci est uniquement utilisable pour le vrack sur les serveurs de gamme Infrastructure ou HG. Les ip étant routées sur l'interface réseau publique, les ip ne pourront pas être configurées sur la seconde interface (sauf si bloc ripe routé sur le vrack).

Cordialement,

Matthieu P.
OVH Team

Nawsa
15/05/2015, 15h36
C'est bon, ça fonctionne, il m'a fallu redémarrer le serveur. Sinon il ne prend pas en charge les modificartions

Merci pour ton aide

bbr18
15/05/2015, 15h31
au lieu de rajouter eth1, je mettrais plutôt eth0:0

Nowwhat
15/05/2015, 14h26
Mon serveur, un SYS (SoYouStart) ne possède qu'UN NIC, un 'eth0'. Je n'ai pas de eth1 (deuxième NIC).
Je ne dit pas que c'est impossible, t'as un serveur d'OVH après tout, ils ont d'autres options comme par exemple, un deixème NIC. A toi de voir.

Mon /etc/networking/interfaces fonctionne bien. Au démarrage toutes mes IPv4 (4) sont tous activés.
J'ai crée ce fichier après le doc sur Debian.org.

Nawsa
15/05/2015, 14h08
Quand je tape la commande "route", voici ce que j'ai

Code:
server# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         37.187.168.254  0.0.0.0         UG    0      0        0 eth0
37.187.168.0    *               255.255.255.0   U     0      0        0 eth0
37.187.168.0    *               255.255.255.0   U     0      0        0 eth1
149.202.14.0    *               255.255.255.0   U     0      0        0 eth1
Il y'a eth1, donc c'est que j'en ai un non ?

Sinon si j'ai bien compris, ce que tu me demandes de faire, c'est de mettre les up/down dans le eth0 de l'ip 22.22.22.22, c'est ça ?
Et sinon j'ai remarqué que toi tu as pre-down, dois-je changer mes post-down par des pre-down comme toi ?

Nowwhat
15/05/2015, 13h45
T'y est presque.
Je pense que ton serveur ne possède pas deuxième interface 'eth1' - tu n'as qu'un 'eth0'

J'ai ceci dans mon /etc/networking/interfaces:
post-up /sbin/ifconfig eth0:0 46.105.79.xx netmask 255.255.255.255 broadcast 46.105.79.xx
post-up /sbin/ifconfig eth0:1 5.196.43.yy netmask 255.255.255.255 broadcast 5.196.43.yy
post-up /sbin/ifconfig eth0:2 5.196.43.aa netmask 255.255.255.255 broadcast 5.196.43.aa
post-up /sbin/ifconfig eth0:3 87.98.174.bb netmask 255.255.255.255 broadcast 87.98.174.bb

pre-down /sbin/ifconfig eth0:3 down
pre-down /sbin/ifconfig eth0:2 down
pre-down /sbin/ifconfig eth0:1 down
pre-down /sbin/ifconfig eth0:0 down
T'inquiète pour le [warn] ....
Test quand même aussi le redémarrage de ton serveur. Au pire tu gagne un tour avec "rescue mode"

Nawsa
15/05/2015, 12h37
Bonjour,

J'ai un serveur dédié sous debian 7 et j'ai un block d'adresse IP FO

Je cherche à lier les adresses IP FO à mon serveur dédié

Voici ce que j'ai mis dans le fichier

> /etc/network/interfaces
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 22.22.22.22
        netmask 255.255.255.0
        network 22.22.22.0
        broadcast 22.22.22.255
        gateway 22.22.22.254

iface eth0 inet6 static
        address 2001:43C0:d:7ae::
        netmask 64
        post-up /sbin/ip -family inet6 route add 2001:43C0:d:7ff:ff:ff:ff:ff dev eth0
        post-up /sbin/ip -family inet6 route add default via 2001:43C0:d:7ff:ff:ff:ff:ff
        pre-down /sbin/ip -family inet6 route del default via 2001:43C0:d:7ff:ff:ff:ff:ff
        pre-down /sbin/ip -family inet6 route del 2001:43c0:d:7ff:ff:ff:ff:ff dev eth0

# --- Configuration que j'ai moi même ajouté ---
auto eth1
iface eth1 inet static
address 22.22.22.22
netmask 255.255.255.0
broadcast 33.33.33.255
network 33.33.33.0
gateway 33.33.33.254
post-up /sbin/ifconfig eth1:0 33.33.33.14 netmask 255.255.255.255 broadcast 33.33.33.14
post-down /sbin/ifconfig eth1:0 down
post-up /sbin/ifconfig eth1:1 33.33.33.15 netmask 255.255.255.255 broadcast 33.33.33.15
post-down /sbin/ifconfig eth1:1 down
NB:
- 22.22.22.22 est l'adresse ip de mon serveur ( que j'ai changé par ce faux nombre )
- 33.33.33.0/24 est le block d'adresse ip de mon serveur ( que j'ai changé par ce faux nombre )

Quand je tape la commande pour reset, voici les erreurs que j'obtient

Code:
root@ns345820:/# /etc/init.d/networking restart
[warn] Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces ... (warning).
[....] Reconfiguring network interfaces...RTNETLINK answers: File exists
Failed to bring up eth0.
RTNETLINK answers: File exists
Failed to bring up eth1.
RTNETLINK answers: File exists
RTNETLINK answers: File exists
done.
Quand je ping 33.33.33.14 ou 33.33.33.15, aucun résultat

On voit que même le eth0 a des erreurs...
Donc le fichier de base, avant même que je le modifie est bugué
Comment corriger ça ?

Et est t'il possible de lier automatiquement l'ensemble du block 33.33.33.0/24 au lieu de le faire IP par IP ?

Je vous remercie pour votre aide. (en dehors de mon modem internet, que je touche pour ouvrir des ports, je vous avoue que c'est la première fois que je fais du réseau, donc si vous avez l'impression que je fais n'importe quoi, c'est normal ^^')