OVH Community, votre nouvel espace communautaire.

Site visible sur mozilla et pas sur IE


visualight
15/11/2006, 17h37
Citation Envoyé par Elised
Ben, le problème c'est qu'il n'y a personne dans mon entourage qui s'y connaisse
Je veux bien t'aider bénévolement pour le faire si tu veux.
Contacte moi par mail (clique ici) afin de me donner de plus amples informations quant au contenu, mise en page, ...

Dès lors où ton problème sera réglé, n'oublie pas de clôturer cette discution par l'apposition de l'image "Réglé".

Merci d'avance c'est cool

@+

MacRicow
14/11/2006, 22h43
Bonjour,

J'embraye sur un autre bug z-index d'IE que celui dont vous parlez (genre celui-ci).

J'ai trouvé un bug qui fait que le z-index est visuellement respecté, mais pas fonctionnellement!!! Exemple (constaté sur IE uniquement). Quelques liens sur la droite fonctionnent, mais pas les autres. En cliquant droit, vous observerez que l'image de fond est bien affichée en fond, mais qu'en revanche, elle passe de façon invisible par-dessus les liens.

Le code CSS est validé, de même que le code HTML)...

Aucun problème sous Mozilla, Safari, Opéra, iCab sur Mac... Seul IE sur Mac comme Windows, y compris IE 7, (et donc les navigateurs basés sur cette m*%£§ d'IE) semblent poser problème à l'interprétation. Je ne comprends pas vraiment l'origine de ce bug malgré quelques heures passées à tout changer, modifier les ordres, etc... Si quelqu'un a une idée...

J'ai trouvé un moyen partiel de résoudre le problème en dégradant la page pour IE (modification apportée uniquement sur IE).

Merci par avance et amusez-vous!

MacRicow

P.S. : je suis intéressé par être contacté par toute personne qui souhaiterait attaquer Microsoft en justice de même que par toute démonstration de bug d'Internet Explorer (depuis version 5) à des fins de collection. Le non respect par Microsoft des standards du W3C qu'il participe à établir en participant à ce consortium peut tout à fait être entendu comme un délit (anti-concurrence, abus de position dominante, etc...). Soit c'est de l'incompétence, auquel cas j'aimerais que la justice puisse imposer la publication de cette incompétence, soit c'est de l'obstruction, auquel cas je souhaiterais que l'entreprise soit contrainte de corriger ses navigateurs, y compris dans sa version 6, voire 5, de telle sorte à ce que nous autres développeurs n'ayions plus à subir le diktat de cette entreprise adepte de la médiocrité.

amadeus
25/09/2006, 17h06
Citation Envoyé par Elised
Ben, le problème c'est qu'il n'y a personne dans mon entourage qui s'y connaisse
C'est un site pro non ?
Dans ce cas il est possible de faire appel à quelqu'un qui install un logiciel pour tout ca, vous explique le minimum pour la mise en route et le tout en reprenant le graphisme actuel.
Si ca vous intéresse contactez moi par mail que l'on en discute .

Sinon dans tous les cas il faut reprendre le graphisme et le code "proprement" mais ca nécessite un minimum de connaissance .

Bon courage,

Yggdrasil
25/09/2006, 13h55
Citation Envoyé par Elised
Comment je fais pour redimensionner les 2 blocs ?
Arf ... ... en les déplaçants ... et en en changeant la taille ...

Il existe sur le marché différent CMS : logiciel de gestion de contenu. L'avantage de ces solutions est que, si la mise en place est un peu plus ardue ... l'utilisation par contre ne nécéssite l'usage d'aucun autre logiciel, ni même de connaissance informatique particulières pour créer ses pages ...

Exemple de CMS (Gratuit ): Joomla, SPIP, Mambo, ...

Cela demande un petit investissement en temps au début ... vite regagné par la suite ...

Si ton offre ne contient pas de support pour mysql, il y a même GuppY : petit cms sympa, facile à mettre en place ... ne nécéssitant pas de base de données ...

Elised
25/09/2006, 13h46
Citation Envoyé par amadeus
Heu honnetement, tu trouves quelqu'un qui s'y connait un peu dans ton entourage et qui t'aide à faire un petit site sympa avec un outil genre spip.
Bon courage
Ben, le problème c'est qu'il n'y a personne dans mon entourage qui s'y connaisse

Elised
25/09/2006, 13h45
Citation Envoyé par Yggdrasil
J'ai peut-être une piste :

- Le problème viens vraisemblement de l'usage dez z-index : suite à un problème d'interprétation des z-index (IE à aussi ses bugs ... mais ils sont reconnus eux au moins ... ) le bloc "Pour visiter le site cliquez" viens se mettre par dessus le bloc contenant le liens (celui contenant la balise
Pour tester il faudrait décaler/redimentionner les deux blocs afin qu'ils ne se chevauchent plus ...
Comment je fais pour redimensionner les 2 blocs ?

amadeus
25/09/2006, 13h44
Heu honnetement, tu trouves quelqu'un qui s'y connait un peu dans ton entourage et qui t'aide à faire un petit site sympa avec un outil genre spip.
Bon courage

Yggdrasil
25/09/2006, 13h44
Je ne connais pas office publisher ...

... mais il devrait y avoir moyen de déplacer/redimentionner le bloc contenant le texte "Pour visiter le site cliquer" afin qu'il ne chevauche plus le bloc contenant le lien vers le site (
).

De cette manière le lien sera accèssible tant par l'un que par l'autre ...

Elised
25/09/2006, 13h39
J'ai fait le site avec Office Publisher et suis totalement novice en informatique, ce qui fait que je tombe dans tous les panneaux !
Au secours, comment je fais le changement ?

Yggdrasil
25/09/2006, 13h33
Citation Envoyé par oInOt
a mon avis ça pue le beau code pourri pondu par Word !!!
C'est quand même fort que le code pondu par microsoft ne marche pas sous microsoft et bien sur d'autres navigateurs (Firefox et Opera)
C'est ausi fort que Fire(bug)Fox soit la seule application à, sporadiquement, de manière inexpliquée à ce jour (ce depuis 4 ans) ... ne pas être capable de gérer un méchanisme aussi basique que le copy/paste ...

- Non je n'ai pas les spyware dont certains sites parlent !
- Oui j'ai la dernière version censée corriger ce bug --> Depuis même avec la souris le fonctionnement du clipboard est erratique ...

... j'ai remplacé FF par IE comme browser principale ce matin ... marre de perdre des copies/de coller des contenus vieux de plusieurs heures ...

[Désolé pour le HS ... mais la caraffe est pleine ...]

oInOt
25/09/2006, 13h24
a mon avis ça pue le beau code pourri pondu par Word !!!
C'est quand même fort que le code pondu par microsoft ne marche pas sous microsoft et bien sur d'autres navigateurs (Firefox et Opera)

Yggdrasil
25/09/2006, 13h23
J'ai peut-être une piste :

- Le problème viens vraisemblement de l'usage dez z-index : suite à un problème d'interprétation des z-index (IE à aussi ses bugs ... mais ils sont reconnus eux au moins ... ) le bloc "Pour visiter le site cliquez" viens se mettre par dessus le bloc contenant le liens (celui contenant la balise

Pour tester il faudrait décaler/redimentionner les deux blocs afin qu'ils ne se chevauchent plus ...

Yggdrasil
25/09/2006, 13h03
... éviter d'utiliser des extentions spécifiques à Fire(bug)Fox ...

Je n'ai jamais vu ce genre de code : quel logiciel à été utilisé pour générer cette page ?

Elised
25/09/2006, 12h49
Voilà,

Je viens de mettre un site en ligne:
http://www.massagepourbebe.org
Il est visible sur mozilla mais pas sur internet explorer.
Comment je peux modifier ça ?

Merci